FTS Index with two nodes give diferent results VS one node


#1

Hi, I been working with Couchbase 5.1, using an enviroment with two nodes for full-text and indexes; and I´m trying to create a FTS Index with no replica.

My problem is when I created my index, one node stock in 50,1% index progress, and the second node stock in 49,9%. I assume this is because the FTS balancing, but this is the tricky part when a search using any of my nodes my search fails, but if I create the same index in another enviroment with only one node (having 100% index progress) my search works perfect.

Enviroment 1 ( two nodes):
node 1:


node 2:

What am I doing wrong?
is it possible to define a Full Text index only in one of my nodes?

FTS INDEX definition:

{
“type”: “fulltext-index”,
“name”: “real-estates”,
“uuid”: “52ddf9ef1bc5f704”,
“sourceType”: “couchbase”,
“sourceName”: “CONTENT”,
“sourceUUID”: “2f07eb016e46883ed2fddca498e206c8”,
“planParams”: {
“maxPartitionsPerPIndex”: 171
},
“params”: {
“doc_config”: {
“mode”: “type_field”,
“type_field”: “main.type”
},
“mapping”: {
“default_analyzer”: “standard”,
“default_datetime_parser”: “dateTimeOptional”,
“default_field”: “_all”,
“default_mapping”: {
“dynamic”: true,
“enabled”: false
},
“default_type”: “_default”,
“index_dynamic”: true,
“store_dynamic”: false,
“types”: {
“real-estate”: {
“dynamic”: false,
“enabled”: true,
“properties”: {
“main”: {
“dynamic”: false,
“enabled”: true,
“properties”: {
“address”: {
“dynamic”: false,
“enabled”: true,
“properties”: {
“locations”: {
“dynamic”: false,
“enabled”: true,
“properties”: {
“ref”: {
“dynamic”: false,
“enabled”: true,
“fields”: [
{
“analyzer”: “”,
“include_in_all”: true,
“include_term_vectors”: true,
“index”: true,
“name”: “ref”,
“store”: false,
“type”: “text”
}
]
}
}
}
}
},
“familyType”: {
“dynamic”: false,
“enabled”: true,
“fields”: [
{
“analyzer”: “”,
“include_in_all”: true,
“include_term_vectors”: true,
“index”: true,
“name”: “familyType”,
“store”: false,
“type”: “text”
}
]
},
“operationType”: {
“dynamic”: false,
“enabled”: true,
“fields”: [
{
“analyzer”: “”,
“include_in_all”: true,
“include_term_vectors”: true,
“index”: true,
“name”: “operationType”,
“store”: false,
“type”: “text”
}
]
},
“status”: {
“dynamic”: false,
“enabled”: true,
“fields”: [
{
“analyzer”: “”,
“include_in_all”: true,
“include_term_vectors”: true,
“index”: true,
“name”: “status”,
“store”: false,
“type”: “text”
}
]
},
“type”: {
“dynamic”: false,
“enabled”: true,
“fields”: [
{
“analyzer”: “”,
“include_in_all”: true,
“include_term_vectors”: true,
“index”: true,
“name”: “type”,
“store”: false,
“type”: “text”
}
]
}
}
}
}
}
}
},
“store”: {
“kvStoreName”: “mossStore”
}
},
“sourceParams”: {}
}


#2

Do anyone have an answer or a hint to give me? Please


#3

UPDATE: I’m using JAVA SDK to connect my application to my couchbase and when I do a Full Text Search only gives me the results of one node, not both nodes.