Getting error: ‘Pooled socket is dead. Continuing to next one’

I am getting ‘Pooled socket is dead’ error after installing Couchbase Server Enterprise 6.6.1… Below is the detail of the error message. I am stuck for days now. Any help please?

[error] 17518#17518: *7703 FastCGI sent in stderr: "PHP message: [cb,WARN] (lcbio_mgr L:483 I:3887268011) <localhost:8093> (HE=0x56542f856a50) Pooled socket is dead. Continuing to next one" while reading response header from upstream, client: xxxxxxxxxxxxxxxx........

I’ve thought of firewall issue and tried disabling firewall, enabling ports in firewall and none worked…

I am getting this error while trying to make a N1QL query. I am successful in getting cluster connection. But it is failed when I am trying to execute the query. Here is the code I am using for cluster connection-

$connectionString = "couchbase://localhost";
$options          = new \Couchbase\ClusterOptions();
$options->credentials('USERNAME', 'PASSWORD');
$cluster = new \Couchbase\Cluster($connectionString, $options);

new \Couchbase\QueryOptions();
$cluster->query($query, $options);

Hello @comet what is the version of PHP SDK that you are using and what is your query looking like ? the N1QL query code example doesn’t give the full picture. I also verified and dont see any open issues related to “Pooled Socket is dead”. Can you provide more information so that someone will be able to help !

Hello @AV25242 , sorry for the late reply. I am using PHP SDK 3.1, the latest one. I am actually getting this error for all couchbase communications. I mean whenever I am trying to make a N1QL query or sub document operation using sdk, I am getting this error. However, I am able to get data from couchbase but the error is there always. What more information do you need please tell me.
Thanks for the reply.

Not a problem. Which CB version are you using and is your application onpremise ? And are you saying this is an annoyance over an actual error ? in the sense unnecessary noise ?

1 Like

CB version is 6.6.1. Nope this is in development stage… We have a community version which is working fine, but this EE version seems to be slower. As everything is working fine except that error in the log, I will skip this then. Thanks for the help!

1 Like

@comet thanks for the response, I will take it back to the team and see the reasoning behind this message being published and if there is a possibility of suppressing it !

1 Like