Getting error with installing Couchbase's PHP SDK on Mac 10.113.4


#1

While trying to install couchbase’s php sdk, I am getting this error Error: No available formula with the name "homebrew/php/php70-couchbase". I am following this link https://developer.couchbase.com/documentation/server/current/sdk/php/start-using-sdk.html. brew update and then brew install libcouchbase is working fine but when I run the command brew install homebrew/php/php70-couchbase I am getting that error. I have tried with php 5.6, 7.0.x, 7.1.x and 7.2.x, and none did work. My Mac is 10.13.14 High Sierra. What is the wrong I am doing?


#2

Seems like homebrew project has changed their infrastructure

could you try just run?

pecl install couchbase

#3

Try a

brew update

and then

brew search couchbase

to see what is available on your system


#4

Just libcouchbase is found… and the other message is caskroom/cask/couchbase-server-community caskroom/cask/couchbase-server-enterprise ==> Searching blacklisted, migrated and deleted formulae...


#5

Does php from homebrew install pecl executable? If so you can just install the extension from the main repository on pecl.php.net:

pecl install couchbase

#6

I did try installing with pecl command and didn’t work last times… What!!! Now it worked!!! After 3 days! Thanks a lot!!! I think last time I messed up by installing too many php versions! It worked at last. Thanks again!


#7

Depends on how PHP was installed. If you used brew to install PHP you can (or used to) be able to specify --with-pear to include that as well.

Otherwise PECL and PEAR are separate installs.


#8

Yes, I did install php with homebrew. Thanks for the help!


#9

You are welcome. For the next PHP extension release I will revisit guides and update with current steps. Thanks for bringing this


#10

Loved to hear that I could be of some help for the Couchbase!