Help~couchbase Lite gets exception information

.net

#1

I use the iOS App development of the xamarin in the open synchronization to get the following information.

2015-10-29 02:51:49.233 iAnesthesiaClinic_HuaXi[9873:413374] push: Active
2015-10-29 02:51:49.240 iAnesthesiaClinic_HuaXi[9873:413374] Pull: Active
Thread started: Change Tracker Thread #11
2015-10-29 02:51:49.296 iAnesthesiaClinic_HuaXi[9873:413374] push: Idle
2015-10-29 02:51:49.317 iAnesthesiaClinic_HuaXi[9873:413516] ChangeTracker
2015-10-29 02:51:49.318 iAnesthesiaClinic_HuaXi[9873:413516]
2015-10-29 02:51:49.318 iAnesthesiaClinic_HuaXi[9873:413516] Change tracker got error with status code: NotFound
2015-10-29 02:51:49.324 iAnesthesiaClinic_HuaXi[9873:413513] Puller
2015-10-29 02:51:49.324 iAnesthesiaClinic_HuaXi[9873:413513]
2015-10-29 02:51:49.324 iAnesthesiaClinic_HuaXi[9873:413513] Change tracker stopped during continuous replication
Thread finished: Change Tracker Thread #11
2015-10-29 02:51:49.327 iAnesthesiaClinic_HuaXi[9873:413513] Replication: Progress: set error =
2015-10-29 02:51:49.327 iAnesthesiaClinic_HuaXi[9873:413513]
2015-10-29 02:51:49.327 iAnesthesiaClinic_HuaXi[9873:413513] System.Exception: Change tracker stopped during continuous replication
2015-10-29 02:51:49.328 iAnesthesiaClinic_HuaXi[9873:413374] Pull: Active
2015-10-29 02:51:49.330 iAnesthesiaClinic_HuaXi[9873:413374] Pull: Idle

I am a novice for CouchBase, hoping to get help.


#2

Well at first glance it looks like the URL you set to replicate from is not valid. What happens if you open the exact URL you gave when you created the replication in a browser?


#3

Oh, my God, is Not found.Thank you for reminding~
This is why?
Is there any problem with my Sync
Gateway configuration

{

    	"log": ["*"],
    	"databases": {
    		"grocery-sync": {
    			"server": "http://localhost:8091",
                        "bucket": "grocery-sync",
    			"users": {
    				"GUEST": {"disabled": false, "admin_channels": ["*"] }
    			}
    		}
    	}
    }

#4

Well what URL are you trying to use to access Sync Gateway?


#5

In my App is accessed by http://10.10.2.105:8091/grocery-sync
I wrote it in the case of an example.


#6

That is the URL for Couchbase Server, not Sync Gateway. Your Sync Gateway URL will be exposed on port 4984, so if they are on the same machine it will be http://10.10.2.105:4984/grocery-sync


#7

You are right,~~I just tried to use the 4984 port, you can access, but the data is not synchronized, this is why?pull and push not work:

Thread started: #8
Thread started: #9
Thread started: #10
2015-10-29 13:04:23.019 iAnesthesiaClinic_HuaXi[10254:530403] push: Active
2015-10-29 13:04:23.026 iAnesthesiaClinic_HuaXi[10254:530403] Pull: Active
Thread started: Change Tracker Thread #11
2015-10-29 13:04:23.069 iAnesthesiaClinic_HuaXi[10254:530403] push: Idle

sync gateway:


#8

Forget to say, I’ve changed another bucket gamesim-sample


#9

You will need to show the code you are using. The logs you have shown show a pull replication succeeding on an empty sync gateway bucket.

Existing data in Couchbase Server will not be replicated. Only data created through Sync Gateway.


#10

I
seem to understand that you mean that I need to use gateway sync to
create the data I need, and then to implement the synchronization, and
not directly use the existing bucket, right?


#11

Yes. There are ways of importing an existing Couchbase Server bucket into a usable Sync Gateway backing bucket, but I’m not familiar with them. @adamf or some others will be able to tell you in more detail, but in the end Couchbase Server data is just raw data, but Sync Gateway also needs special metadata to function and recognize documents.


#12

I if this configuration gateway sync, is the establishment of the sync gateway bucket?

{
“interface”: “localhost:4984”,
“adminInterface”: “localhost:4985”,
“log”: [ “REST” ],
“databases”: {
“rimshx”: {
“server”: “http://localhost:8091”,
“bucket”: “xxxx_mobile”,
“shadow”: {
“server”: “http://localhost:8091”,
“bucket”: “xxxx”,
},
“users”: {
“GUEST”: {“disabled”: false, “admin_channels”: ["*"] }
}
}
}
}


#13

Thank you very much! You are great to me.