High CPU usage of couchbase server

#1

We are using the 4.0.0-4051 version of Couchbase server on our linux systems and have been observing constant high CPU usage on them. I have a LinuxMint OS where I run it locally and I see the same too. There are no clients connected to the couchbase server and the server just has the sample beer buckets within it. This high CPU usage over a period of time leads to heating up the CPU which then triggers the machine to shutdown,

Here’s the output of one of the ps commands from my system:

ps -eo pcpu,pid,user,args | sort -k 1 -r | head -10

20.9 1885 couchba+ /opt/couchbase/lib/erlang/erts-5.10.4.0.0.1/bin/beam.smp -A 16 -sbt u -P 327680 -K true -swt low -MMmcs 30 -e102400 -- -root /opt/couchbase/lib/erlang -progname erl -- -home /opt/couchbase -- -smp enable -setcookie nocookie -kernel inet_dist_listen_min 21100 inet_dist_listen_max 21299 error_logger false -sasl sasl_error_logger false -nouser -run child_erlang child_start ns_bootstrap -- -smp enable -couch_ini /opt/couchbase/etc/couchdb/default.ini /opt/couchbase/etc/couchdb/default.d/capi.ini /opt/couchbase/etc/couchdb/default.d/geocouch.ini /opt/couchbase/etc/couchdb/local.ini

Is this a known issue? Or is there a way I can get more information on this to see how to solve this?

1 Like
#2

Hi Jaikiran,

are you using XDCR v1, which is the CAPI based XDCR?

There is a known issue that some users have reported, these days it’s pretty much just people using the Elasticsearch plugin.

Fixed in 4.1.0:
https://issues.couchbase.com/browse/MB-16244
Fixed in 4.1.1:
https://issues.couchbase.com/browse/MB-17483
There’s one more issue reported where we couldn’t reproduce the high CPU, just the high mem which is fixed in MB-17483.
https://issues.couchbase.com/browse/MB-17287

Best,
-Will

#3

Hi Will,

The installation we have is a single server and XDCR isn’t enabled on this:

are you using XDCR v1, which is the CAPI based XDCR?

Do you know if that plays a role when there’s no XDCR enabled in a single node installation?

#4

No, if it’s not enabled you won’t encounter this. It was a wild guess but wrong. I suggest you check your logs. There’s a good troubleshooting section in the docs here:
http://developer.couchbase.com/documentation/server/4.0/troubleshooting/troubleshooting-intro.html

There are three sub-pages (it might not be obvious at first glance - look to the left hand nav): Common errors, general tips, and system logs. Hopefully that helps, and if you do see anything odd in the logs, you can post it back here.