How do I configure kv timeout using the PHP sdk?

I need to increase the general timeout for accessing key/value documents

How can I do this in PHP?

also, is there any settings for the number of retries?

I receive in logs messages like Orphan responses observed. What may be the cause?

PHP message: [cb,WARN] (tracer L:147 I:1243402330) Orphan responses observed: {“count”:1,“service”:“kv”,“top”:[{“last_local_address”:“IP_REDACTED:38570”,“last_local_id”:“4f42c7264a1cd05a/7a8ad96d3e2d780e”,“last_operation_id”:“0x2cad”,“last_remote_address”:“SERVER_HOSTNAME_REDACTED:11210”,“operation_name”:“get”,“server_us”:0,“total_us”:2500517}]}

If I will increase the general timeout would these messages disappear?

not sure if you were talking about SDK 3.0

I found this example from documentation.
I am unsure if this fixes your messages

$opts = new GetOptions();
$opts->timeout(3000 /* milliseconds */);
$res = $collection->get(“document-key”, $opts);

Thanks, @AV25242 ,

but I was looking for something global, not per operation.

I have found this in the doc (for Ruby SDK)

https://docs.couchbase.com/ruby-sdk/current/ref/client-settings.html

but for some reason doesn’t seem to work on PHP.

The documentation in the PHP is super basic and it does not seem to cover this part.

I started another thread about this here: https://forums.couchbase.com/t/lcb-err-unsupported-operation-214/27835 but I haven’t received an answer yet.