How to enable N1QL Query Service on an upgraded Couchbase 4.0 Setup

n1ql

#1

We have upgraded our Couchbase 3 to Couchbase 4.0. How do we enable N1QL Query Service via the Web Console or any other means.

Whenever, we start the N1QL Shell, it gives an error ERROR 100 : Unable to connect to query service http://localhost:8093/

How do we go about this issue ?


#2

Can you try restarting your cluster? The query service should be enabled by default.