Improper handling of appended list

#1

I have a manged list of JSON documents. This is managed with append and does not generate a valid JSON document, but one that is easily created by trim any leading or trailing comma and wrapping the list in an []

For example:

{“a”:“A”},
{“c”:“B”},
{“c”:“C”},

When the .NET client retrieve this document, with:

IDocumentResult result = bucket.GetDocument(key);

It actually returns only the first element ({“a”:“A”}). This is incorrect behavior, as it should be an error.

IDocumentResult result = bucket.GetDocument(key);
works as expected (gets entire text which we can manage in code).

Thanks - H

#2

Hi @unhuman -

I am not sure I am following here, perhaps there is some missing code you can add?

-Jeff

#3

Interestingly doing it as I illustrated works fine. But, I have a particular document that fails in my test client, but then worked in some very simple code I wrote out…

But, the same document appears to break the Couchbase Web UI (documents tab)…

Sorry for the confusion. I’ll message you the document separately (and create a support ticket).

-H

#4

Is this what we are talking about?

lists that are not encapsulated in json seem to break the UI even though it kinda is valid json, its just a UI problem, your code is fine. Its an annoying problem as you can view, but cant modify the document directly in the ui (will give a format error) but not a show stopper

i.e. the key document is the same. you cannot modify it , it will give the same format error (or at least last I tried)

#5

Not entirely. The entire documents tab breaks when that document is on the page. Not just viewing the document itself (which gives binary response).

The problem I’m seeing (in one place and I need to understand why) is that if I query that key for the document (by type) that it gives me back the first item in the list. That’s bad. If I query by , I get the text of the list as expected.