Inappropriate version check with Couchbase 4.0 DP

40-preview
#1

I just downloaded Couchbase 4.0 DP to give it a try. I’m running on MacOS 10.10. When I launch the Couchbase app, the first thing that appears is a version check:

A new version of Couchbase Server is available!
Couchbase Server 3.0.2 is now available - you have  . Would you like to download it now?

Presumably 3.0.2 is not an upgrade from 4.0…

#2

P.s. I think this may have been caused by me not sufficiently removing the files from the previous installation. It didn’t occur on subsequent launches, in any case.