Inconsistent results with 'reduce' in sync gateway view query


#1

I know reduce didn’t work in views in sync gateway 1.5, and I assume that’s still the case with sync gateway 2.0. However, with 2.0 I get inconsistent results if I pass in a ‘reduce=false’ query parameter vs no reduce parameter at all. If I pass in ‘reduce=false’, the query returns deleted documents. If I pass in no reduce parameter at all, deleted documents are excluded from the results. Also, passing in ‘reduce=true’ provides yet another variation of results, returning rows=null.

Not a big deal, we can modify our code to remove the reduce parameter, but it is apparently a bug introduced in 2.0.


#2

Actually it looks like the difference is worse than I thought. Without the ‘reduce=false’ parameter, I’m not seeing any results from my query. So, the question is, how can I query and exclude deleted documents?


#3

Never mind this whole post. I think my problem has to do with stale views. I will post again if it turns out there is an actual problem here.