Indexer restarts every five seconds

#1

I use Version: 4.0.0-4051 Community Edition (build-4051) on CentOS 6 (from RPM). With one empty bucket, I get following error every five minutes (and also /opt/couchbase/var/lib/couchbase/data/@2i seems to be growing with no data in any bucket and no traffic).

Error is:
Service ‘indexer’ exited with status 1. Restarting. Messages: github.com/couchbase/indexing/secondary/indexer.(*indexer).listenAdminMsgs(0xc208054280)
/home/couchbase/jenkins/workspace/sherlock-unix/goproj/src/github.com/couchbase/indexing/secondary/indexer/indexer.go:431 +0x320
created by github.com/couchbase/indexing/secondary/indexer.(*indexer).run
/home/couchbase/jenkins/workspace/sherlock-unix/goproj/src/github.com/couchbase/indexing/secondary/indexer/indexer.go:393 +0x5d
[goport] 2015/12/15 01:23:57 /opt/couchbase/bin/indexer terminated: exit status 2

Would have created the issue in JIRA but seems that forum credentials don’t work there.

#2

Could you check and make sure what you have specified under “Settings > Index RAM quota” is set to a value lower than total free RAM available on the node that is experiencing the crash?

#3

Free memory over 3 gigabytes, data RAM quota 1600 MB and index RAM quota 400 MB.

#4

would you mind lowering the index ram quota 256. I wanted to see if we can eliminate the failures with this default setting.
thanks
-cihan

#5

I have the same log error and decrease the index ram quota to 265 mb
but with no effect

#6

Changed to 256 MB, no change, still same error.

#7

Could you share the indexer.log?
thanks

#8

It seems to be 24 MB currently, where do you want me to post it? Or does some amount of tail (few thousand rows) be enough?

#9

if you can share the full view, it will help. I am at cihan@couchbase.com if you’d like to privately send that over.

#10

Apologies for the late response.
Looks like you have another app taking over port 9102 on the node indexer is running. Could you free up that port for indexer?

2015-12-23T14:14:31.146Z+02:00 [Fatal] indexer:: Error Starting Http Server: listen tcp :9102: bind: address already in use
panic: listen tcp :9102: bind: address already in use

thanks
-cihan

#11

It’s standardized port for bacula. So no.

1 Like