Installation error: "useradd command has been disabled because this system is connected to an LDAP server"


#1

Hi.
I’m installing Couchbase on Ubuntu 16.04 on a cluster I have access to using an LDAP account.
During the installation (apt-get install couchbase-server-community) I got the following error:

Error: useradd command has been disabled because this system is connected to an LDAP server.

I googled the error, and weirdly enough, the error has never been reported before. Only returned official page was: https://developer.couchbase.com/documentation/server/current/security/security-ldap-new.html, but it doesn’t seem to be relevant.

How to solve/get around this error? the current cluster I have access to is my only option to run Couchbase.

Full message:

Fetched 337 kB in 1s (257 kB/s)
Reading package lists… Done
hduser@akswnc5:/tmp$ sudo apt-get install couchbase-
couchbase-release couchbase-server couchbase-server-community
hduser@akswnc5:/tmp$ sudo apt-get install couchbase-server-community
Reading package lists… Done
Building dependency tree
Reading state information… Done
The following NEW packages will be installed:
couchbase-server-community
0 upgraded, 1 newly installed, 0 to remove and 35 not upgraded.
Need to get 96,9 MB of archives.
After this operation, 308 MB of additional disk space will be used.
Get:1 htt://packages.couchbase.com/releases/couchbase-server/community/deb xenial/xenial/main amd64 couchbase-server-community amd64 5.0.0-3519-1 [96,9 MB]
Fetched 96,9 MB in 19s (5.051 kB/s)
Selecting previously unselected package couchbase-server-community.
(Reading database … 251092 files and directories currently installed.)
Preparing to unpack …/couchbase-server-community_5.0.0-3519-1_amd64.deb …
Warning: Transparent hugepages looks to be active and should not be.
Please look at https://developer.couchbase.com/documentation/server/current/install/thp-disable.html as for how to PERMANENTLY alter this setting.
Warning: Swappiness is not set to 0.
Please look at htts://developer.couchbase.com/documentation/server/current/install/install-swap-space.html as for how to PERMANENTLY alter this setting.
Minimum RAM required : 4 GB
System RAM configured : 251.89 GB
Minimum number of processors required : 4 cores
Number of processors on the system : 64 cores
Error: useradd command has been disabled because this system is connected
to an LDAP server.
dpkg: error processing archive /var/cache/apt/archives/couchbase-server-community_5.0.0-3519-1_amd64.deb (–unpack):
subprocess new pre-installation script returned error exit status 1
Errors were encountered while processing:
/var/cache/apt/archives/couchbase-server-community_5.0.0-3519-1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)


#2

Hi @mnmami,

This may be a documentation issue, but I’m not sure. I created a ticket that you can track: https://issues.couchbase.com/browse/MB-30212


#3

Thanks @matthew.groves for acting upon this.

If there is a doubt about the possibility to create users on the system, then I would like to add that I had installed before in the same Ubuntu system other databases like Cassanda, MongoDB and MySQL, and they all created users and are functioning normally.


#4

I can’t speak to how the other database installers work. If useradd doesn’t work for Couchbase, I don’t see how it would work for other installers.

But per the comments in the issue, you might try a non-root, non-sudo installation and see if that works: https://developer.couchbase.com/documentation/server/current/install/ubuntu-debian-install.html