Installing Couchbase Lite with Cocoapods in a framework


Hey guys I saw this post:
Trying to build a Cocoapod for iOS and Couchbase Lite

And now I’m having the same problem, has there been any fix yet?
I can install it manually with the same steps as the guy in the comments, but I would really like to be able to install it adding it as a dependency to my Podfile.

Trying to build a Cocoapod for iOS and Couchbase Lite

I don’t think that importing Couchbase Lite 1.x as a framework (or in a framework) has ever been possible because it is a static library. The demo project on the original thread compiles but it doesn’t try to use the CBL API. I just posted an update on the original thread.

It should be possible with Couchbase Lite 2.0 though ( because the library is shipped as a dynamic framework.


Jamiltz, you have no idea how many headaches you’ve saved me. It finally
works! I don’t know how I didn’t find it before, but thank you so much for
your help and your time!

Kind regards and best of wishes,
Ángel Ávila


I’m sorry, just one more question, is this version of Couchbase installable
by Cocoapods?


It’s not on the Cocoapods site yet as it in early developer preview. But you can pull it in directly from the repo:

pod 'CouchbaseLite', :git => '', :tag => '2.0DB1', :submodules => true

Note that 2.0 is currently in early developer preview (iOS only) and not all features are in this build (developer build 1). The details are in the docs linked above. That being said, it’s worth giving it a try to see if it works for you. We will also add this pod line in the developer preview docs.