Installing on CentOS 5.x


#1

That should have read “I’m trying to install Couchbase on Centos 5.x…”!


#2

Hi folks,

I’m trying to install centos on Centos 5.x, and I’m getting the following errors:

error: Failed dependencies: libc.so.6(GLIBC_2.7)(64bit) is needed by couchbase-server-2.5.1-1083.x86_64 libcrypto.so.10()(64bit) is needed by couchbase-server-2.5.1-1083.x86_64 libreadline.so.6()(64bit) is needed by couchbase-server-2.5.1-1083.x86_64 libssl.so.10()(64bit) is needed by couchbase-server-2.5.1-1083.x86_64 libstdc++.so.6(GLIBCXX_3.4.10)(64bit) is needed by couchbase-server-2.5.1-1083.x86_64 libstdc++.so.6(GLIBCXX_3.4.11)(64bit) is needed by couchbase-server-2.5.1-1083.x86_64 libstdc++.so.6(GLIBCXX_3.4.9)(64bit) is needed by couchbase-server-2.5.1-1083.x86_64 libtinfo.so.5()(64bit) is needed by couchbase-server-2.5.1-1083.x86_64 openssl >= 1.0.0 is needed by couchbase-server-2.5.1-1083.x86_64 rpmlib(FileDigests) <= 4.6.0-1 is needed by couchbase-server-2.5.1-1083.x86_64 rpmlib(PayloadIsXz) <= 5.2-1 is needed by couchbase-server-2.5.1-1083.x86_64

The getting started guide at http://docs.couchbase.com/couchbase-manual-2.5/cb-install/#supported-platforms states that Centos 5.x is supported. Is that still the case? I’ve tried Centos 5.6, 5.8, and 5.10

Thanks

Martin Harris


#3

For RHEL/CentOS 5.X we have a different build package that has a different openssl dependency.

You appear to have the RHEL/CentOS 6.x RPM, not the 5.X one.

E.g. the enterprise 5.X package is named -> couchbase-server-enterprise_2.5.1_x86_openssl098.rpm

Jim