Is 1.2 breaking compatibility with CouchDB?


#1

Hi,

I have an issue with json parsing of the changes feed with CouchBaseLite 1.2 on iOS.

WARNING: JSON error parsing _changes feed: lexical error: invalid char in son text

And I don’t get changes callbacks. The server to which is CouchDB 1.6. Is CouchBaseLite 1.2 still supposed to be compatible with CouchDB for synchronization purposes?

I reverted to 1.1 in the meantime since 1.2 is unusable for my use case.

Please help, I need to get this project out on the AppStore asap.

Thank you,
Francois