Is couchbase 3 backwards compatible with 2.2?


#1

Hi,

Is it safe to replace couchbase 3.0 with couchbase 2.2 ? I am using .Net framework to access the database. I do not want to break my current setup.

Thanks.

PP


#2

Generally, yes. It’s intended to do a rebalance upgrade from 2.2 to 3.0!

As with any updated/new piece of software, you should check the release notes for any known issues that may be not so good for your specific deployment. You should also test your upgrade if possible, as downgrades are not supported.

Keep in mind, as of this writing there is no GA release for Windows, but that’ll change soon.