Issue cbbackup/cbrestore Windows to Debian


I want to migrate all the data in my buckets from the couchbase server EE 5.10 windows to a new couchbase server CE 6.6.0 Debian 10. The two couchbases being on different remote machines.

I run this command on couchbase windows:

 cbbackup ./ -u USER -p MDP 

I get all the data, then,I create the buckets on Debian.

I copy the files to the server and I run this command :

The problem is that the total remains at 0 and no data is imported

Thanks for your help

Hi @Late_matre,

With the information that we have currently, I’m not sure exactly why you’d be seeing this behavior. Looking at the command/screenshot provided, we can deduce a few things.

  1. There exists a directory named bucket-Luchta.Request in the backup directory postfixed with -full (otherwise the -b flag would have thrown an error)
  2. There exists a bucket (on the cluster) called Luchta.Request (for the same reason as above)
  3. The command completed (since the progress bar completed without displaying an error)

I believe this suggests one of a few things:

  1. There may not be any directories in bucket-Luchta.Request named node-* (where * is a glob pattern)
  2. This specific backup directory may not contain any data

I’ve attempted to reproduce this issue by installing 5.1.0 on Windows, creating a backup (of a sample bucket) and restoring using a 6.6.0 version of cbrestore with everything working as expected.

To further debug this, please could you answer/provide the following:

  1. An ls -lR of the 2021-06-21T075735Z directory
  2. The output of the same cbrestore command run with debug logging (using -vvv)
  3. Could you also confirm that the backup directories have been correctly transferred (including recursively copied) to the remote server

Thanks in advance,