Kubernetes Operator validation failure


#1

Is it required to run the enterprise version of Couchbase deploying in K8S Cluster? I’ve tried changing the version from: enterprise-5.5.1 to community-5.1.1 and receive the following error: validation failure list:
spec.version in body should match ‘^([\w\d]±)?\d+.\d+.\d+(-[\w\d]+)?$’

I’m deploying to local minikube version 1.11.2 of kubectl.

If I deploy the defaults within: couchbase-autonomous-operator-kubernetes_1.0.0-macos_x86_64 the enterprise version deploys without an issue.


#2

@pplavetzki My understanding is the minimum version of couchbase server supported is 5.5.0. I will double check with my Dev team and get back to you. Thank you for your interest in Kubernetes Operator


#3

The Couchbase Autonomous Operator is only supported with Couchbase Server Enterprise Edition, please check here for more details https://docs.couchbase.com/operator/1.0/overview.html