Loads of intermittent generic network failures & can't get anything to log


#1

Basics:

  • One VPS hosting our application split into docker containers.
  • Couchbase Server in a container, with data shared to host
  • Couchbase Sync Gateway in another container
  • PHP app, on Laravel, living in another container.

We’re getting loads of connection timeouts which happen with between 0 and 1 online users (not public, in development).

I’ve tried everything I could think of, including all the usual suggestions that come up from googling around. The only thing that made a difference was having the Laravel app running on the host, and using ‘localhost’ as the connection string - that actually seemed to completely nail the issue. Now that the PHP app is running in a container, I’ve gone back to calling it by the DNS, and the issue returns.

There’s nothing I can think of which can be causing it every time. Sometimes it’s OK, and then it’ll become completely unusable, then it’ll be OK again after a bit.

The admin area (:8091) works perfectly, all the time, if that helps at all.

CouchbaseException (23)
Client-Side timeout exceeded for operation. Inspect network conditions or increase the timeout

#2

Right.

Looks like linking the containers together properly with the --link command seems to have nailed things (which runs SSH between two containers on a private subnet as far as I’m aware).

I still get the error when connecting to our staging couchbase server, with a container on localhost, and using the DNS.