Memcached constant load 20% to 30% in spite of no activity at all


#1

Hello Couchbase Team,

Thanks for getting such a wonderful product and concept to people. The tech talks and videos have been awesome too. A little setback : I see that the community is not very active yet in answering questions, loads of answers still remain unanswered. A lot of questions do not end up with a resolution, but rather end with questions from the couchbase team which gives a feeling as if the those issues are resolved offline and away from this forum.

This is regarding an issue I am facing with the following config :

Server Setup :
Amazon EC2 m2.medium - Para virtualization - OS on the default volume provided by AMI, and Couchbase Data storage folder set to EBS volume mounted separately.
Ubuntu 14.04 - 64 Bit.

Couchbase Server :
Installed from couchbase-server-community_2.2.0_x86_64.deb - (Stats on Web UI show : build-837)
No Other Services running except SSHd.
Total Buckets : 3 - default, beer-sample and gamesim-sample

No activity is happening on the server. No extra nodes. No Activity means, not even accessing the web control running at 8091. So effective no calls to couchbase of any kind are happening at all.

memcached process takes anything between 20% to 30% of CPU all the time.
System Loads averages are : 0.31, 0.38, 0.57

From what i can make out this is surely a bug or something related to setup/config.
I can provide any necessary additional info if required.

If anyone from the couchbase team wants to take a peek, I can create a sudo 'able account and share details.

Any insights on what can be wrong ? We are planning to use couchbase on a Project which is not financially funded yet, so using enterprise is probably not an option even if 2 nodes are free). So any help will be highly appreciated.