Memcached CPU usage spikes after server restart


#1

I have a question about the memcached service. We are running our dev server as a single node instance of couchbase, with 2 cores and 4MB of RAM. I know this is an unsupported configuration but since it’s our dev server it has practically no load so it works ok for us. Normally couchbase uses about 62% of the server’s CPU, but we restarted the Azure VM it was running on at the beginning of March and ever since then it has been using 100% CPU, even when there is no load on it. Using top I can see that it is the memcached service that is using all the CPU (with beam.smp using 5 - 20% at any given time). How come memcached would start using 100% CPU just because the server was restarted? We didn’t change anything or add a significant number of documents, I was just training someone on how to restart the server and we did not manually bring couchbase back up, it came up on its own from the init script. The http_access log shows everything normal, the debug.log shows compression running every 30s but I saw in a different post that this was normal behaviour, and nothing else looks weird in the logs.

We are using Couchbase Version: 3.1.0-1776 Enterprise Edition (build-1776-rel). We are also running sync gateway v1.1.1 on the same node and it connects to that couchbase instance. NOTE: We cannot collect any extra logs because if we enable it couchbase crashes and restarts.


#2

@alexegli a server restart doesn’t help? Since its a dev environment I’d also recommend upgrade to 3.1.4 and see if it helps.

If it still doesn’t work with 3.1.4 let us know?