Memory leak python sdk > 2.5.X

We have APIs that we have tried to upgrade from python sdk 2.5.x to a higher version.
Couchbase has been tested with the python sdk versions:

  • 3.2.X
  • 3.0.X
  • 4.0.X

But they all produce memory lake.

The Server version is 6.0.0, which is compatible in principle.

The APIs are made with Tornado 5.0.2, but we also have another one with flask and it also produces a memory leak.

the following code corresponds to the way to install the bucket that we use with sdk version 4.0.x:

and we also call the getmulti method.

If anyone can help, I’d appreciate it.

Thank you

Sorry for the delayed response, but PYCBC-1387 was created for this issue. The issue has been addressed and will be available in the 4.0.3 release. I will update this forum post again once the new version becomes available on PyPI.

1 Like

Hi @Jhonier_Duvan_Menese - Just want to give an update that we released version 4.0.3 of the SDK yesterday which includes a fix for this issue.

1 Like