Module compiled with Swift 4.2 cannot be imported by the Swift 5.1 compiler

Hi,

I am trying to build my project on Xcode 11 bata and I see the following CouchbaseLiteSwift error:
« Module compiled with Swift 4.2 cannot be imported by the Swift 5.1 compiler: …Pods/CouchbaseLite-Swift/iOS/CouchbaseLiteSwift.framework/Modules/CouchbaseLiteSwift.swiftmodule/x86_64.swiftmodule»
how to resolve this without changing Xcode command line tool to an old Xcode version?

Thanks!

The only way to resolve it is to build from source instead of using pods.

As soon as Xcode 11 is released (next month?) we’ll release a build of Couchbase Lite built with it, and then this will never be a problem again. Swift 5.1 finally adds full binary compatibility between versions.