Module compiled with Swift 5.0.1 cannot be imported by the Swift 4.2.1 compiler

#1

I have updated couchbase IOS SDK to v2.5.0 via CocoaPods . But, I cannot able to run my project.

Pod file,

target 'APP' do
  use_frameworks!
  pod 'CouchbaseLite-Swift', '~> 2.5.0'
end

XCode Version: 10.1

#2

Could you please try updating XCode to 10.2, so that the Swift 5 compiler can be used.

#3

@jayahari.vavachan Thank you for you reply. But, we can’t update our xcode to 10.2. Because, we are using a lot of frameworks in our app which is still compiling with swift3.

Do we have any other options?

#4

Isn’t the whole point of CocoaPods that it downloads every single thing from source and then builds it with your current version of Xcode? What you are describing sounds like what could happen for EE since it is not open source and the only choice is to download prebuilt binaries and link with them but for CE I thought that it would get around this problem by compiling everything from source. Am I imagining that?

#5

That is correct. For CE they should be able to pull the source and build it with installed version of Xcode.