Multiple jdk variants of CBL 1.3


#1

@hideki Hi. Can you please supply a jdk7 compiled CBL 1.3 in addition to the jdk8 version?
This, because there are many complications for multiple library (builds) based apps who target Android <= 23.
Gradle has its own share of complications/bugs/requirements and why force jdk8 upon developers who are not targeting android N just yet.
It would also greatly simplify development when we can compare a jdk8 versus a jdk7 based build.

As far as version numbering goes, it should be rather simple to come up with something like
couchbase-lite-android:81.3.0 and couchbase-lite-android:71.3.0.
Thank you much.
nat


#2

Hi @natgross,

This issue is tracked by the following ticket.

Thanks!
Hideki


#3

Thank you.
Will comment there if necessary.
nat


#4

This issue is addressed with CBL v1.3.1.