N1QL connection refused error


#1

Hello,

I didn’t found the download of N1QL for my 3.0.3 couchbase cluster. SO I have installed the Developer Preview of Couchbase Server 4.0 on another host called test1 not member of my production couchbase cluster.

From the test1 host I run N1QL and wanted to connect to the one of the nodes of the production couchbase cluster with IP 158.7.21.101, when running create index command, I have connection refused error. Where I am able to ping both the node of the production cluster with the test1 server. Any idea?

root@test1:/opt/couchbase/bin# ./cbq -engine=http://158.7.21.101:8093
Couchbase query shell connected to http:// 158.7.21.101:8093/ . Type Ctrl-D to exit.
cbq> CREATE PRIMARY INDEX ON forum USING GSI;
ERROR : Post http:// 158.7.21.101:8093/query: dial tcp 158.7.21.101:8093: connection refused
cbq> CREATE PRIMARY INDEX ON forum;
ERROR : Post http:// 158.7.21.101:8093/query: dial tcp 158.7.21.101:8093: connection refused
cbq> select * from system:indexes;
ERROR : Post http:// 158.7.21.101:8093/query: dial tcp 158.7.21.101:8093: connection refused
cbq>

root@test1:/opt/couchbase/bin# ping 158.7.21.101
PING 158.7.21.101 (158.7.21.101) 56(84) bytes of data.
64 bytes from 158.7.21.101: icmp_seq=1 ttl=64 time=0.505 ms
64 bytes from 158.7.21.101: icmp_seq=2 ttl=64 time=0.243 ms
64 bytes from 158.7.21.101: icmp_seq=3 ttl=64 time=0.257 ms
^C
— 158.7.21.101 ping statistics —
3 packets transmitted, 3 received, 0% packet loss, time 1999ms
rtt min/avg/max/mdev = 0.243/0.335/0.505/0.120 ms


Connecting N1QL to a remote couchbase server
#2

@couchbwiss so are you running a mixed cluster right now? Can you show the Ip and version layout of your cluster and which nodes you are trying to access? At least on 148.7.21.101, the query service seems not to be enabled (either because the checkbox was not selected on adding, or it’s a 3.0.3 node?)

Btw, the download for 3.0.3 is here: http://www.couchbase.com/nosql-databases/downloads right on the top.


#3

@daschl Thanks for your help.

At the end I uninstalled the 3 nodes cluster of Couchbase server 3.0.3 version and installed the version 4.0 and now I am able to use N1QL from the query nodes.
cheers


#4

great that it works now!