N1QL, Inconsistency between CBQ and Couchbase Browser


#1

Guys,

I created some documents, I saw this documents at the web browser but when I try to see in cbq I cant see it.

It is the same bucket and I can see another documents from the same bucket.

Attach some captures about it

https://mega.nz/#!kspAAIja!fEZcVgVoJG7NqcZluzmdZ9WFL1ThldkdeQrOuP7g2kc

I will try to restart the couchbase Service.

Regards.


#2

I restarted the service couchbase and I could see them.

Why happened this?

Regards.


#3

@Antx2207, what was the latency between the time you inserted the document and issued the query? typically indexes are fast in indexing but you may see latencies in indexing items. you could specify scan_consistency=request_plus at the REST API or when using SDKs. cbq does not have the ability to pass this in at this point with the beta build.


#4

I tested a lot at different time, because I thought that my query was wrong. therefore I thought that index is not the problem.

With Cbq I tried to exit and enter again and I could not make it work.

When I restart the service so cbq worked.

I Attach the some logs about it:

https://mega.nz/#!A4YHzKqQ!q0ff4Z6HHp68gEgpt83k9KZoqMHZEGLA2r8glbf82dg

Regards