No primary index on keyspace


#1

I have problem about index when I use query N1QL using PHP SDK.
My site says: "No primary index on keyspace mybucket. Use CREATE PRIMARY INDEX to create one"
I had no problem before, I created index gsi for my bucket, run my query and have a results.
I try create index gsi again, but I get error also.
CREATE PRIMARY INDEX ON mybucket USING GSI;
{
“requestID”: “8c94b33f-3f1f-4a95-b27f-b90da73c2e8b”,
“signature”: null,
“results”: [
],
“errors”: [
{
“code”: 12005,
“msg”: “Indexer not implemented GSI may not be enabled”
}
],
“status”: “errors”,
“metrics”: {
“elapsedTime”: “1.085959ms”,
“executionTime”: “1.011575ms”,
“resultCount”: 0,
“resultSize”: 0,
“errorCount”: 1
}
}

Any solution? How to enable GSI?


#2

I run query using cli cbq. And now I have result on my site… I don’t know why… But now I can work my project again… :slight_smile:


#3

FYI, this only happens to me if I have a separate query and index nodes, and they are running different versions.