Old jdk client with 5.x server

Hey ! I am trying to migrate our servers from 4.x to 5.x. but while doing some testing I found that the old Java client driver 1.x seems not to be compatible with 5.x servers.
The errors seen is

WARN net.spy.memcached.transcoders.SerializingTranscoder: Failed to decompress data
java.util.zip.ZipException: Not in GZIP format

Any ideas if this Java driver 1.x can work with a 5.x server ?

Java client 2.x worked just fine but changing that will be a heavy lift.

Thanks

Hi German,

Any ideas if this Java driver 1.x can work with a 5.x server ?

I haven’t tried it, and I haven’t been around long enough to know how the Java client has changed from 1.x to 2.x, but I’m not surprised you’re running into issues; the 1.x client reached EOL back in April of 2016.

Depending on how urgently you need to upgrade, you might consider waiting before starting that heavy lift. If you can hold out a little longer, you might be able to skip Java client 2.x and go directly to 3.x; it’s available now in alpha (apis not solidified yet), with a GA release coming around the start of next year.

We’ve not touched this in some time, but I would expect the 1.x client to work generally.

The symptom doesn’t quite match this, but if you’re using a brand new 5.x cluster, you need to setup the users in a very specific way to be compatible with clients that are not RBAC ready.

Starting in 5.0, you need to create a user with the same name as the bucket for compatibility and give that user permissions to access the bucket. You can no longer create passwords directly on buckets in 5.0. Using a password is required.

For more info, see:

https://developer.couchbase.com/documentation/server/5.0/security/security-authorization.html#authorization

https://developer.couchbase.com/documentation/server/5.0/sdk/java/start-using-sdk.html (note cluster.authenticate() )

Thanks for.answering ! So far is not working. I am wondering if this error could be a server configuration thing …
This is quite.urgent so I will need to update to 2.x

Will check those links ! Thanks !
Yes user management in 5 is different, but I already did that, the error shown is when trying to read a document using the old driver

Seems that the minor version supported is 2.5.1

https://docs.couchbase.com/server/5.1/release-notes/relnotes-v5.0.x.html#sdk-compatibility

That’s true. Supported and works though are two different things. We can definitely say supported is that or later, as we (Couchbase) support what we test to.

Yes you are right. But as far I was able to test this seems not to going through