PHP SDK 2.0.6 - Wrong version number


#1

As I mentioned in another thread, I’m in the process of building my own library utilizing your PHP SDK. I just upgraded my library to 2.0.6. I’m currently on Windows 7 64bit (local dev instance), running PHP 5.6.7, and I’m using the new libcouchbase.dll & php_couchbase.dll files from the zip archive (php_couchbase-2.0.6-5.6-zts-vc11-x86.zip) that I downloaded from your CDN. I just switched a constant in my class that checks for the required version number of your SDK to 2.0.6 and it threw an exception (which I designed it to do) if that criteria wasn’t being met. So, I immediately assumed that the problem was on my end and that I didn’t install the right versions of the aforementioned files. However, when I copied over the files, again, it still threw the exception, I checked in phpinfo() and sure enough it says the version is still 2.0.5.

Could this be a bug/miss inside the code in the php_couchbase.dll file or maybe the wrong files were packaged into the new archive? I was about to log an issue for it, but I wasn’t sure what the correct classification for this would be.


#2

Hey, thanks for the post. That does look like it’d be better handled through our Issues system. If you could file something under the PHP SDK project, that’d be great:

https://issues.couchbase.com/browse/PCBC

I’d love to hear more about your library.

Cheers.


PHP Couchbase SDK versions
#3

Thank you, Matthew. I’ve just reported it. What is it that you’d like to know about my library?