Php SDK unable to install


#1

I am following the below documentation :

http://developer.couchbase.com/documentation/server/4.1/sdks/php-2.0/download-links.html

which mentions about C SDK as a prerequisite, thus I am following the below :

http://developer.couchbase.com/documentation/server/4.0/sdks/c-2.4/download-install.html

I am using RedHat and thus ran the below :
sudo yum install libcouchbase-devel libcouchbase2-bin gcc gcc-c++

now am getting the below error log :

Loaded plugins: amazon-id, rhui-lb, search-disabled-repos
http://packages.couchbase.com/rpm/7Server/x86_64/repodata/repomd.xml: [Errno 14] HTTP Error 403 - Forbidden

Kindly help me solve the issue


#2

Which specific release of Red Hat Linux are you using? When you add libcouchbase from a yum repository, it needs to be a supported platform so the right yum metadata can be loaded. If we don’t have package coverage for that platform, the other way to approach this might be to build from source.

@mnunberg: does this look like a platform we’d expect but might be missing?


PHP Couchbase SDK installation error
#3

This looks like a problem on our end. We do support el7, but it seems the repo URL itself is incorrect.

I think the real issue is why your $releasever is showing up as 7Server rather than just 7: http://packages.couchbase.com/rpm/7/x86_64/repodata/repomd.xml works.

A short-term solution would be to edit /etc/yum.repos.d/couchbase-Base.repo and change references from $releasever to 7.

Unless this is some different exotic version of EL7 which is substantially different, but I doubt it.

EDIT: Apparently CentOS sets $releasever to 7, but actual “vanilla” RHEL sets it to 7Server. We’ll be working on making sure the 7 is always used.


#4

Hi,

I tried with Amazon Linux in AWS and I am receiving the below log after running

sudo yum install libcouchbase-devel libcouchbase2-bin gcc gcc-c++

Logs:

Loaded plugins: priorities, update-motd, upgrade-helper
amzn-main/latest                                         | 2.1 kB     00:00
amzn-updates/latest                                      | 2.3 kB     00:00
http://packages.couchbase.com/releases/couchbase-server/enterprise/rpm/latest/x86_64/repodata/repomd.xml: [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 403 Forbidden"
Trying other mirror.


 One of the configured repositories failed (Couchbase Server),
 and yum doesn't have enough cached data to continue. At this point the only
 safe thing yum can do is fail. There are a few ways to work "fix" this:

     1. Contact the upstream for the repository and get them to fix the problem.

     2. Reconfigure the baseurl/etc. for the repository, to point to a working
        upstream. This is most often useful if you are using a newer
        distribution release than is supported by the repository (and the
        packages for the previous distribution release still work).

     3. Disable the repository, so yum won't use it by default. Yum will then
        just ignore the repository until you permanently enable it again or use
        --enablerepo for temporary usage:

            yum-config-manager --disable couchbase-server

     4. Configure the failing repository to be skipped, if it is unavailable.
        Note that yum will try to contact the repo. when it runs most commands,
        so will have to try and fail each time (and thus. yum will be be much
        slower). If it is a very temporary problem though, this is often a nice
        compromise:

            yum-config-manager --save --setopt=couchbase-server.skip_if_unavailable=true

failure: repodata/repomd.xml from couchbase-server: [Errno 256] No more mirrors to try.

Kindly help. Thanking you.