PHP5-FPM fail to start


#1

Hi,

I’ve installed C sdk then php by executing pecl install couchbase.

I have nginx + php5-fpm with php version 5.6.3.

When I hit the nginx, I get 502 Bad Gateway.

Here’s GDB output.

root@homestead:/tmp# gdb /usr/sbin/php5-fpm /tmp/coredump-php5-fpm.3221
GNU gdb (Ubuntu 7.7.1-0ubuntu5~14.04.2) 7.7.1
Copyright (C) 2014 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-linux-gnu".
Type "show configuration" for configuration details.
For bug reporting instructions, please see:
Find the GDB manual and other documentation resources online at:
For help, type "help".
Type "apropos word" to search for commands related to "word"...
Reading symbols from /usr/sbin/php5-fpm...(no debugging symbols found)...done.
[New LWP 3221]
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
Core was generated by `php-fpm: pool www                                                       '.
Program terminated with signal SIGSEGV, Segmentation fault.
#0  0x00007f1fac4db63e in xdebug_execute_internal (current_execute_data=0x7f1faf69a7c0, fci=0x0, return_value_used=0)
    at /build/buildd/xdebug-2.2.5/xdebug-2.2.5/xdebug.c:1589
1589    /build/buildd/xdebug-2.2.5/xdebug-2.2.5/xdebug.c: No such file or directory.
(gdb) bt
#0  0x00007f1fac4db63e in xdebug_execute_internal (current_execute_data=0x7f1faf69a7c0, fci=0x0, return_value_used=0)
    at /build/buildd/xdebug-2.2.5/xdebug-2.2.5/xdebug.c:1589
#1  0x000000000077de70 in ?? ()
#2  0x0000000000714d88 in execute_ex ()
#3  0x00000000006c9829 in dtrace_execute_ex ()
#4  0x00007f1fac4dab6c in xdebug_execute_ex (execute_data=0x7f1faf69a7c0) at /build/buildd/xdebug-2.2.5/xdebug-2.2.5/xdebug.c:1437
#5  0x00000000006cd08a in zend_eval_stringl ()
#6  0x00007f1fa1a1fc46 in zm_activate_couchbase (type=<optimized out>, module_number=<optimized out>) at /tmp/pear/temp/couchbase/couchbase.c:109
#7  0x00000000006e19f0 in zend_activate_modules ()
#8  0x0000000000677f6a in php_request_startup ()
#9  0x0000000000463d32 in main ()
(gdb) Quit

What’s causing it?


#2

This is an issue with XDebug. See PCBC-294 for more details.


#3

Thank you pvarley. That fixed it :slight_smile: