Pip install couchbase is broken


#1

I’m trying to install the python SDK through pip and this is my traceback:

$sudo pip install couchbase
Traceback (most recent call last):
File “/usr/bin/pip”, line 9, in
load_entry_point(‘pip==1.5.4’, ‘console_scripts’, ‘pip’)()
File “/usr/lib/python2.7/dist-packages/pkg_resources.py”, line 351, in load_entry_point
return get_distribution(dist).load_entry_point(group, name)
File “/usr/lib/python2.7/dist-packages/pkg_resources.py”, line 2363, in load_entry_point
return ep.load()
File “/usr/lib/python2.7/dist-packages/pkg_resources.py”, line 2088, in load
entry = import(self.module_name, globals(),globals(), [‘name’])
File “/usr/lib/python2.7/dist-packages/pip/init.py”, line 11, in
from pip.vcs import git, mercurial, subversion, bazaar # noqa
File “/usr/lib/python2.7/dist-packages/pip/vcs/mercurial.py”, line 9, in
from pip.download import path_to_url
File “/usr/lib/python2.7/dist-packages/pip/download.py”, line 25, in
from requests.compat import IncompleteRead
ImportError: cannot import name IncompleteRead

Apart from installing from the latest dev release from github, is there anyway I can get a stable release?


#2

I haven’t seen this issue before. Can you please tell me the platform you’re using? It looks like an issue with pip itself.


#3

hey @mnunberg - this is on an ec2 instance running Ubuntu 14.04.2 LTS… what other info can i give you? I actively use that instance for dev and just installed a flask using pip - that worked fine.


#4

Resolved.

Super weird - the pip repo is working for everything other than couchbase. I just updated pip using ‘easy_install -U pip’ and then ran pip install couchbase and it worked. Hopefully, this will save someone else in the future :smile:

Thanks!


#5

Hrm. It would seem like an issue in communicating with the index server - I couldn’t reproduce it on a full spectrum of pip versions, but I’ll keep an eye open.