Push replication stops working


#1

Hello,

We have a CBlite Beta Plugin for Android Phonegap project running ok and replicating in pull and push mode in continuous mode. When a modification is made on the mobile database it is correctly pushed on the server.

Surprisingly, when the app is stopped and when we restart the app, pull replication works as expected but pushes stops working. All modifications done on the local database are not anymore replicated.

When we monitor HTTP traffic from the mobile to the server and we see no HTTP activity …

Nothing changes is we request explicitly a replication using the REST API to the local database.

Any idea ?

Thx


#2

This sounds like it’s a duplicate of this bug:

Unfortunately we don’t yet have official post beta2 artifacts for Android yet, so you would need to either wait until that happens, or use code from the master branch to verify this is fixed.


#3

I had a look at this 190 issue, it is not exactly the same. in #190 the push replication is not working after connectivity loss. In our case, connectivity is always there, replication just stops after restarting the app…


#4

Ok, Found the problem.

We were asking for the “create target” option for the push replication. When we set this option to false, Push replication works even if we restart the app …

Nice to know : )


#5

That sounds like a new bug.

Can you file a bug in https://github.com/couchbase/couchbase-lite-java-core/issues/ and mention the exact version of couchbase lite you are using?


#6

We have been having the very same issue and I can confirm the fix suggested by opic does work. Has a bug been filed already?


#7

ilmaruk no bug has been filed that I’m aware of. Can you file one here? https://github.com/couchbase/couchbase-lite-java-core/issues

Don’t forget to mention which version you are using, and exact steps to reproduce the issue.


#8