Python SDK 2.0 with Python 3.x?

#1

I have seen the notice on the top of the Python SDK 2.0 documentation: “This document is for the 2.x version of the Python SDK. If you are not using the 2.x version, please refer to the Python SDK 1.2 documentation.”

Would this mean that the Python SDK 2.0 does not support Python 3.x or just the documentation does not cover it?

If the Python SDK 2.0 does not support Python 3.x, are there any plans to get it supported? By when?

#2

I guess I will answer my own question.

I have tested it and the Python SDK 2.0 seems to be running just fine in Python 3.5, so I guess that quote in the documentation referred to the fact that the example code in the document is written for Python 2.x and not for 3.x, but the SDK itself still works in 3.x too.

#3

Sorry for the confusion. The 1.x and 2.x refer to the SDK version. The Python SDK since 1.0.0 functions perfectly on all versions of Python (2.x and 3.x) starting from 2.6