Q: about 'This is usually related to an out-of-memory condition'


#1

hi:

my environments are:
node.js sdk: V2.6
Operator: couchbase/operator:1.0.0
kubernetes: V11.1
couchbase server: 5.5.1
I use the Operator with K8S deploy the couchbase server cluster. I deploy the node.js API pods on k8s, It’s work for me.but when I want to run the node.js API from my notepad, always throw ‘out of memory’ error. I enter the API pods, and run node.js command line, run the bucket.query with N1QL statements is correct. but when I run bucket.get(‘IDXXXXX’), it’s will throw error below:

{“subsystem”:“bootstrap”,“srcfile”:"…/deps/lcb/src/bootstrap.cc",“srcline”:218,“level”:“info”,“message”:“Requested network configuration: heuristic”}
{“subsystem”:“cccp”,“srcfile”:"…/deps/lcb/src/bucketconfig/bc_cccp.cc",“srcline”:151,“level”:“info”,“message”:“Requesting connection to node 110.212.23.1:11210 for CCCP c
onfiguration”}{“subsystem”:“connection”,“srcfile”:"…/deps/lcb/src/lcbio/connect.cc",“srcline”:474,“level”:“info”,“message”:"<110.212.23.1:11210> (SOCK=000000004a04dfa5) Starting. Timeo
ut=2000000us"}{“subsystem”:“connection”,“srcfile”:"…/deps/lcb/src/lcbio/connect.cc",“srcline”:147,“level”:“info”,“message”:"<110.212.23.1:11210> (SOCK=000000004a04dfa5) Connected estab
lished"}{“subsystem”:“lcbio”,“srcfile”:"…/deps/lcb/src/lcbio/ioutils.cc",“srcline”:112,“level”:“warn”,“message”:“Translating errno=0, lcb=0x2d to NETWORK_ERROR”}
{“subsystem”:“connection”,“srcfile”:"…/deps/lcb/src/lcbio/connect.cc",“srcline”:108,“level”:“info”,“message”:"<110.212.23.1:11210> (SOCK=000000004a04dfa5) Couldn’t set TC
P_NODELAY"}{“subsystem”:“lcbio”,“srcfile”:"…/deps/lcb/src/lcbio/ioutils.cc",“srcline”:112,“level”:“warn”,“message”:“Translating errno=0, lcb=0x2d to NETWORK_ERROR”}
{“subsystem”:“negotiation”,“srcfile”:"…/deps/lcb/src/mcserver/negotiate.cc",“srcline”:154,“level”:“error”,“message”:"<110.212.23.1:11210> (CTX=0x36ab050,sasl,SASLREQ=0x36
1c030) Error: 0x10, IO Error"}{“subsystem”:“cccp”,“srcfile”:"…/deps/lcb/src/bucketconfig/bc_cccp.cc",“srcline”:165,“level”:“error”,“message”:“NOHOST:NOPORT (CTX=(nil),) Could not get configuration:
LCB_NETWORK_ERROR (0x10)”}{“subsystem”:“confmon”,“srcfile”:"…/deps/lcb/src/bucketconfig/confmon.cc",“srcline”:185,“level”:“info”,“message”:“Provider ‘CCCP’ failed”}
{“subsystem”:“connection”,“srcfile”:"…/deps/lcb/src/lcbio/connect.cc",“srcline”:474,“level”:“info”,“message”:"<110.212.23.1:8091> (SOCK=000000006b5cb71b) Starting. Timeou
t=2000000us"}{“subsystem”:“connection”,“srcfile”:"…/deps/lcb/src/lcbio/connect.cc",“srcline”:147,“level”:“info”,“message”:"<110.212.23.1:8091> (SOCK=000000006b5cb71b) Connected establ
ished"}{“subsystem”:“lcbio”,“srcfile”:"…/deps/lcb/src/lcbio/ioutils.cc",“srcline”:112,“level”:“warn”,“message”:“Translating errno=0, lcb=0x2d to NETWORK_ERROR”}
{“subsystem”:“connection”,“srcfile”:"…/deps/lcb/src/lcbio/connect.cc",“srcline”:108,“level”:“info”,“message”:"<110.212.23.1:8091> (SOCK=000000006b5cb71b) Couldn’t set TCP
_NODELAY"}{“subsystem”:“confmon”,“srcfile”:"…/deps/lcb/src/bucketconfig/confmon.cc",“srcline”:160,“level”:“info”,“message”:“Setting new configuration. Received via HTTP”}
{“subsystem”:“bootstrap”,“srcfile”:"…/deps/lcb/src/bootstrap.cc",“srcline”:90,“level”:“info”,“message”:“Selected network configuration: “default””}
{“subsystem”:“connection”,“srcfile”:"…/deps/lcb/src/lcbio/connect.cc",“srcline”:474,“level”:“info”,“message”:“ydd-cbs-0001.ydd-cbs.default.svc:11210 (SOCK=0000000044d46
0a7) Starting. Timeout=2500000us”}{“subsystem”:“connection”,“srcfile”:"…/deps/lcb/src/lcbio/connect.cc",“srcline”:147,“level”:“info”,“message”:“ydd-cbs-0001.ydd-cbs.default.svc:11210 (SOCK=0000000044d46
0a7) Connected established”}{“subsystem”:“lcbio”,“srcfile”:"…/deps/lcb/src/lcbio/ioutils.cc",“srcline”:112,“level”:“warn”,“message”:“Translating errno=0, lcb=0x2d to NETWORK_ERROR”}
{“subsystem”:“connection”,“srcfile”:"…/deps/lcb/src/lcbio/connect.cc",“srcline”:108,“level”:“info”,“message”:“ydd-cbs-0001.ydd-cbs.default.svc:11210 (SOCK=0000000044d46
0a7) Couldn’t set TCP_NODELAY”}{“subsystem”:“lcbio”,“srcfile”:"…/deps/lcb/src/lcbio/ioutils.cc",“srcline”:112,“level”:“warn”,“message”:“Translating errno=0, lcb=0x2d to NETWORK_ERROR”}
{“subsystem”:“negotiation”,“srcfile”:"…/deps/lcb/src/mcserver/negotiate.cc",“srcline”:154,“level”:“error”,“message”:“ydd-cbs-0001.ydd-cbs.default.svc:11210 (CTX=0x36800
50,sasl,SASLREQ=0x36a9c50) Error: 0x10, IO Error”}{“subsystem”:“server”,“srcfile”:"…/deps/lcb/src/mcserver/mcserver.cc",“srcline”:777,“level”:“error”,“message”:“NOHOST:NOPORT (CTX=(nil),SRV=0x36180a0,IX=1) Connection
attempt failed. Received LCB_NETWORK_ERROR (0x10) from libcouchbase, received 0 from operating system”}{“subsystem”:“bootstrap”,“srcfile”:"…/deps/lcb/src/bootstrap.cc",“srcline”:206,“level”:“info”,“message”:“Not requesting a config refresh because of throttling parameters.
Next refresh possible in 3ms or 99 errors. See LCB_CNTL_CONFDELAY_THRESH and LCB_CNTL_CONFERRTHRESH to modify the throttling settings”}{“subsystem”:“connection”,“srcfile”:"…/deps/lcb/src/lcbio/connect.cc",“srcline”:474,“level”:“info”,“message”:“ydd-cbs-0001.ydd-cbs.default.svc:11210 (SOCK=0000000030324
108) Starting. Timeout=2500000us”}{“subsystem”:“connection”,“srcfile”:"…/deps/lcb/src/lcbio/connect.cc",“srcline”:147,“level”:“info”,“message”:“ydd-cbs-0001.ydd-cbs.default.svc:11210 (SOCK=0000000030324
108) Connected established”}{“subsystem”:“lcbio”,“srcfile”:"…/deps/lcb/src/lcbio/ioutils.cc",“srcline”:112,“level”:“warn”,“message”:“Translating errno=0, lcb=0x2d to NETWORK_ERROR”}
{“subsystem”:“connection”,“srcfile”:"…/deps/lcb/src/lcbio/connect.cc",“srcline”:108,“level”:“info”,“message”:“ydd-cbs-0001.ydd-cbs.default.svc:11210 (SOCK=0000000030324
108) Couldn’t set TCP_NODELAY”}{“subsystem”:“lcbio”,“srcfile”:"…/deps/lcb/src/lcbio/ioutils.cc",“srcline”:112,“level”:“warn”,“message”:“Translating errno=0, lcb=0x2d to NETWORK_ERROR”}
{“subsystem”:“negotiation”,“srcfile”:"…/deps/lcb/src/mcserver/negotiate.cc",“srcline”:154,“level”:“error”,“message”:“ydd-cbs-0001.ydd-cbs.default.svc:11210 (CTX=0x365b8
60,sasl,SASLREQ=0x36a9c50) Error: 0x10, IO Error”}{“subsystem”:“server”,“srcfile”:"…/deps/lcb/src/mcserver/mcserver.cc",“srcline”:777,“level”:“error”,“message”:“NOHOST:NOPORT (CTX=(nil),SRV=0x36180a0,IX=1) Connection
attempt failed. Received LCB_NETWORK_ERROR (0x10) from libcouchbase, received 0 from operating system”}{“subsystem”:“connection”,“srcfile”:"…/deps/lcb/src/lcbio/connect.cc",“srcline”:474,“level”:“info”,“message”:“ydd-cbs-0001.ydd-cbs.default.svc:11210 (SOCK=00000000656c3
9f7) Starting. Timeout=2500000us”}{“subsystem”:“connection”,“srcfile”:"…/deps/lcb/src/lcbio/connect.cc",“srcline”:147,“level”:“info”,“message”:“ydd-cbs-0001.ydd-cbs.default.svc:11210 (SOCK=00000000656c3
9f7) Connected established”}{“subsystem”:“lcbio”,“srcfile”:"…/deps/lcb/src/lcbio/ioutils.cc",“srcline”:112,“level”:“warn”,“message”:“Translating errno=0, lcb=0x2d to NETWORK_ERROR”}
{“subsystem”:“connection”,“srcfile”:"…/deps/lcb/src/lcbio/connect.cc",“srcline”:108,“level”:“info”,“message”:“ydd-cbs-0001.ydd-cbs.default.svc:11210 (SOCK=00000000656c3
9f7) Couldn’t set TCP_NODELAY”}{“subsystem”:“lcbio”,“srcfile”:"…/deps/lcb/src/lcbio/ioutils.cc",“srcline”:112,“level”:“warn”,“message”:“Translating errno=0, lcb=0x2d to NETWORK_ERROR”}
{“subsystem”:“negotiation”,“srcfile”:"…/deps/lcb/src/mcserver/negotiate.cc",“srcline”:154,“level”:“error”,“message”:“ydd-cbs-0001.ydd-cbs.default.svc:11210 (CTX=0x368aa
70,sasl,SASLREQ=0x36a9c50) Error: 0x10, IO Error”}{“subsystem”:“server”,“srcfile”:"…/deps/lcb/src/mcserver/mcserver.cc",“srcline”:777,“level”:“error”,“message”:“NOHOST:NOPORT (CTX=(nil),SRV=0x36180a0,IX=1) Connection
attempt failed. Received LCB_NETWORK_ERROR (0x10) from libcouchbase, received 0 from operating system”}{“subsystem”:“connection”,“srcfile”:"…/deps/lcb/src/lcbio/connect.cc",“srcline”:474,“level”:“info”,“message”:“ydd-cbs-0001.ydd-cbs.default.svc:11210 (SOCK=000000004622b
aa3) Starting. Timeout=2500000us”}{“subsystem”:“connection”,“srcfile”:"…/deps/lcb/src/lcbio/connect.cc",“srcline”:147,“level”:“info”,“message”:“ydd-cbs-0001.ydd-cbs.default.svc:11210 (SOCK=000000004622b
aa3) Connected established”}{“subsystem”:“lcbio”,“srcfile”:"…/deps/lcb/src/lcbio/ioutils.cc",“srcline”:112,“level”:“warn”,“message”:“Translating errno=0, lcb=0x2d to NETWORK_ERROR”}
{“subsystem”:“connection”,“srcfile”:"…/deps/lcb/src/lcbio/connect.cc",“srcline”:108,“level”:“info”,“message”:“ydd-cbs-0001.ydd-cbs.default.svc:11210 (SOCK=000000004622b
aa3) Couldn’t set TCP_NODELAY”}{“subsystem”:“lcbio”,“srcfile”:"…/deps/lcb/src/lcbio/ioutils.cc",“srcline”:112,“level”:“warn”,“message”:“Translating errno=0, lcb=0x2d to NETWORK_ERROR”}
{“subsystem”:“negotiation”,“srcfile”:"…/deps/lcb/src/mcserver/negotiate.cc",“srcline”:154,“level”:“error”,“message”:“ydd-cbs-0001.ydd-cbs.default.svc:11210 (CTX=0x36a9c
50,sasl,SASLREQ=0x368aa70) Error: 0x10, IO Error”}{“subsystem”:“server”,“srcfile”:"…/deps/lcb/src/mcserver/mcserver.cc",“srcline”:777,“level”:“error”,“message”:“NOHOST:NOPORT (CTX=(nil),SRV=0x36180a0,IX=1) Connection
attempt failed. Received LCB_NETWORK_ERROR (0x10) from libcouchbase, received 0 from operating system”}{“subsystem”:“connection”,“srcfile”:"…/deps/lcb/src/lcbio/connect.cc",“srcline”:474,“level”:“info”,“message”:“ydd-cbs-0001.ydd-cbs.default.svc:11210 (SOCK=000000001617d
055) Starting. Timeout=2500000us”}{“subsystem”:“connection”,“srcfile”:"…/deps/lcb/src/lcbio/connect.cc",“srcline”:147,“level”:“info”,“message”:“ydd-cbs-0001.ydd-cbs.default.svc:11210 (SOCK=000000001617d
055) Connected established”}{“subsystem”:“lcbio”,“srcfile”:"…/deps/lcb/src/lcbio/ioutils.cc",“srcline”:112,“level”:“warn”,“message”:“Translating errno=0, lcb=0x2d to NETWORK_ERROR”}
{“subsystem”:“connection”,“srcfile”:"…/deps/lcb/src/lcbio/connect.cc",“srcline”:108,“level”:“info”,“message”:“ydd-cbs-0001.ydd-cbs.default.svc:11210 (SOCK=000000001617d
055) Couldn’t set TCP_NODELAY”}{“subsystem”:“lcbio”,“srcfile”:"…/deps/lcb/src/lcbio/ioutils.cc",“srcline”:112,“level”:“warn”,“message”:“Translating errno=0, lcb=0x2d to NETWORK_ERROR”}
{“subsystem”:“negotiation”,“srcfile”:"…/deps/lcb/src/mcserver/negotiate.cc",“srcline”:154,“level”:“error”,“message”:“ydd-cbs-0001.ydd-cbs.default.svc:11210 (CTX=0x368ab
80,sasl,SASLREQ=0x36a9c50) Error: 0x10, IO Error”}{“subsystem”:“server”,“srcfile”:"…/deps/lcb/src/mcserver/mcserver.cc",“srcline”:777,“level”:“error”,“message”:“NOHOST:NOPORT (CTX=(nil),SRV=0x36180a0,IX=1) Connection
attempt failed. Received LCB_NETWORK_ERROR (0x10) from libcouchbase, received 0 from operating system”}{“subsystem”:“connection”,“srcfile”:"…/deps/lcb/src/lcbio/connect.cc",“srcline”:474,“level”:“info”,“message”:“ydd-cbs-0001.ydd-cbs.default.svc:11210 (SOCK=000000001e47d
06c) Starting. Timeout=2500000us”}{“subsystem”:“connection”,“srcfile”:"…/deps/lcb/src/lcbio/connect.cc",“srcline”:147,“level”:“info”,“message”:“ydd-cbs-0001.ydd-cbs.default.svc:11210 (SOCK=000000001e47d
06c) Connected established”}{“subsystem”:“lcbio”,“srcfile”:"…/deps/lcb/src/lcbio/ioutils.cc",“srcline”:112,“level”:“warn”,“message”:“Translating errno=0, lcb=0x2d to NETWORK_ERROR”}
{“subsystem”:“connection”,“srcfile”:"…/deps/lcb/src/lcbio/connect.cc",“srcline”:108,“level”:“info”,“message”:“ydd-cbs-0001.ydd-cbs.default.svc:11210 (SOCK=000000001e47d
06c) Couldn’t set TCP_NODELAY”}{“subsystem”:“lcbio”,“srcfile”:"…/deps/lcb/src/lcbio/ioutils.cc",“srcline”:112,“level”:“warn”,“message”:“Translating errno=0, lcb=0x2d to NETWORK_ERROR”}
{“subsystem”:“negotiation”,“srcfile”:"…/deps/lcb/src/mcserver/negotiate.cc",“srcline”:154,“level”:“error”,“message”:“ydd-cbs-0001.ydd-cbs.default.svc:11210 (CTX=0x368ac
00,sasl,SASLREQ=0x36a9c50) Error: 0x10, IO Error”}{“subsystem”:“server”,“srcfile”:"…/deps/lcb/src/mcserver/mcserver.cc",“srcline”:777,“level”:“error”,“message”:“NOHOST:NOPORT (CTX=(nil),SRV=0x36180a0,IX=1) Connection
attempt failed. Received LCB_NETWORK_ERROR (0x10) from libcouchbase, received 0 from operating system”}{“subsystem”:“connection”,“srcfile”:"…/deps/lcb/src/lcbio/connect.cc",“srcline”:474,“level”:“info”,“message”:“ydd-cbs-0001.ydd-cbs.default.svc:11210 (SOCK=00000000772dd
2d4) Starting. Timeout=2500000us”}{“subsystem”:“connection”,“srcfile”:"…/deps/lcb/src/lcbio/connect.cc",“srcline”:147,“level”:“info”,“message”:“ydd-cbs-0001.ydd-cbs.default.svc:11210 (SOCK=00000000772dd
2d4) Connected established”}{“subsystem”:“lcbio”,“srcfile”:"…/deps/lcb/src/lcbio/ioutils.cc",“srcline”:112,“level”:“warn”,“message”:“Translating errno=0, lcb=0x2d to NETWORK_ERROR”}
{“subsystem”:“connection”,“srcfile”:"…/deps/lcb/src/lcbio/connect.cc",“srcline”:108,“level”:“info”,“message”:“ydd-cbs-0001.ydd-cbs.default.svc:11210 (SOCK=00000000772dd
2d4) Couldn’t set TCP_NODELAY”}{“subsystem”:“lcbio”,“srcfile”:"…/deps/lcb/src/lcbio/ioutils.cc",“srcline”:112,“level”:“warn”,“message”:“Translating errno=0, lcb=0x2d to NETWORK_ERROR”}
{“subsystem”:“negotiation”,“srcfile”:"…/deps/lcb/src/mcserver/negotiate.cc",“srcline”:154,“level”:“error”,“message”:“ydd-cbs-0001.ydd-cbs.default.svc:11210 (CTX=0x36143
e0,sasl,SASLREQ=0x36a9ce0) Error: 0x10, IO Error”}{“subsystem”:“server”,“srcfile”:"…/deps/lcb/src/mcserver/mcserver.cc",“srcline”:777,“level”:“error”,“message”:“NOHOST:NOPORT (CTX=(nil),SRV=0x36180a0,IX=1) Connection
attempt failed. Received LCB_NETWORK_ERROR (0x10) from libcouchbase, received 0 from operating system”}{“subsystem”:“connection”,“srcfile”:"…/deps/lcb/src/lcbio/connect.cc",“srcline”:474,“level”:“info”,“message”:“ydd-cbs-0001.ydd-cbs.default.svc:11210 (SOCK=000000006a44e
61c) Starting. Timeout=2500000us”}{“subsystem”:“connection”,“srcfile”:"…/deps/lcb/src/lcbio/connect.cc",“srcline”:147,“level”:“info”,“message”:“ydd-cbs-0001.ydd-cbs.default.svc:11210 (SOCK=000000006a44e
61c) Connected established”}{“subsystem”:“lcbio”,“srcfile”:"…/deps/lcb/src/lcbio/ioutils.cc",“srcline”:112,“level”:“warn”,“message”:“Translating errno=0, lcb=0x2d to NETWORK_ERROR”}
{“subsystem”:“connection”,“srcfile”:"…/deps/lcb/src/lcbio/connect.cc",“srcline”:108,“level”:“info”,“message”:“ydd-cbs-0001.ydd-cbs.default.svc:11210 (SOCK=000000006a44e
61c) Couldn’t set TCP_NODELAY”}{“subsystem”:“lcbio”,“srcfile”:"…/deps/lcb/src/lcbio/ioutils.cc",“srcline”:112,“level”:“warn”,“message”:“Translating errno=0, lcb=0x2d to NETWORK_ERROR”}
{“subsystem”:“negotiation”,“srcfile”:"…/deps/lcb/src/mcserver/negotiate.cc",“srcline”:154,“level”:“error”,“message”:“ydd-cbs-0001.ydd-cbs.default.svc:11210 (CTX=0x36144
f0,sasl,SASLREQ=0x36a9d70) Error: 0x10, IO Error”}{“subsystem”:“server”,“srcfile”:"…/deps/lcb/src/mcserver/mcserver.cc",“srcline”:777,“level”:“error”,“message”:“NOHOST:NOPORT (CTX=(nil),SRV=0x36180a0,IX=1) Connection
attempt failed. Received LCB_NETWORK_ERROR (0x10) from libcouchbase, received 0 from operating system”}{“subsystem”:“connection”,“srcfile”:"…/deps/lcb/src/lcbio/connect.cc",“srcline”:474,“level”:“info”,“message”:“ydd-cbs-0001.ydd-cbs.default.svc:11210 (SOCK=0000000038520
922) Starting. Timeout=2500000us”}{“subsystem”:“connection”,“srcfile”:"…/deps/lcb/src/lcbio/connect.cc",“srcline”:147,“level”:“info”,“message”:“ydd-cbs-0001.ydd-cbs.default.svc:11210 (SOCK=0000000038520
922) Connected established”}{“subsystem”:“lcbio”,“srcfile”:"…/deps/lcb/src/lcbio/ioutils.cc",“srcline”:112,“level”:“warn”,“message”:“Translating errno=0, lcb=0x2d to NETWORK_ERROR”}
{“subsystem”:“connection”,“srcfile”:"…/deps/lcb/src/lcbio/connect.cc",“srcline”:108,“level”:“info”,“message”:“ydd-cbs-0001.ydd-cbs.default.svc:11210 (SOCK=0000000038520
922) Couldn’t set TCP_NODELAY”}{“subsystem”:“lcbio”,“srcfile”:"…/deps/lcb/src/lcbio/ioutils.cc",“srcline”:112,“level”:“warn”,“message”:“Translating errno=0, lcb=0x2d to NETWORK_ERROR”}
{“subsystem”:“negotiation”,“srcfile”:"…/deps/lcb/src/mcserver/negotiate.cc",“srcline”:154,“level”:“error”,“message”:“ydd-cbs-0001.ydd-cbs.default.svc:11210 (CTX=0x368ab
a0,sasl,SASLREQ=0x36143e0) Error: 0x10, IO Error”}{“subsystem”:“server”,“srcfile”:"…/deps/lcb/src/mcserver/mcserver.cc",“srcline”:777,“level”:“error”,“message”:“NOHOST:NOPORT (CTX=(nil),SRV=0x36180a0,IX=1) Connection
attempt failed. Received LCB_NETWORK_ERROR (0x10) from libcouchbase, received 0 from operating system”}{“subsystem”:“connection”,“srcfile”:"…/deps/lcb/src/lcbio/connect.cc",“srcline”:474,“level”:“info”,“message”:“ydd-cbs-0001.ydd-cbs.default.svc:11210 (SOCK=0000000013da5
ec2) Starting. Timeout=2500000us”}{“subsystem”:“connection”,“srcfile”:"…/deps/lcb/src/lcbio/connect.cc",“srcline”:147,“level”:“info”,“message”:“ydd-cbs-0001.ydd-cbs.default.svc:11210 (SOCK=0000000013da5
ec2) Connected established”}{“subsystem”:“lcbio”,“srcfile”:"…/deps/lcb/src/lcbio/ioutils.cc",“srcline”:112,“level”:“warn”,“message”:“Translating errno=0, lcb=0x2d to NETWORK_ERROR”}
{“subsystem”:“connection”,“srcfile”:"…/deps/lcb/src/lcbio/connect.cc",“srcline”:108,“level”:“info”,“message”:“ydd-cbs-0001.ydd-cbs.default.svc:11210 (SOCK=0000000013da5
ec2) Couldn’t set TCP_NODELAY”}{“subsystem”:“lcbio”,“srcfile”:"…/deps/lcb/src/lcbio/ioutils.cc",“srcline”:112,“level”:“warn”,“message”:“Translating errno=0, lcb=0x2d to NETWORK_ERROR”}
{“subsystem”:“negotiation”,“srcfile”:"…/deps/lcb/src/mcserver/negotiate.cc",“srcline”:154,“level”:“error”,“message”:“ydd-cbs-0001.ydd-cbs.default.svc:11210 (CTX=0x36146
50,sasl,SASLREQ=0x36143e0) Error: 0x10, IO Error”}{“subsystem”:“server”,“srcfile”:"…/deps/lcb/src/mcserver/mcserver.cc",“srcline”:777,“level”:“error”,“message”:“NOHOST:NOPORT (CTX=(nil),SRV=0x36180a0,IX=1) Connection
attempt failed. Received LCB_NETWORK_ERROR (0x10) from libcouchbase, received 0 from operating system”}{“subsystem”:“connection”,“srcfile”:"…/deps/lcb/src/lcbio/connect.cc",“srcline”:474,“level”:“info”,“message”:“ydd-cbs-0001.ydd-cbs.default.svc:11210 (SOCK=0000000005290
c77) Starting. Timeout=2500000us”}{“subsystem”:“connection”,“srcfile”:"…/deps/lcb/src/lcbio/connect.cc",“srcline”:147,“level”:“info”,“message”:“ydd-cbs-0001.ydd-cbs.default.svc:11210 (SOCK=0000000005290
c77) Connected established”}{“subsystem”:“lcbio”,“srcfile”:"…/deps/lcb/src/lcbio/ioutils.cc",“srcline”:112,“level”:“warn”,“message”:“Translating errno=0, lcb=0x2d to NETWORK_ERROR”}
{“subsystem”:“connection”,“srcfile”:"…/deps/lcb/src/lcbio/connect.cc",“srcline”:108,“level”:“info”,“message”:“ydd-cbs-0001.ydd-cbs.default.svc:11210 (SOCK=0000000005290
c77) Couldn’t set TCP_NODELAY”}{“subsystem”:“lcbio”,“srcfile”:"…/deps/lcb/src/lcbio/ioutils.cc",“srcline”:112,“level”:“warn”,“message”:“Translating errno=0, lcb=0x2d to NETWORK_ERROR”}
{“subsystem”:“negotiation”,“srcfile”:"…/deps/lcb/src/mcserver/negotiate.cc",“srcline”:154,“level”:“error”,“message”:“ydd-cbs-0001.ydd-cbs.default.svc:11210 (CTX=0x365d7
50,sasl,SASLREQ=0x365d4e0) Error: 0x10, IO Error”}{“subsystem”:“server”,“srcfile”:"…/deps/lcb/src/mcserver/mcserver.cc",“srcline”:777,“level”:“error”,“message”:“NOHOST:NOPORT (CTX=(nil),SRV=0x36180a0,IX=1) Connection
attempt failed. Received LCB_NETWORK_ERROR (0x10) from libcouchbase, received 0 from operating system”}{“subsystem”:“connection”,“srcfile”:"…/deps/lcb/src/lcbio/connect.cc",“srcline”:474,“level”:“info”,“message”:“ydd-cbs-0001.ydd-cbs.default.svc:11210 (SOCK=0000000047f7b
054) Starting. Timeout=2500000us”}{“subsystem”:“connection”,“srcfile”:"…/deps/lcb/src/lcbio/connect.cc",“srcline”:147,“level”:“info”,“message”:“ydd-cbs-0001.ydd-cbs.default.svc:11210 (SOCK=0000000047f7b
054) Connected established”}{“subsystem”:“lcbio”,“srcfile”:"…/deps/lcb/src/lcbio/ioutils.cc",“srcline”:112,“level”:“warn”,“message”:“Translating errno=0, lcb=0x2d to NETWORK_ERROR”}
{“subsystem”:“connection”,“srcfile”:"…/deps/lcb/src/lcbio/connect.cc",“srcline”:108,“level”:“info”,“message”:“ydd-cbs-0001.ydd-cbs.default.svc:11210 (SOCK=0000000047f7b
054) Couldn’t set TCP_NODELAY”}{“subsystem”:“lcbio”,“srcfile”:"…/deps/lcb/src/lcbio/ioutils.cc",“srcline”:112,“level”:“warn”,“message”:“Translating errno=0, lcb=0x2d to NETWORK_ERROR”}
{“subsystem”:“negotiation”,“srcfile”:"…/deps/lcb/src/mcserver/negotiate.cc",“srcline”:154,“level”:“error”,“message”:“ydd-cbs-0001.ydd-cbs.default.svc:11210 (CTX=0x365d4
20,sasl,SASLREQ=0x3614530) Error: 0x10, IO Error”}{“subsystem”:“server”,“srcfile”:"…/deps/lcb/src/mcserver/mcserver.cc",“srcline”:777,“level”:“error”,“message”:“NOHOST:NOPORT (CTX=(nil),SRV=0x36180a0,IX=1) Connection
attempt failed. Received LCB_NETWORK_ERROR (0x10) from libcouchbase, received 0 from operating system”}{“subsystem”:“connection”,“srcfile”:"…/deps/lcb/src/lcbio/connect.cc",“srcline”:474,“level”:“info”,“message”:“ydd-cbs-0001.ydd-cbs.default.svc:11210 (SOCK=0000000057478
5b8) Starting. Timeout=2500000us”}{“subsystem”:“connection”,“srcfile”:"…/deps/lcb/src/lcbio/connect.cc",“srcline”:147,“level”:“info”,“message”:“ydd-cbs-0001.ydd-cbs.default.svc:11210 (SOCK=0000000057478
5b8) Connected established”}{“subsystem”:“lcbio”,“srcfile”:"…/deps/lcb/src/lcbio/ioutils.cc",“srcline”:112,“level”:“warn”,“message”:“Translating errno=0, lcb=0x2d to NETWORK_ERROR”}
{“subsystem”:“connection”,“srcfile”:"…/deps/lcb/src/lcbio/connect.cc",“srcline”:108,“level”:“info”,“message”:“ydd-cbs-0001.ydd-cbs.default.svc:11210 (SOCK=0000000057478
5b8) Couldn’t set TCP_NODELAY”}{“subsystem”:“lcbio”,“srcfile”:"…/deps/lcb/src/lcbio/ioutils.cc",“srcline”:112,“level”:“warn”,“message”:“Translating errno=0, lcb=0x2d to NETWORK_ERROR”}
{“subsystem”:“negotiation”,“srcfile”:"…/deps/lcb/src/mcserver/negotiate.cc",“srcline”:154,“level”:“error”,“message”:“ydd-cbs-0001.ydd-cbs.default.svc:11210 (CTX=0x36801
10,sasl,SASLREQ=0x365d420) Error: 0x10, IO Error”}{“subsystem”:“server”,“srcfile”:"…/deps/lcb/src/mcserver/mcserver.cc",“srcline”:777,“level”:“error”,“message”:“NOHOST:NOPORT (CTX=(nil),SRV=0x36180a0,IX=1) Connection
attempt failed. Received LCB_NETWORK_ERROR (0x10) from libcouchbase, received 0 from operating system”}{“subsystem”:“connection”,“srcfile”:"…/deps/lcb/src/lcbio/connect.cc",“srcline”:474,“level”:“info”,“message”:“ydd-cbs-0001.ydd-cbs.default.svc:11210 (SOCK=000000000f27d
8b7) Starting. Timeout=2500000us”}{“subsystem”:“connection”,“srcfile”:"…/deps/lcb/src/lcbio/connect.cc",“srcline”:147,“level”:“info”,“message”:“ydd-cbs-0001.ydd-cbs.default.svc:11210 (SOCK=000000000f27d
8b7) Connected established”}{“subsystem”:“lcbio”,“srcfile”:"…/deps/lcb/src/lcbio/ioutils.cc",“srcline”:112,“level”:“warn”,“message”:“Translating errno=0, lcb=0x2d to NETWORK_ERROR”}
{“subsystem”:“connection”,“srcfile”:"…/deps/lcb/src/lcbio/connect.cc",“srcline”:108,“level”:“info”,“message”:“ydd-cbs-0001.ydd-cbs.default.svc:11210 (SOCK=000000000f27d
8b7) Couldn’t set TCP_NODELAY”}{“subsystem”:“lcbio”,“srcfile”:"…/deps/lcb/src/lcbio/ioutils.cc",“srcline”:112,“level”:“warn”,“message”:“Translating errno=0, lcb=0x2d to NETWORK_ERROR”}
{“subsystem”:“negotiation”,“srcfile”:"…/deps/lcb/src/mcserver/negotiate.cc",“srcline”:154,“level”:“error”,“message”:“ydd-cbs-0001.ydd-cbs.default.svc:11210 (CTX=0x365d5
80,sasl,SASLREQ=0x365d420) Error: 0x10, IO Error”}{“subsystem”:“server”,“srcfile”:"…/deps/lcb/src/mcserver/mcserver.cc",“srcline”:777,“level”:“error”,“message”:“NOHOST:NOPORT (CTX=(nil),SRV=0x36180a0,IX=1) Connection
attempt failed. Received LCB_NETWORK_ERROR (0x10) from libcouchbase, received 0 from operating system”}{“subsystem”:“connection”,“srcfile”:"…/deps/lcb/src/lcbio/connect.cc",“srcline”:474,“level”:“info”,“message”:“ydd-cbs-0001.ydd-cbs.default.svc:11210 (SOCK=00000000797d1
403) Starting. Timeout=2500000us”}{“subsystem”:“connection”,“srcfile”:"…/deps/lcb/src/lcbio/connect.cc",“srcline”:147,“level”:“info”,“message”:“ydd-cbs-0001.ydd-cbs.default.svc:11210 (SOCK=00000000797d1
403) Connected established”}{“subsystem”:“lcbio”,“srcfile”:"…/deps/lcb/src/lcbio/ioutils.cc",“srcline”:112,“level”:“warn”,“message”:“Translating errno=0, lcb=0x2d to NETWORK_ERROR”}
{“subsystem”:“connection”,“srcfile”:"…/deps/lcb/src/lcbio/connect.cc",“srcline”:108,“level”:“info”,“message”:“ydd-cbs-0001.ydd-cbs.default.svc:11210 (SOCK=00000000797d1
403) Couldn’t set TCP_NODELAY”}{“subsystem”:“lcbio”,“srcfile”:"…/deps/lcb/src/lcbio/ioutils.cc",“srcline”:112,“level”:“warn”,“message”:“Translating errno=0, lcb=0x2d to NETWORK_ERROR”}
{“subsystem”:“negotiation”,“srcfile”:"…/deps/lcb/src/mcserver/negotiate.cc",“srcline”:154,“level”:“error”,“message”:“ydd-cbs-0001.ydd-cbs.default.svc:11210 (CTX=0x36146
c0,sasl,SASLREQ=0x365d420) Error: 0x10, IO Error”}{“subsystem”:“server”,“srcfile”:"…/deps/lcb/src/mcserver/mcserver.cc",“srcline”:777,“level”:“error”,“message”:“NOHOST:NOPORT (CTX=(nil),SRV=0x36180a0,IX=1) Connection
attempt failed. Received LCB_NETWORK_ERROR (0x10) from libcouchbase, received 0 from operating system”}{“subsystem”:“connection”,“srcfile”:"…/deps/lcb/src/lcbio/connect.cc",“srcline”:474,“level”:“info”,“message”:“ydd-cbs-0001.ydd-cbs.default.svc:11210 (SOCK=000000005c2f7
c23) Starting. Timeout=2500000us”}{“subsystem”:“connection”,“srcfile”:"…/deps/lcb/src/lcbio/connect.cc",“srcline”:147,“level”:“info”,“message”:“ydd-cbs-0001.ydd-cbs.default.svc:11210 (SOCK=000000005c2f7
c23) Connected established”}{“subsystem”:“lcbio”,“srcfile”:"…/deps/lcb/src/lcbio/ioutils.cc",“srcline”:112,“level”:“warn”,“message”:“Translating errno=0, lcb=0x2d to NETWORK_ERROR”}
{“subsystem”:“connection”,“srcfile”:"…/deps/lcb/src/lcbio/connect.cc",“srcline”:108,“level”:“info”,“message”:“ydd-cbs-0001.ydd-cbs.default.svc:11210 (SOCK=000000005c2f7
c23) Couldn’t set TCP_NODELAY”}{“subsystem”:“lcbio”,“srcfile”:"…/deps/lcb/src/lcbio/ioutils.cc",“srcline”:112,“level”:“warn”,“message”:“Translating errno=0, lcb=0x2d to NETWORK_ERROR”}
{“subsystem”:“negotiation”,“srcfile”:"…/deps/lcb/src/mcserver/negotiate.cc",“srcline”:154,“level”:“error”,“message”:“ydd-cbs-0001.ydd-cbs.default.svc:11210 (CTX=0x365d5
d0,sasl,SASLREQ=0x365d420) Error: 0x10, IO Error”}{“subsystem”:“server”,“srcfile”:"…/deps/lcb/src/mcserver/mcserver.cc",“srcline”:777,“level”:“error”,“message”:“NOHOST:NOPORT (CTX=(nil),SRV=0x36180a0,IX=1) Connection
attempt failed. Received LCB_NETWORK_ERROR (0x10) from libcouchbase, received 0 from operating system”}{“subsystem”:“htconfig”,“srcfile”:"…/deps/lcb/src/bucketconfig/bc_http.cc",“srcline”:331,“level”:“error”,“message”:"<110.212.23.1:8091> (CTX=0x3618490,bc_http) HTTP Provi
der timed out waiting for I/O"}{“subsystem”:“connection”,“srcfile”:"…/deps/lcb/src/lcbio/connect.cc",“srcline”:474,“level”:“info”,“message”:“ydd-cbs-0000.ydd-cbs.default.svc:8091 (SOCK=000000007cad28
a3) Starting. Timeout=2000000us”}{“subsystem”:“connection”,“srcfile”:"…/deps/lcb/src/lcbio/connect.cc",“srcline”:147,“level”:“info”,“message”:“ydd-cbs-0000.ydd-cbs.default.svc:8091 (SOCK=000000007cad28
a3) Connected established”}{“subsystem”:“lcbio”,“srcfile”:"…/deps/lcb/src/lcbio/ioutils.cc",“srcline”:112,“level”:“warn”,“message”:“Translating errno=0, lcb=0x2d to NETWORK_ERROR”}
{“subsystem”:“connection”,“srcfile”:"…/deps/lcb/src/lcbio/connect.cc",“srcline”:108,“level”:“info”,“message”:“ydd-cbs-0000.ydd-cbs.default.svc:8091 (SOCK=000000007cad28
a3) Couldn’t set TCP_NODELAY”}{“subsystem”:“connection”,“srcfile”:"…/deps/lcb/src/lcbio/connect.cc",“srcline”:474,“level”:“info”,“message”:“ydd-cbs-0001.ydd-cbs.default.svc:11210 (SOCK=000000000cf44
c38) Starting. Timeout=2500000us”}{“subsystem”:“connection”,“srcfile”:"…/deps/lcb/src/lcbio/connect.cc",“srcline”:147,“level”:“info”,“message”:“ydd-cbs-0001.ydd-cbs.default.svc:11210 (SOCK=000000000cf44
c38) Connected established”}{“subsystem”:“lcbio”,“srcfile”:"…/deps/lcb/src/lcbio/ioutils.cc",“srcline”:112,“level”:“warn”,“message”:“Translating errno=0, lcb=0x2d to NETWORK_ERROR”}
{“subsystem”:“connection”,“srcfile”:"…/deps/lcb/src/lcbio/connect.cc",“srcline”:108,“level”:“info”,“message”:“ydd-cbs-0001.ydd-cbs.default.svc:11210 (SOCK=000000000cf44
c38) Couldn’t set TCP_NODELAY”}{“subsystem”:“lcbio”,“srcfile”:"…/deps/lcb/src/lcbio/ioutils.cc",“srcline”:112,“level”:“warn”,“message”:“Translating errno=0, lcb=0x2d to NETWORK_ERROR”}
{“subsystem”:“negotiation”,“srcfile”:"…/deps/lcb/src/mcserver/negotiate.cc",“srcline”:154,“level”:“error”,“message”:“ydd-cbs-0001.ydd-cbs.default.svc:11210 (CTX=0x3672c
30,sasl,SASLREQ=0x361c310) Error: 0x10, IO Error”}{“subsystem”:“server”,“srcfile”:"…/deps/lcb/src/mcserver/mcserver.cc",“srcline”:777,“level”:“error”,“message”:“NOHOST:NOPORT (CTX=(nil),SRV=0x36180a0,IX=1) Connection
attempt failed. Received LCB_NETWORK_ERROR (0x10) from libcouchbase, received 0 from operating system”}{“subsystem”:“connection”,“srcfile”:"…/deps/lcb/src/lcbio/connect.cc",“srcline”:474,“level”:“info”,“message”:“ydd-cbs-0001.ydd-cbs.default.svc:11210 (SOCK=0000000020ec9
cf9) Starting. Timeout=2500000us”}{“subsystem”:“connection”,“srcfile”:"…/deps/lcb/src/lcbio/connect.cc",“srcline”:147,“level”:“info”,“message”:“ydd-cbs-0001.ydd-cbs.default.svc:11210 (SOCK=0000000020ec9
cf9) Connected established”}{“subsystem”:“lcbio”,“srcfile”:"…/deps/lcb/src/lcbio/ioutils.cc",“srcline”:112,“level”:“warn”,“message”:“Translating errno=0, lcb=0x2d to NETWORK_ERROR”}
{“subsystem”:“connection”,“srcfile”:"…/deps/lcb/src/lcbio/connect.cc",“srcline”:108,“level”:“info”,“message”:“ydd-cbs-0001.ydd-cbs.default.svc:11210 (SOCK=0000000020ec9
cf9) Couldn’t set TCP_NODELAY”}{“subsystem”:“lcbio”,“srcfile”:"…/deps/lcb/src/lcbio/ioutils.cc",“srcline”:112,“level”:“warn”,“message”:“Translating errno=0, lcb=0x2d to NETWORK_ERROR”}
{“subsystem”:“negotiation”,“srcfile”:"…/deps/lcb/src/mcserver/negotiate.cc",“srcline”:154,“level”:“error”,“message”:“ydd-cbs-0001.ydd-cbs.default.svc:11210 (CTX=0x3672c
30,sasl,SASLREQ=0x361c310) Error: 0x10, IO Error”}{“subsystem”:“server”,“srcfile”:"…/deps/lcb/src/mcserver/mcserver.cc",“srcline”:777,“level”:“error”,“message”:“NOHOST:NOPORT (CTX=(nil),SRV=0x36180a0,IX=1) Connection
attempt failed. Received LCB_NETWORK_ERROR (0x10) from libcouchbase, received 0 from operating system”}{“subsystem”:“retryq”,“srcfile”:"…/deps/lcb/src/retryq.cc",“srcline”:162,“level”:“warn”,“message”:“Failing command (seq=0) from retry queue: LCB_NETWORK_ERROR (0x10)”}

repl:3
throw err;
^
CouchbaseError: Generic network failure. Enable detailed error codes (via LCB_CNTL_DETAILED_ERRCODES, or via detailed_errcodes in the connection string) and/or enable lo
gging to get more information

I already open the 8091/8092/8093/11210/11211 ports from firewall and expose from pods.

how can I resolve this error?

thanks!

          best regards!