Restore Data not work couchbase 5.0.1 community edition


#1

Hello, i am trying to restore buckup on a separate node with command

~/opt/couchbase/bin/./cbrestore  ~/backup-couch-18.09.01 --bucket-source=bucket_tokens --bucket-destination=bucket_tokens   http://localhost:8091 -u Administrator -p password -vvvvvvv

I’ve create the bucket *bucket_tokens * in the target…

2018-09-18 18:05:26,265: mt cbrestore…
2018-09-18 18:05:26,265: mt source : /backup-couch-18.09.01
2018-09-18 18:05:26,266: mt sink : http://localhost:8091
2018-09-18 18:05:26,266: mt opts : {‘username’: ‘’, ‘verbose’: 7, ‘extra’: {‘max_retry’: 10.0, ‘rehash’: 0.0, ‘dcp_consumer_queue_length’: 1000.0, ‘data_only’: 0.0, ‘uncompress’: 0.0, ‘nmv_retry’: 1.0, ‘conflict_resolve’: 1.0, ‘cbb_max_mb’: 100000.0, ‘report’: 5.0, ‘mcd_compatible’: 1.0, ‘try_xwm’: 1.0, ‘backoff_cap’: 10.0, ‘batch_max_bytes’: 400000.0, ‘report_full’: 2000.0, ‘flow_control’: 1.0, ‘batch_max_size’: 1000.0, ‘seqno’: 0.0, ‘design_doc_only’: 0.0, ‘allow_recovery_vb_remap’: 0.0, ‘recv_min_bytes’: 4096.0}, ‘collection’: None, ‘ssl’: False, ‘threads’: 4, ‘to_date’: None, ‘key’: None, ‘password’: ‘’, ‘id’: None, ‘bucket_source’: ‘bucket_tokens’, ‘silent’: False, ‘dry_run’: False, ‘from_date’: None, ‘bucket_destination’: ‘restore_bucket’, ‘add’: False, ‘vbucket_list’: None, ‘separator’: ‘::’}
2018-09-18 18:05:26,266: mt source_class: <class ‘pump_bfd.BFDSource’>
2018-09-18 18:05:26,266: mt sink_class: <class ‘pump_cb.CBSink’>
2018-09-18 18:05:26,273: mt Starting new HTTP connection (1): localhost
2018-09-18 18:05:26,289: mt “GET /pools/default/buckets HTTP/1.1” 200 39521
2018-09-18 18:05:26,295: mt source_bucket: bucket_tokens
2018-09-18 18:05:26,295: mt sink_bucket: restore_bucket
error: missing bucket-destination: restore_bucket at destination: http://localhost:8091; perhaps your username/password is missing or incorrect

what am I doing wrong? Login and password for connection api is correct

I have tried add cli args -x rehash=1 this dont helped me

I use this build
Couchbase-server-community-5.0.1-centos7


#2

Hello @vga21,

error: missing bucket-destination: restore_bucket at destination: http://localhost:8091; perhaps your username/password is missing or incorrect

Given that the previous REST API request is returning HTTP 200 status would suggest that the username/password is good.

Does bucket bucket_tokens exist on the target cluster?


#3

Hello, thx so much, You gave me an idea. My bucket is called tokens and not bucket_tokens