RHEL8/Centos8 Support?

Hello,

Does Couchbase support RHEL8/CentOS8? According to Redhat it sounds like it does, but I am having some trouble.

I am trying to setup Couchbase on CentOS8 minimal server install using the installing using Yum instructions in Couchbase’s documentation, replacing yum with dnf.

First Error: Error: Failed to synchronize cache for repo ‘couchbase-sdk’

I realized this was because it was trying to resolve: ‘http://packages.couchbase.com/rpm/%SDK_VERSION%/x86_64

I went to /etc/yum.repos.d/couchbase-Base.repo on the CentOS7 VM that I had installed Couchbase on and copied and pasted what was in place of “%SDK_VERSION%” (and the two %SERVER_VERSION entries) there - “7.” This resolved the first error on the CentOS8 VM. However when I tried to dnf install couchbase-server, I got this error:

Error:
Problem: cannot install the best candidate for the job

  • nothing provides /usr/bin/python needed by couchbase-server-6.0.3-2895.x86_64

output of ls /usr/bin/py:*
[root@localhost ~]# ls /usr/bin/py*
/usr/bin/pydoc3.6 /usr/bin/pyvenv-3.6

I tried to dnf install python2 and python36, and then cp’d each of them to /usr/bin/python, but neither worked.

Any assistance anyone could provide would be greatly appreciated. Thanks so much.