Ruby client connection refused using node_list


#1

Looks like a bug! It’s definitely fixed in later developer preview versions (I confirmed it works with 1.2.0dp6), but it was not working for me for couchbase gems 1.1.2 & 1.1.3. I was getting similar error: Connection failed: Connection refused (error=0x17) (Couchbase::Error::Connect).
I’ll notify avsej, thanks for reporting this!!


#2

This looks like it’s formed right. Maybe the syntax got changed. I will confirm with avsej and try it out myself…
Just to be complete, which gem version are you using? i.e. did you gem install couchbase? or gem install couchbase --pre?
Thanks!


#3

Hi, i’m using 1.1.2.
I did “gem install couchbase” it was like 2 weeks ago.
I noticed there is a new version (1.1.3) released 3 days ago, but as for the release/commit notes I don’t think it is there now, right?
Thanks and please do keep me posted.
best regards.


#4

hi guys. node_list feature isn’t accessible in couchbase 1.1.x branch http://rubydoc.info/gems/couchbase/Couchbase/Bucket#initialize-instance_
and as documentation for preview version says http://rubydoc.info/github/couchbase/couchbase-ruby-client/Couchbase/Buc… node_list option accepts array of hosts with optional ports


#5

I have set up couchbase on 2 servers(192.168.56.4 & 192.168.56.5) both in the same bucket(default). I’m able to connect to each individually, but not when passing the node_list arg as shown below:
It connnects when I do so:
client = Couchbase.connect(“http://192.168.56.4:8091/pools/default”)
OR
client = Couchbase.connect(“http://192.168.56.5:8091/pools/default”)
but I get a refuse connection error when I try:
c = Couchbase.connect( :pool => “default”, :port => 8091, :node_list => [‘http://192.168.56.4’, ‘http://192.168.56.5’])
OR
c = Couchbase.connect( :pool => “default”, :port => 8091, :node_list => [‘192.168.56.4’, ‘192.168.56.5’])
OR
c = Couchbase.connect( :pool => “default”, :node_list => [‘http://192.168.56.4:8091’, ‘http://192.168.56.5:8091’])
AND with other combinations that I have tried…
I was taking a look on the client source code and couldn’t find anything related to this node_list arg. Is it still supported(since we can still find this option on the documentation)?
So, any ideas on what am I doing wrong?
BTW, just in case anyone asks, they seem to be working properly when it comes to replicate the data between themselves.
Thanks.


#6

Brilliant!!
after installing the preview version it worked like a charm.
Thank you guys!