Ruby Daili with 5.0


#1

We are testing the upgrade from 4.6. to 5.0, we have a memcache bucket. But either we get no server available or Dalli::DalliError: Error authenticating: 32

How do we configure CB 5.0 memache with no auth or dali to use it?


#2

Dalli is memcached client, have you tried couchbase-ruby-client?


#3

It worked before the upgrade to CB5.0, and it works Rails.cache.XXX and we use couchbase-ruby-client to connect to other CB buckets, but I excepted if we create a memache type bucket, it would work with other memcache clients, is this not the case?


#4

Couchbase 5.0 improved security, so old clients will not work.

What is Rails.cache.XXX? Have you tried
https://github.com/couchbase/couchbase-ruby-client/blob/master/lib/active_support/cache/couchbase_store.rb