Running sync_gateway


#1

to start sync gateway through cmd, I receive following errors:
and I am unable to start my sync gateway,
I run following command to cmd: "sync_gateway -url http://207.98.0.0:8091"
kindly help

errors are following:
C:\Program Files (x86)\Couchbase>sync_gateway -url http://207.98.0.0:8091
18:18:47.115308 ==== Couchbase Sync Gateway/1.0.4(34;04138fd) ====
18:18:47.116285 Configured Go to use all 4 CPUs; setenv GOMAXPROCS to override t
his
18:18:47.116285 WARNING: Error setting MaxFileDescriptors to 5000: Unsupported o
n Windows – rest.setMaxFileDescriptors() at config.go:378
18:18:47.116285 Opening db /sync_gateway as bucket “sync_gateway”, pool “default
”, server http://207.98.0.0:8091
18:18:47.116285 Opening Couchbase database sync_gateway on <http://207.98.0.0
:8091>
18:19:12.953985 WARNING: Error installing Couchbase design doc: Put http://192.1
68.2.102:8092/sync_gateway/_design/sync_gateway: dial tcp 192.168.2.102:8092: Co
nnectEx tcp: A connection attempt failed because the connected party did not pro
perly respond after a period of time, or established connection failed because c
onnected host has failed to respond. – db.installViews() at database.go:291
18:19:33.955444 WARNING: Error installing Couchbase design doc: Put http://192.1
68.2.102:8092/sync_gateway/_design/sync_housekeeping: dial tcp 192.168.2.102:809
2: ConnectEx tcp: A connection attempt failed because the connected party did no
t properly respond after a period of time, or established connection failed beca
use connected host has failed to respond. – db.installViews() at database.go:30
5
18:19:33.955444 FATAL: Error opening database: Put http://192.168.2.102:8092/syn
c_gateway/_design/sync_housekeeping: dial tcp 192.168.2.102:8092: ConnectEx tcp:
A connection attempt failed because the connected party did not properly respon
d after a period of time, or established connection failed because connected hos
t has failed to respond. – rest.RunServer() at config.go:415


#2

Can you start sync_gateway with the default parameters?

$ ./sync_gateway -url http://localhost:8091

http://developer.couchbase.com/mobile/develop/guides/sync-gateway/getting-started-with-sync-gateway/starting-sync-gateway/index.html


#3

yes I can start sync_gateway on my local machine
I run this in cmd : sync_gateway -url http://localhost:8091
sync gateway starts


#4

Have you checked firewall and port settings for the remote CB Server?
From the error message it could look like that there is a connection error to the cluster at 192.168.2.102