Safeguarding Timeout at startup


#1

@daschl

Having problems connecting to Couchbase (Timeout with safeguarding) when we start several (7) processes simultaneously. This causes our application to fail to start up. If we slow the cadence of the startup, all services start up properly. This appears like it could be https://issues.couchbase.com/browse/JVMCBC-453 which looks like it will be fixed in Couchbase Core 1.6.0 / Java client 2.6.0. Can you confirm? When will that be released?

Logs (redacted / modified /filtered) will be the next 3 comments - can’t upload .log files.

Thanks!


#2

{“timestamp”:“2018-04-04T17:28:48.727Z”,“level”:“DEBUG”,“thread”:“main”,“logger”:“com.couchbase.client.core.logging.CouchbaseLoggerFactory”,“message”:“Using SLF4J as the default logging framework”,“context”:“default”}
{“timestamp”:“2018-04-04T17:28:48.810Z”,“level”:“DEBUG”,“thread”:“main”,“logger”:“com.couchbase.client.deps.io.netty.util.internal.logging.InternalLoggerFactory”,“message”:“Using SLF4J as the default logging framework”,“context”:“default”}
{“timestamp”:“2018-04-04T17:29:29.529Z”,“level”:“DEBUG”,“thread”:“main”,“logger”:“com.couchbase.client.deps.io.netty.channel.MultithreadEventLoopGroup”,“message”:"-Dio.netty.eventLoopThreads: 8",“context”:“default”}
{“timestamp”:“2018-04-04T17:29:30.317Z”,“level”:“DEBUG”,“thread”:“main”,“logger”:“com.couchbase.client.deps.io.netty.util.internal.PlatformDependent”,“message”:"-Dio.netty.noUnsafe: false",“context”:“default”}
{“timestamp”:“2018-04-04T17:29:30.488Z”,“level”:“DEBUG”,“thread”:“main”,“logger”:“com.couchbase.client.deps.io.netty.util.internal.PlatformDependent0”,“message”:“java.nio.Buffer.address: available”,“context”:“default”}
{“timestamp”:“2018-04-04T17:29:30.489Z”,“level”:“DEBUG”,“thread”:“main”,“logger”:“com.couchbase.client.deps.io.netty.util.internal.PlatformDependent0”,“message”:“sun.misc.Unsafe.theUnsafe: available”,“context”:“default”}
{“timestamp”:“2018-04-04T17:29:30.489Z”,“level”:“DEBUG”,“thread”:“main”,“logger”:“com.couchbase.client.deps.io.netty.util.internal.PlatformDependent0”,“message”:“sun.misc.Unsafe.copyMemory: available”,“context”:“default”}
{“timestamp”:“2018-04-04T17:29:30.490Z”,“level”:“DEBUG”,“thread”:“main”,“logger”:“com.couchbase.client.deps.io.netty.util.internal.PlatformDependent0”,“message”:“direct buffer constructor: available”,“context”:“default”}
{“timestamp”:“2018-04-04T17:29:30.491Z”,“level”:“DEBUG”,“thread”:“main”,“logger”:“com.couchbase.client.deps.io.netty.util.internal.PlatformDependent0”,“message”:“java.nio.Bits.unaligned: available, true”,“context”:“default”}
{“timestamp”:“2018-04-04T17:29:30.491Z”,“level”:“DEBUG”,“thread”:“main”,“logger”:“com.couchbase.client.deps.io.netty.util.internal.PlatformDependent0”,“message”:“java.nio.DirectByteBuffer.(long, int): available”,“context”:“default”}
{“timestamp”:“2018-04-04T17:29:30.492Z”,“level”:“DEBUG”,“thread”:“main”,“logger”:“com.couchbase.client.deps.io.netty.util.internal.Cleaner0”,“message”:“java.nio.ByteBuffer.cleaner(): available”,“context”:“default”}
{“timestamp”:“2018-04-04T17:29:30.493Z”,“level”:“DEBUG”,“thread”:“main”,“logger”:“com.couchbase.client.deps.io.netty.util.internal.PlatformDependent”,“message”:“Java version: 8”,“context”:“default”}
{“timestamp”:“2018-04-04T17:29:30.493Z”,“level”:“DEBUG”,“thread”:“main”,“logger”:“com.couchbase.client.deps.io.netty.util.internal.PlatformDependent”,“message”:“sun.misc.Unsafe: available”,“context”:“default”}
{“timestamp”:“2018-04-04T17:29:30.493Z”,“level”:“DEBUG”,“thread”:“main”,“logger”:“com.couchbase.client.deps.io.netty.util.internal.PlatformDependent”,“message”:"-Dio.netty.noJavassist: false",“context”:“default”}
{“timestamp”:“2018-04-04T17:29:30.494Z”,“level”:“DEBUG”,“thread”:“main”,“logger”:“com.couchbase.client.deps.io.netty.util.internal.PlatformDependent”,“message”:“Javassist: unavailable”,“context”:“default”}
{“timestamp”:“2018-04-04T17:29:30.494Z”,“level”:“DEBUG”,“thread”:“main”,“logger”:“com.couchbase.client.deps.io.netty.util.internal.PlatformDependent”,“message”:“You don’t have Javassist in your class path or you don’t have enough permission to load dynamically generated classes. Please check the configuration for better performance.”,“context”:“default”}
{“timestamp”:“2018-04-04T17:29:30.494Z”,“level”:“DEBUG”,“thread”:“main”,“logger”:“com.couchbase.client.deps.io.netty.util.internal.PlatformDependent”,“message”:"-Dio.netty.tmpdir: /tmp (java.io.tmpdir)",“context”:“default”}
{“timestamp”:“2018-04-04T17:29:30.494Z”,“level”:“DEBUG”,“thread”:“main”,“logger”:“com.couchbase.client.deps.io.netty.util.internal.PlatformDependent”,“message”:"-Dio.netty.bitMode: 64 (sun.arch.data.model)",“context”:“default”}
{“timestamp”:“2018-04-04T17:29:30.494Z”,“level”:“DEBUG”,“thread”:“main”,“logger”:“com.couchbase.client.deps.io.netty.util.internal.PlatformDependent”,“message”:"-Dio.netty.noPreferDirect: false",“context”:“default”}
{“timestamp”:“2018-04-04T17:29:30.494Z”,“level”:“DEBUG”,“thread”:“main”,“logger”:“com.couchbase.client.deps.io.netty.util.internal.PlatformDependent”,“message”:“com.couchbase.client.deps.io.netty.maxDirectMemory: 268435456 bytes”,“context”:“default”}
{“timestamp”:“2018-04-04T17:29:31.023Z”,“level”:“DEBUG”,“thread”:“main”,“logger”:“com.couchbase.client.deps.io.netty.channel.nio.NioEventLoop”,“message”:"-Dio.netty.noKeySetOptimization: false",“context”:“default”}
{“timestamp”:“2018-04-04T17:29:31.103Z”,“level”:“DEBUG”,“thread”:“main”,“logger”:“com.couchbase.client.deps.io.netty.channel.nio.NioEventLoop”,“message”:"-Dio.netty.selectorAutoRebuildThreshold: 512",“context”:“default”}
{“timestamp”:“2018-04-04T17:29:31.178Z”,“level”:“DEBUG”,“thread”:“main”,“logger”:“com.couchbase.client.deps.io.netty.util.internal.PlatformDependent”,“message”:“org.jctools-core.MpscChunkedArrayQueue: available”,“context”:“default”}
{“timestamp”:“2018-04-04T17:29:41.615Z”,“level”:“INFO”,“thread”:“main”,“logger”:“com.couchbase.client.core.CouchbaseCore”,“message”:“CouchbaseEnvironment: {sslEnabled=false, sslKeystoreFile=‘null’, sslKeystorePassword=false, sslKeystore=null, bootstrapHttpEnabled=true, bootstrapCarrierEnabled=true, bootstrapHttpDirectPort=8091, bootstrapHttpSslPort=18091, bootstrapCarrierDirectPort=11210, bootstrapCarrierSslPort=11207, ioPoolSize=4, computationPoolSize=4, responseBufferSize=16384, requestBufferSize=16384, kvServiceEndpoints=1, viewServiceEndpoints=12, queryServiceEndpoints=12, searchServiceEndpoints=12, ioPool=NioEventLoopGroup, kvIoPool=null, viewIoPool=null, searchIoPool=null, queryIoPool=null, coreScheduler=CoreScheduler, memcachedHashingStrategy=DefaultMemcachedHashingStrategy, eventBus=DefaultEventBus, packageNameAndVersion=couchbase-java-client/2.4.3 (git: 2.4.3, core: 1.4.3), dcpEnabled=false, retryStrategy=BestEffort, maxRequestLifetime=75000, retryDelay=ExponentialDelay{growBy 1.0 MICROSECONDS, powers of 2; lower=100, upper=100000}, reconnectDelay=ExponentialDelay{growBy 1.0 MILLISECONDS, powers of 2; lower=32, upper=4096}, observeIntervalDelay=ExponentialDelay{growBy 1.0 MICROSECONDS, powers of 2; lower=10, upper=100000}, keepAliveInterval=30000, autoreleaseAfter=2000, bufferPoolingEnabled=true, tcpNodelayEnabled=true, mutationTokensEnabled=false, socketConnectTimeout=1000, dcpConnectionBufferSize=20971520, dcpConnectionBufferAckThreshold=0.2, dcpConnectionName=dcp/core-io, callbacksOnIoPool=false, disconnectTimeout=25000, requestBufferWaitStrategy=com.couchbase.client.core.env.DefaultCoreEnvironment$2@20326436, queryTimeout=10000, viewTimeout=75000, searchTimeout=75000, analyticsTimeout=75000, kvTimeout=10000, connectTimeout=10000, dnsSrvEnabled=false}”,“context”:“default”}
{“timestamp”:“2018-04-04T17:29:41.639Z”,“level”:“DEBUG”,“thread”:“main”,“logger”:“com.couchbase.client.core.CouchbaseCore”,“message”:“Diagnostics {\n gc.g1 old generation.collectionCount=0,\n gc.g1 old generation.collectionTime=0,\n gc.g1 young generation.collectionCount=37,\n gc.g1 young generation.collectionTime=6228,\n heap.pendingFinalize=0,\n heap.used=init = 33554432(32768K) used = 79015408(77163K) committed = 248512512(242688K) max = 268435456(262144K),\n mem.physical.free=20385689600,\n mem.physical.total=33669763072,\n mem.swap.free=2138918912,\n mem.swap.total=2147479552,\n mem.virtual.comitted=3900100608,\n offHeap.used=init = 2555904(2496K) used = 62721216(61251K) committed = 63885312(62388K) max = -1(-1K),\n proc.cpu.time=48740000000,\n runtime.name=29262@ap20-wiz16-001.company.com,\n runtime.spec=Oracle Corporation/Java Virtual Machine Specification: 1.8,\n runtime.startTime=1522862802567,\n runtime.sysProperties={awt.toolkit=sun.awt.X11.XToolkit, file.encoding.pkg=sun.io, java.specification.version=1.8, com.couchbase.client.deps.io.netty.packagePrefix=com.couchbase.client.deps., sun.cpu.isalist=, sun.jnu.encoding=ANSI_X3.4-1968, com.sun.management.jmxremote.authenticate=false, java.class.path=/path/to/service/service.jar:/services/newrelic/java/newrelic.jar, java.vm.vendor=Oracle Corporation, sun.arch.data.model=64, java.vendor.url=http://java.oracle.com/, user.timezone=UTC, os.name=Linux, java.vm.specification.version=1.8, user.country=US, sun.java.launcher=SUN_STANDARD, com.newrelic.agent.deps.org.apache.commons.logging.LogFactory=com.newrelic.agent.logging.ApacheCommonsAdaptingLogFactory, sun.boot.library.path=/usr/java/jdk1.8.0_101/jre/lib/amd64, com.sun.management.jmxremote.ssl=false, sun.java.command=/path/to/service/service.jar server /path/to/service/S452.yaml, com.sun.management.jmxremote=, sun.cpu.endian=little, user.home=/root, user.language=en, java.specification.vendor=Oracle Corporation, java.home=/usr/java/jdk1.8.0_101/jre, file.separator=/, line.separator=\n, java.vm.specification.vendor=Oracle Corporation, java.specification.name=Java Platform API Specification, java.awt.graphicsenv=sun.awt.X11GraphicsEnvironment, newrelic.config.file=/path/to/service/1.0.23/configs/newrelic.yml, newrelic.environment=alpha, logback.configurationFile=/path/to/service/S452.logback.xml, sun.boot.class.path=/usr/java/jdk1.8.0_101/jre/lib/resources.jar:/usr/java/jdk1.8.0_101/jre/lib/rt.jar:/usr/java/jdk1.8.0_101/jre/lib/sunrsasign.jar:/usr/java/jdk1.8.0_101/jre/lib/jsse.jar:/usr/java/jdk1.8.0_101/jre/lib/jce.jar:/usr/java/jdk1.8.0_101/jre/lib/charsets.jar:/usr/java/jdk1.8.0_101/jre/lib/jfr.jar:/usr/java/jdk1.8.0_101/jre/classes, java.util.logging.config.file=/path/to/service/configs/jmx_logging.properties, sun.management.compiler=HotSpot 64-Bit Tiered Compilers, java.runtime.version=1.8.0_101-b13, user.name=root, path.separator=:, os.version=2.6.32-696.16.1.el6.x86_64, java.endorsed.dirs=/usr/java/jdk1.8.0_101/jre/lib/endorsed, java.runtime.name=Java™ SE Runtime Environment, file.encoding=UTF-8, sun.nio.ch.bugLevel=, java.vm.name=Java HotSpot™ 64-Bit Server VM, deploymentName=S452, java.vendor.url.bug=http://bugreport.sun.com/bugreport/, java.io.tmpdir=/tmp, com.sun.management.jmxremote.port=0, java.version=1.8.0_101, user.dir=/path/to/service, os.arch=amd64, java.vm.specification.name=Java Virtual Machine Specification, java.awt.printerjob=sun.print.PSPrinterJob, sun.os.patch.level=unknown, java.library.path=/usr/java/packages/lib/amd64:/usr/lib64:/lib64:/lib:/usr/lib, java.vm.info=mixed mode, java.vendor=Oracle Corporation, java.vm.version=25.101-b13, java.rmi.server.randomIDs=true, java.rmi.server.hostname=ap20-wiz16-001.company.com, java.ext.dirs=/usr/java/jdk1.8.0_101/jre/lib/ext:/usr/java/packages/lib/ext, sun.io.unicode.encoding=UnicodeLittle, java.class.version=52.0},\n runtime.uptime=179673,\n runtime.vm=Oracle Corporation/Java HotSpot™ 64-Bit Server VM: 25.101-b13,\n sys.cpu.loadAvg=48.58,\n sys.cpu.num=4,\n sys.os.arch=amd64,\n sys.os.name=Linux,\n sys.os.version=2.6.32-696.16.1.el6.x86_64,\n thread.count=38,\n thread.peakCount=38,\n thread.startedCount=54\n}”,“context”:“default”}
{“timestamp”:“2018-04-04T17:29:43.025Z”,“level”:“DEBUG”,“thread”:“main”,“logger”:“com.couchbase.client.core.config.ConfigurationProvider”,“message”:“Setting seed hosts to [/1.1.14.155, /1.1.18.208, /1.1.12.243]”,“context”:“default”}
{“timestamp”:“2018-04-04T17:29:43.356Z”,“level”:“DEBUG”,“thread”:“main”,“logger”:“com.couchbase.client.core.config.ConfigurationProvider”,“message”:“Got instructed to open bucket volatile1”,“context”:“default”}
{“timestamp”:“2018-04-04T17:29:43.465Z”,“level”:“DEBUG”,“thread”:“main”,“logger”:“com.couchbase.client.core.config.loader.Loader”,“message”:“Loading Config for bucket volatile1”,“context”:“default”}
{“timestamp”:“2018-04-04T17:29:43.541Z”,“level”:“DEBUG”,“thread”:“main”,“logger”:“com.couchbase.client.core.config.loader.Loader”,“message”:“Loading Config for bucket volatile1”,“context”:“default”}
{“timestamp”:“2018-04-04T17:29:43.823Z”,“level”:“DEBUG”,“thread”:“main”,“logger”:“com.couchbase.client.core.RequestHandler”,“message”:“Got instructed to add Node 1-1-14-155.company.com/1.1.14.155",“context”:"default”}
{“timestamp”:“2018-04-04T17:29:43.823Z”,“level”:“DEBUG”,“thread”:“main”,“logger”:“com.couchbase.client.core.RequestHandler”,“message”:“Connecting Node 1-1-14155.company.com/1.1.14.155",“context”:"default”}
{“timestamp”:“2018-04-04T17:29:43.823Z”,“level”:“DEBUG”,“thread”:“main”,“logger”:“com.couchbase.client.core.node.Node”,“message”:"[1-1-14-155.company.com]: Got instructed to connect.",“context”:“default”}
{“timestamp”:“2018-04-04T17:29:43.913Z”,“level”:“DEBUG”,“thread”:“main”,“logger”:“com.couchbase.client.core.RequestHandler”,“message”:“Connect finished, registering for use.”,“context”:“default”}
{“timestamp”:“2018-04-04T17:29:43.975Z”,“level”:“DEBUG”,“thread”:“cb-computations-2”,“logger”:“com.couchbase.client.core.config.loader.Loader”,“message”:“Successfully added Node 1-1-14-155.company.com/1.1.14.155",“context”:"default”}
{“timestamp”:“2018-04-04T17:29:43.977Z”,“level”:“DEBUG”,“thread”:“cb-computations-2”,“logger”:“com.couchbase.client.core.RequestHandler”,“message”:“Got instructed to add Service BINARY, to Node 1-1-14-155.company.com/1.1.14.155",“context”:"default”}
{“timestamp”:“2018-04-04T17:29:43.977Z”,“level”:“DEBUG”,“thread”:“cb-computations-2”,“logger”:“com.couchbase.client.core.node.Node”,“message”:"[1-1-14-155.company.com]: Adding Service BINARY",“context”:“default”}
{“timestamp”:“2018-04-04T17:29:43.979Z”,“level”:“DEBUG”,“thread”:“cb-computations-2”,“logger”:“com.couchbase.client.core.service.ServiceFactory”,“message”:“New Services are enabled”,“context”:“default”}
{“timestamp”:“2018-04-04T17:29:43.997Z”,“level”:“DEBUG”,“thread”:“main”,“logger”:“com.couchbase.client.core.config.loader.Loader”,“message”:“Loading Config for bucket volatile1”,“context”:“default”}
{“timestamp”:“2018-04-04T17:29:43.997Z”,“level”:“DEBUG”,“thread”:“main”,“logger”:“com.couchbase.client.core.config.loader.Loader”,“message”:“Loading Config for bucket volatile1”,“context”:“default”}
{“timestamp”:“2018-04-04T17:29:44.008Z”,“level”:“DEBUG”,“thread”:“main”,“logger”:“com.couchbase.client.core.RequestHandler”,“message”:“Got instructed to add Node 1-1-18-208.company.com/1.1.18.208",“context”:"default”}
{“timestamp”:“2018-04-04T17:29:44.009Z”,“level”:“DEBUG”,“thread”:“main”,“logger”:“com.couchbase.client.core.RequestHandler”,“message”:“Connecting Node 1-1-18-208.company.com/1.1.18.208",“context”:"default”}
{“timestamp”:“2018-04-04T17:29:44.009Z”,“level”:“DEBUG”,“thread”:“main”,“logger”:“com.couchbase.client.core.node.Node”,“message”:"[1-1-18-208.company.com]: Got instructed to connect.",“context”:“default”}
{“timestamp”:“2018-04-04T17:29:44.010Z”,“level”:“DEBUG”,“thread”:“main”,“logger”:“com.couchbase.client.core.RequestHandler”,“message”:“Connect finished, registering for use.”,“context”:“default”}
{“timestamp”:“2018-04-04T17:29:43.988Z”,“level”:“DEBUG”,“thread”:“cb-computations-2”,“logger”:“com.couchbase.client.core.node.Node”,“message”:"[1-1-14-155.company.com]: Adding Service BINARY to registry and connecting it.",“context”:“default”}
{“timestamp”:“2018-04-04T17:29:44.042Z”,“level”:“DEBUG”,“thread”:“main”,“logger”:“com.couchbase.client.core.config.loader.Loader”,“message”:“Loading Config for bucket volatile1”,“context”:“default”}
{“timestamp”:“2018-04-04T17:29:44.042Z”,“level”:“DEBUG”,“thread”:“main”,“logger”:“com.couchbase.client.core.config.loader.Loader”,“message”:“Loading Config for bucket volatile1”,“context”:“default”}
{“timestamp”:“2018-04-04T17:29:44.043Z”,“level”:“DEBUG”,“thread”:“cb-computations-2”,“logger”:“com.couchbase.client.core.service.Service”,“message”:"[1-1-14-155.company.com][KeyValueService]: Got instructed to connect.",“context”:“default”}
{“timestamp”:“2018-04-04T17:29:44.044Z”,“level”:“DEBUG”,“thread”:“main”,“logger”:“com.couchbase.client.core.RequestHandler”,“message”:“Got instructed to add Node 1-1-12-243.company.com/1.1.12.243",“context”:"default”}
{“timestamp”:“2018-04-04T17:29:44.059Z”,“level”:“DEBUG”,“thread”:“main”,“logger”:“com.couchbase.client.core.RequestHandler”,“message”:“Connecting Node 1-1-12-243.company.com/1.1.12.243",“context”:"default”}
{“timestamp”:“2018-04-04T17:29:44.059Z”,“level”:“DEBUG”,“thread”:“main”,“logger”:“com.couchbase.client.core.node.Node”,“message”:"[1-1-12-243.company.com]: Got instructed to connect.",“context”:“default”}
{“timestamp”:“2018-04-04T17:29:44.059Z”,“level”:“DEBUG”,“thread”:“main”,“logger”:“com.couchbase.client.core.RequestHandler”,“message”:“Connect finished, registering for use.”,“context”:“default”}
{“timestamp”:“2018-04-04T17:29:44.043Z”,“level”:“DEBUG”,“thread”:“cb-computations-3”,“logger”:“com.couchbase.client.core.config.loader.Loader”,“message”:“Successfully added Node 1-1-18-208.company.com/1.1.18.208",“context”:"default”}
{“timestamp”:“2018-04-04T17:29:44.059Z”,“level”:“DEBUG”,“thread”:“cb-computations-3”,“logger”:“com.couchbase.client.core.RequestHandler”,“message”:“Got instructed to add Service BINARY, to Node 1-1-18-208.company.com/1.1.18.208",“context”:"default”}
{“timestamp”:“2018-04-04T17:29:44.059Z”,“level”:“DEBUG”,“thread”:“cb-computations-3”,“logger”:“com.couchbase.client.core.node.Node”,“message”:"[1-1-18-208.company.com]: Adding Service BINARY",“context”:“default”}
{“timestamp”:“2018-04-04T17:29:44.061Z”,“level”:“DEBUG”,“thread”:“cb-computations-3”,“logger”:“com.couchbase.client.core.node.Node”,“message”:"[1-1-18-208.company.com]: Adding Service BINARY to registry and connecting it.",“context”:“default”}
{“timestamp”:“2018-04-04T17:29:44.061Z”,“level”:“DEBUG”,“thread”:“cb-computations-3”,“logger”:“com.couchbase.client.core.service.Service”,“message”:"[1-1-18-208.company.com][KeyValueService]: Got instructed to connect.",“context”:“default”}
{“timestamp”:“2018-04-04T17:29:44.069Z”,“level”:“DEBUG”,“thread”:“cb-computations-4”,“logger”:“com.couchbase.client.core.config.loader.Loader”,“message”:“Successfully added Node 1-1-12-243.company.com/1.1.12.243",“context”:"default”}
{“timestamp”:“2018-04-04T17:29:44.069Z”,“level”:“DEBUG”,“thread”:“cb-computations-4”,“logger”:“com.couchbase.client.core.RequestHandler”,“message”:“Got instructed to add Service BINARY, to Node 1-1-12-243.company.com/1.1.12.243",“context”:"default”}
{“timestamp”:“2018-04-04T17:29:44.072Z”,“level”:“DEBUG”,“thread”:“cb-computations-4”,“logger”:“com.couchbase.client.core.node.Node”,“message”:"[1-1-12-243.company.com]: Adding Service BINARY",“context”:“default”}
{“timestamp”:“2018-04-04T17:29:44.072Z”,“level”:“DEBUG”,“thread”:“cb-computations-4”,“logger”:“com.couchbase.client.core.node.Node”,“message”:"[1-1-12-243.company.com]: Adding Service BINARY to registry and connecting it.",“context”:“default”}
{“timestamp”:“2018-04-04T17:29:44.072Z”,“level”:“DEBUG”,“thread”:“cb-computations-4”,“logger”:“com.couchbase.client.core.service.Service”,“message”:"[1-1-12-243.company.com][KeyValueService]: Got instructed to connect.",“context”:“default”}
{“timestamp”:“2018-04-04T17:29:44.283Z”,“level”:“DEBUG”,“thread”:“cb-computations-2”,“logger”:“com.couchbase.client.core.endpoint.Endpoint”,“message”:“Using a connectCallbackGracePeriod of 2000 on Endpoint 1-1-14-155.company.com:11210”,“context”:“default”}
{“timestamp”:“2018-04-04T17:29:44.335Z”,“level”:“DEBUG”,“thread”:“cb-computations-3”,“logger”:“com.couchbase.client.core.endpoint.Endpoint”,“message”:“Using a connectCallbackGracePeriod of 2000 on Endpoint 1-1-18-208.company.com:11210”,“context”:“default”}
{“timestamp”:“2018-04-04T17:29:44.434Z”,“level”:“DEBUG”,“thread”:“cb-computations-4”,“logger”:“com.couchbase.client.core.endpoint.Endpoint”,“message”:“Using a connectCallbackGracePeriod of 2000 on Endpoint 1-1-12-243.company.com:11210”,“context”:“default”}
{“timestamp”:“2018-04-04T17:29:44.824Z”,“level”:“DEBUG”,“thread”:“cb-computations-3”,“logger”:“com.couchbase.client.deps.io.netty.buffer.PooledByteBufAllocator”,“message”:"-Dio.netty.allocator.numHeapArenas: 2",“context”:“default”}
{“timestamp”:“2018-04-04T17:29:44.824Z”,“level”:“DEBUG”,“thread”:“cb-computations-3”,“logger”:“com.couchbase.client.deps.io.netty.buffer.PooledByteBufAllocator”,“message”:"-Dio.netty.allocator.numDirectArenas: 2",“context”:“default”}
{“timestamp”:“2018-04-04T17:29:44.824Z”,“level”:“DEBUG”,“thread”:“cb-computations-3”,“logger”:“com.couchbase.client.deps.io.netty.buffer.PooledByteBufAllocator”,“message”:"-Dio.netty.allocator.pageSize: 8192",“context”:“default”}
{“timestamp”:“2018-04-04T17:29:44.824Z”,“level”:“DEBUG”,“thread”:“cb-computations-3”,“logger”:“com.couchbase.client.deps.io.netty.buffer.PooledByteBufAllocator”,“message”:"-Dio.netty.allocator.maxOrder: 11",“context”:“default”}
{“timestamp”:“2018-04-04T17:29:44.824Z”,“level”:“DEBUG”,“thread”:“cb-computations-3”,“logger”:“com.couchbase.client.deps.io.netty.buffer.PooledByteBufAllocator”,“message”:"-Dio.netty.allocator.chunkSize: 16777216",“context”:“default”}
{“timestamp”:“2018-04-04T17:29:44.824Z”,“level”:“DEBUG”,“thread”:“cb-computations-3”,“logger”:“com.couchbase.client.deps.io.netty.buffer.PooledByteBufAllocator”,“message”:"-Dio.netty.allocator.tinyCacheSize: 512",“context”:“default”}
{“timestamp”:“2018-04-04T17:29:44.824Z”,“level”:“DEBUG”,“thread”:“cb-computations-3”,“logger”:“com.couchbase.client.deps.io.netty.buffer.PooledByteBufAllocator”,“message”:"-Dio.netty.allocator.smallCacheSize: 256",“context”:“default”}
{“timestamp”:“2018-04-04T17:29:44.824Z”,“level”:“DEBUG”,“thread”:“cb-computations-3”,“logger”:“com.couchbase.client.deps.io.netty.buffer.PooledByteBufAllocator”,“message”:"-Dio.netty.allocator.normalCacheSize: 64",“context”:“default”}
{“timestamp”:“2018-04-04T17:29:44.824Z”,“level”:“DEBUG”,“thread”:“cb-computations-3”,“logger”:“com.couchbase.client.deps.io.netty.buffer.PooledByteBufAllocator”,“message”:"-Dio.netty.allocator.maxCachedBufferCapacity: 32768",“context”:“default”}
{“timestamp”:“2018-04-04T17:29:44.824Z”,“level”:“DEBUG”,“thread”:“cb-computations-3”,“logger”:“com.couchbase.client.deps.io.netty.buffer.PooledByteBufAllocator”,“message”:"-Dio.netty.allocator.cacheTrimInterval: 8192",“context”:“default”}
{“timestamp”:“2018-04-04T17:29:44.824Z”,“level”:“DEBUG”,“thread”:“cb-computations-3”,“logger”:“com.couchbase.client.deps.io.netty.buffer.PooledByteBufAllocator”,“message”:"-Dio.netty.allocator.useCacheForAllThreads",“context”:“default”}
{“timestamp”:“2018-04-04T17:29:46.028Z”,“level”:“DEBUG”,“thread”:“cb-computations-2”,“logger”:“com.couchbase.client.core.service.Service”,“message”:"[1-1-14-155.company.com][KeyValueService]: New number of endpoints is 1",“context”:“default”}
{“timestamp”:“2018-04-04T17:29:46.031Z”,“level”:“DEBUG”,“thread”:“cb-computations-3”,“logger”:“com.couchbase.client.core.service.Service”,“message”:"[1-1-18-208.company.com][KeyValueService]: New number of endpoints is 1",“context”:“default”}
{“timestamp”:“2018-04-04T17:29:46.031Z”,“level”:“DEBUG”,“thread”:“cb-computations-4”,“logger”:“com.couchbase.client.core.service.Service”,“message”:"[1-1-12-243.company.com][KeyValueService]: New number of endpoints is 1",“context”:“default”}
{“timestamp”:“2018-04-04T17:29:46.039Z”,“level”:“DEBUG”,“thread”:“cb-computations-2”,“logger”:“com.couchbase.client.core.service.Service”,“message”:"[1-1-14-155.company.com][KeyValueService]: Connecting Endpoint during Service connect.",“context”:“default”}
{“timestamp”:“2018-04-04T17:29:46.045Z”,“level”:“DEBUG”,“thread”:“cb-computations-3”,“logger”:“com.couchbase.client.core.service.Service”,“message”:"[1-1-18-208.company.com][KeyValueService]: Connecting Endpoint during Service connect.",“context”:“default”}
{“timestamp”:“2018-04-04T17:29:46.045Z”,“level”:“DEBUG”,“thread”:“cb-computations-4”,“logger”:“com.couchbase.client.core.service.Service”,“message”:"[1-1-12-243.company.com][KeyValueService]: Connecting Endpoint during Service connect.",“context”:“default”}
{“timestamp”:“2018-04-04T17:29:48.137Z”,“level”:“DEBUG”,“thread”:“cb-computations-3”,“logger”:“com.couchbase.client.deps.io.netty.util.internal.ThreadLocalRandom”,“message”:"-Dio.netty.initialSeedUniquifier: 0x266c7cb1e7fa3079 (took 0 ms)",“context”:“default”}
{“timestamp”:“2018-04-04T17:29:48.541Z”,“level”:“DEBUG”,“thread”:“cb-computations-4”,“logger”:“com.couchbase.client.deps.io.netty.buffer.ByteBufUtil”,“message”:"-Dio.netty.allocator.type: unpooled",“context”:“default”}
{“timestamp”:“2018-04-04T17:29:48.574Z”,“level”:“DEBUG”,“thread”:“cb-computations-4”,“logger”:“com.couchbase.client.deps.io.netty.buffer.ByteBufUtil”,“message”:"-Dio.netty.threadLocalDirectBufferSize: 65536",“context”:“default”}
{“timestamp”:“2018-04-04T17:29:48.574Z”,“level”:“DEBUG”,“thread”:“cb-computations-4”,“logger”:“com.couchbase.client.deps.io.netty.buffer.ByteBufUtil”,“message”:"-Dio.netty.maxThreadLocalCharBufferSize: 16384",“context”:“default”}
{“timestamp”:“2018-04-04T17:29:50.013Z”,“level”:“DEBUG”,“thread”:“cb-io-1-1”,“logger”:“com.couchbase.client.deps.io.netty.util.Recycler”,“message”:"-Dio.netty.recycler.maxCapacity.default: 32768",“context”:“default”}
{“timestamp”:“2018-04-04T17:29:50.013Z”,“level”:“DEBUG”,“thread”:“cb-io-1-1”,“logger”:“com.couchbase.client.deps.io.netty.util.Recycler”,“message”:"-Dio.netty.recycler.maxSharedCapacityFactor: 2",“context”:“default”}
{“timestamp”:“2018-04-04T17:29:50.013Z”,“level”:“DEBUG”,“thread”:“cb-io-1-1”,“logger”:“com.couchbase.client.deps.io.netty.util.Recycler”,“message”:"-Dio.netty.recycler.linkCapacity: 16",“context”:“default”}
{“timestamp”:“2018-04-04T17:29:50.013Z”,“level”:“DEBUG”,“thread”:“cb-io-1-1”,“logger”:“com.couchbase.client.deps.io.netty.util.Recycler”,“message”:"-Dio.netty.recycler.ratio: 8",“context”:“default”}
{“timestamp”:“2018-04-04T17:29:50.243Z”,“level”:“DEBUG”,“thread”:“cb-io-1-2”,“logger”:“com.couchbase.client.deps.io.netty.buffer.AbstractByteBuf”,“message”:"-Dcom.couchbase.client.deps.io.netty.buffer.bytebuf.checkAccessible: true",“context”:“default”}
{“timestamp”:“2018-04-04T17:29:50.248Z”,“level”:“DEBUG”,“thread”:“cb-io-1-2”,“logger”:“com.couchbase.client.deps.io.netty.util.ResourceLeakDetector”,“message”:"-Dcom.couchbase.client.deps.io.netty.leakDetection.level: simple",“context”:“default”}
{“timestamp”:“2018-04-04T17:29:50.248Z”,“level”:“DEBUG”,“thread”:“cb-io-1-2”,“logger”:“com.couchbase.client.deps.io.netty.util.ResourceLeakDetector”,“message”:"-Dcom.couchbase.client.deps.io.netty.leakDetection.maxRecords: 4",“context”:“default”}
{“timestamp”:“2018-04-04T17:29:50.248Z”,“level”:“DEBUG”,“thread”:“cb-io-1-2”,“logger”:“com.couchbase.client.deps.io.netty.util.ResourceLeakDetectorFactory”,“message”:“Loaded default ResourceLeakDetector: com.couchbase.client.deps.io.netty.util.ResourceLeakDetector@5e349000”,“context”:“default”}
{“timestamp”:“2018-04-04T17:29:50.770Z”,“level”:“WARN”,“thread”:“RxComputationScheduler-2”,“logger”:“com.couchbase.client.core.endpoint.Endpoint”,“message”:"[null][KeyValueEndpoint]: Socket connect took longer than specified timeout.",“context”:“default”}
{“timestamp”:“2018-04-04T17:29:50.716Z”,“level”:“WARN”,“thread”:“RxComputationScheduler-1”,“logger”:“com.couchbase.client.core.endpoint.Endpoint”,“message”:"[null][KeyValueEndpoint]: Socket connect took longer than specified timeout.",“context”:“default”}
{“timestamp”:“2018-04-04T17:29:51.426Z”,“level”:“DEBUG”,“thread”:“RxComputationScheduler-2”,“logger”:“com.couchbase.client.core.node.Node”,“message”:“Disconnected (CONNECTING) from Node 1-1-18-208.company.com/1.1.18.208",“context”:"default”}
{“timestamp”:“2018-04-04T17:29:51.425Z”,“level”:“WARN”,“thread”:“RxComputationScheduler-3”,“logger”:“com.couchbase.client.core.endpoint.Endpoint”,“message”:"[null][KeyValueEndpoint]: Socket connect took longer than specified timeout.",“context”:“default”}
{“timestamp”:“2018-04-04T17:29:52.125Z”,“level”:“DEBUG”,“thread”:“RxComputationScheduler-3”,“logger”:“com.couchbase.client.core.node.Node”,“message”:“Disconnected (CONNECTING) from Node 1-1-14-155.company.com/1.1.14.155",“context”:"default”}
{“timestamp”:“2018-04-04T17:29:52.125Z”,“level”:“DEBUG”,“thread”:“cb-computations-4”,“logger”:“com.couchbase.client.core.config.ConfigurationProvider”,“message”:“Received signal to proactively refresh (a maybe outdated) configuration.”,“context”:“default”}
{“timestamp”:“2018-04-04T17:29:52.125Z”,“level”:“DEBUG”,“thread”:“cb-computations-4”,“logger”:“com.couchbase.client.core.config.ConfigurationProvider”,“message”:“Ignoring outdated signal, since no buckets are open.”,“context”:“default”}
{“timestamp”:“2018-04-04T17:29:52.126Z”,“level”:“DEBUG”,“thread”:“RxComputationScheduler-1”,“logger”:“com.couchbase.client.core.node.Node”,“message”:“Disconnected (CONNECTING) from Node 1-1-12-243.company.com/1.1.12.243",“context”:"default”}
{“timestamp”:“2018-04-04T17:29:52.145Z”,“level”:“DEBUG”,“thread”:“cb-computations-3”,“logger”:“com.couchbase.client.core.RequestHandler”,“message”:“Node 1-1-18-208.company.com/1.1.18.208 already registered, skipping.”,“context”:“default”}
{“timestamp”:“2018-04-04T17:29:52.148Z”,“level”:“DEBUG”,“thread”:“cb-computations-4”,“logger”:“com.couchbase.client.core.RequestHandler”,“message”:“Node 1-1-14-155.company.com/1.1.14.155 already registered, skipping.”,“context”:“default”}
{“timestamp”:“2018-04-04T17:29:52.149Z”,“level”:“DEBUG”,“thread”:“cb-computations-1”,“logger”:“com.couchbase.client.core.config.loader.Loader”,“message”:“Successfully added Node 1-1-18-208.company.com/1.1.18.208",“context”:"default”}
{“timestamp”:“2018-04-04T17:29:52.149Z”,“level”:“DEBUG”,“thread”:“cb-computations-1”,“logger”:“com.couchbase.client.core.RequestHandler”,“message”:“Got instructed to add Service CONFIG, to Node 1-1-18-208.company.com/1.1.18.208",“context”:"default”}


#3

{“timestamp”:“2018-04-04T17:29:52.149Z”,“level”:“DEBUG”,“thread”:“cb-computations-1”,“logger”:“com.couchbase.client.core.node.Node”,“message”:"[1-1-18-208.company.com]: Adding Service CONFIG",“context”:“default”}
{“timestamp”:“2018-04-04T17:29:52.156Z”,“level”:“DEBUG”,“thread”:“cb-computations-1”,“logger”:“com.couchbase.client.core.node.Node”,“message”:"[1-1-18-208.company.com]: Adding Service CONFIG to registry and connecting it.",“context”:“default”}
{“timestamp”:“2018-04-04T17:29:52.157Z”,“level”:“DEBUG”,“thread”:“cb-computations-1”,“logger”:“com.couchbase.client.core.service.Service”,“message”:"[1-1-18-208.company.com][ConfigService]: Got instructed to connect.",“context”:“default”}
{“timestamp”:“2018-04-04T17:29:52.199Z”,“level”:“DEBUG”,“thread”:“cb-computations-2”,“logger”:“com.couchbase.client.core.RequestHandler”,“message”:“Node 1-1-12-243.company.com/1.1.12.243 already registered, skipping.”,“context”:“default”}
{“timestamp”:“2018-04-04T17:29:52.200Z”,“level”:“DEBUG”,“thread”:“cb-computations-2”,“logger”:“com.couchbase.client.core.config.loader.Loader”,“message”:“Successfully added Node 1-1-14-155.company.com/1.1.14.155",“context”:"default”}
{“timestamp”:“2018-04-04T17:29:52.200Z”,“level”:“DEBUG”,“thread”:“cb-computations-2”,“logger”:“com.couchbase.client.core.RequestHandler”,“message”:“Got instructed to add Service CONFIG, to Node 1-1-14-155.company.com/1.1.14.155",“context”:"default”}
{“timestamp”:“2018-04-04T17:29:52.200Z”,“level”:“DEBUG”,“thread”:“cb-computations-2”,“logger”:“com.couchbase.client.core.node.Node”,“message”:"[1-1-14-155.company.com]: Adding Service CONFIG",“context”:“default”}
{“timestamp”:“2018-04-04T17:29:52.200Z”,“level”:“DEBUG”,“thread”:“cb-computations-2”,“logger”:“com.couchbase.client.core.node.Node”,“message”:"[1-1-14-155.company.com]: Adding Service CONFIG to registry and connecting it.",“context”:“default”}
{“timestamp”:“2018-04-04T17:29:52.200Z”,“level”:“DEBUG”,“thread”:“cb-computations-2”,“logger”:“com.couchbase.client.core.service.Service”,“message”:"[1-1-14-155.company.com][ConfigService]: Got instructed to connect.",“context”:“default”}
{“timestamp”:“2018-04-04T17:29:52.200Z”,“level”:“DEBUG”,“thread”:“cb-computations-3”,“logger”:“com.couchbase.client.core.config.loader.Loader”,“message”:“Successfully added Node 1-1-12-243.company.com/1.1.12.243",“context”:"default”}
{“timestamp”:“2018-04-04T17:29:52.200Z”,“level”:“DEBUG”,“thread”:“cb-computations-3”,“logger”:“com.couchbase.client.core.RequestHandler”,“message”:“Got instructed to add Service CONFIG, to Node 1-1-12-243.company.com/1.1.12.243",“context”:"default”}
{“timestamp”:“2018-04-04T17:29:52.200Z”,“level”:“DEBUG”,“thread”:“cb-computations-3”,“logger”:“com.couchbase.client.core.node.Node”,“message”:"[1-1-12-243.company.com]: Adding Service CONFIG",“context”:“default”}
{“timestamp”:“2018-04-04T17:29:52.200Z”,“level”:“DEBUG”,“thread”:“cb-computations-3”,“logger”:“com.couchbase.client.core.node.Node”,“message”:"[1-1-12-243.company.com]: Adding Service CONFIG to registry and connecting it.",“context”:“default”}
{“timestamp”:“2018-04-04T17:29:52.200Z”,“level”:“DEBUG”,“thread”:“cb-computations-3”,“logger”:“com.couchbase.client.core.service.Service”,“message”:"[1-1-12-243.company.com][ConfigService]: Got instructed to connect.",“context”:“default”}
{“timestamp”:“2018-04-04T17:29:52.204Z”,“level”:“DEBUG”,“thread”:“cb-computations-4”,“logger”:“com.couchbase.client.core.config.loader.Loader”,“message”:“Successfully enabled Service CONFIG on Node 1-1-18-208.company.com/1.1.18.208",“context”:"default”}
{“timestamp”:“2018-04-04T17:29:52.204Z”,“level”:“DEBUG”,“thread”:“cb-computations-4”,“logger”:“com.couchbase.client.core.config.loader.HttpLoader”,“message”:“Starting to discover config through HTTP Bootstrap”,“context”:“default”}
{“timestamp”:“2018-04-04T17:29:52.218Z”,“level”:“DEBUG”,“thread”:“cb-core-3-2”,“logger”:“com.couchbase.client.core.endpoint.Endpoint”,“message”:“Using a connectCallbackGracePeriod of 2000 on Endpoint 1-1-18-208.company.com:8091”,“context”:“default”}
{“timestamp”:“2018-04-04T17:29:52.253Z”,“level”:“DEBUG”,“thread”:“cb-computations-1”,“logger”:“com.couchbase.client.core.config.loader.Loader”,“message”:“Successfully enabled Service CONFIG on Node 1-1-12-243.company.com/1.1.12.243",“context”:"default”}
{“timestamp”:“2018-04-04T17:29:52.766Z”,“level”:“DEBUG”,“thread”:“cb-computations-1”,“logger”:“com.couchbase.client.core.config.loader.HttpLoader”,“message”:“Starting to discover config through HTTP Bootstrap”,“context”:“default”}
{“timestamp”:“2018-04-04T17:29:52.778Z”,“level”:“DEBUG”,“thread”:“cb-core-3-2”,“logger”:“com.couchbase.client.core.endpoint.Endpoint”,“message”:“Using a connectCallbackGracePeriod of 2000 on Endpoint 1-1-12-243.company.com:8091”,“context”:“default”}
{“timestamp”:“2018-04-04T17:29:52.857Z”,“level”:“DEBUG”,“thread”:“cb-computations-2”,“logger”:“com.couchbase.client.core.config.loader.Loader”,“message”:“Successfully enabled Service CONFIG on Node 1-1-14-155.company.com/1.1.14.155",“context”:"default”}
{“timestamp”:“2018-04-04T17:29:52.858Z”,“level”:“DEBUG”,“thread”:“cb-computations-2”,“logger”:“com.couchbase.client.core.config.loader.HttpLoader”,“message”:“Starting to discover config through HTTP Bootstrap”,“context”:“default”}
{“timestamp”:“2018-04-04T17:29:53.308Z”,“level”:“DEBUG”,“thread”:“cb-core-3-2”,“logger”:“com.couchbase.client.core.endpoint.Endpoint”,“message”:“Using a connectCallbackGracePeriod of 2000 on Endpoint 1-1-14-155.company.com:8091”,“context”:“default”}
{“timestamp”:“2018-04-04T17:29:54.093Z”,“level”:“WARN”,“thread”:“main”,“logger”:“org.eclipse.jetty.util.component.AbstractLifeCycle”,“message”:“FAILED com.company.couch2.CouchbaseClientManager@7cc742d: java.lang.RuntimeException: java.util.concurrent.TimeoutException”,“context”:“default”,“exception”:“java.lang.RuntimeException: java.util.concurrent.TimeoutException\n\tat com.couchbase.client.core.utils.Blocking.blockForSingle(Blocking.java:74)\n\tat com.couchbase.client.java.CouchbaseCluster.openBucket(CouchbaseCluster.java:310)\n\tat com.couchbase.client.java.CouchbaseCluster.openBucket(CouchbaseCluster.java:294)\n\tat com.couchbase.client.java.CouchbaseCluster.openBucket(CouchbaseCluster.java:283)\n\tat com.company.couch2.CouchbaseClientManager.lambda$initializeBuckets$3(CouchbaseClientManager.java:160)\n\tat java.util.Iterator.forEachRemaining(Iterator.java:116)\n\tat java.util.Spliterators$IteratorSpliterator.forEachRemaining(Spliterators.java:1801)\n\tat java.util.stream.ReferencePipeline$Head.forEach(ReferencePipeline.java:580)\n\tat com.company.couch2.CouchbaseClientManager.initializeBuckets(CouchbaseClientManager.java:154)\n\tat com.company.couch2.CouchbaseClientManager.lambda$start$1(CouchbaseClientManager.java:87)\n\tat java.util.Iterator.forEachRemaining(Iterator.java:116)\n\tat java.util.Spliterators$IteratorSpliterator.forEachRemaining(Spliterators.java:1801)\n\tat java.util.stream.ReferencePipeline$Head.forEach(ReferencePipeline.java:580)\n\tat com.company.couch2.CouchbaseClientManager.start(CouchbaseClientManager.java:71)\n\tat io.dropwizard.lifecycle.JettyManaged.doStart(JettyManaged.java:27)\n\tat org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:69)\n\tat org.eclipse.jetty.util.component.ContainerLifeCycle.start(ContainerLifeCycle.java:118)\n\tat org.eclipse.jetty.server.Server.start(Server.java:342)\n\tat org.eclipse.jetty.util.component.ContainerLifeCycle.doStart(ContainerLifeCycle.java:100)\n\tat org.eclipse.jetty.server.handler.AbstractHandler.doStart(AbstractHandler.java:60)\n\tat org.eclipse.jetty.server.Server.doStart(Server.java:290)\n\tat org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:69)\n\tat io.dropwizard.cli.ServerCommand.run(ServerCommand.java:43)\n\tat io.dropwizard.cli.EnvironmentCommand.run(EnvironmentCommand.java:43)\n\tat io.dropwizard.cli.ConfiguredCommand.run(ConfiguredCommand.java:76)\n\tat io.dropwizard.cli.Cli.run(Cli.java:70)\n\tat io.dropwizard.Application.run(Application.java:72)\n\tat com.company.sqlcdcrelay.SqlCdcRelayServiceApplication.main(SqlCdcRelayServiceApplication.java:248)\nCaused by: java.util.concurrent.TimeoutException: null\n\t… 28 common frames omitted\n”}
{“timestamp”:“2018-04-04T17:29:54.097Z”,“level”:“WARN”,“thread”:“main”,“logger”:“org.eclipse.jetty.util.component.AbstractLifeCycle”,“message”:“FAILED org.eclipse.jetty.server.Server@678f685f: java.lang.RuntimeException: java.util.concurrent.TimeoutException”,“context”:“default”,“exception”:“java.lang.RuntimeException: java.util.concurrent.TimeoutException\n\tat com.couchbase.client.core.utils.Blocking.blockForSingle(Blocking.java:74)\n\tat com.couchbase.client.java.CouchbaseCluster.openBucket(CouchbaseCluster.java:310)\n\tat com.couchbase.client.java.CouchbaseCluster.openBucket(CouchbaseCluster.java:294)\n\tat com.couchbase.client.java.CouchbaseCluster.openBucket(CouchbaseCluster.java:283)\n\tat com.company.couch2.CouchbaseClientManager.lambda$initializeBuckets$3(CouchbaseClientManager.java:160)\n\tat java.util.Iterator.forEachRemaining(Iterator.java:116)\n\tat java.util.Spliterators$IteratorSpliterator.forEachRemaining(Spliterators.java:1801)\n\tat java.util.stream.ReferencePipeline$Head.forEach(ReferencePipeline.java:580)\n\tat com.company.couch2.CouchbaseClientManager.initializeBuckets(CouchbaseClientManager.java:154)\n\tat com.company.couch2.CouchbaseClientManager.lambda$start$1(CouchbaseClientManager.java:87)\n\tat java.util.Iterator.forEachRemaining(Iterator.java:116)\n\tat java.util.Spliterators$IteratorSpliterator.forEachRemaining(Spliterators.java:1801)\n\tat java.util.stream.ReferencePipeline$Head.forEach(ReferencePipeline.java:580)\n\tat com.company.couch2.CouchbaseClientManager.start(CouchbaseClientManager.java:71)\n\tat io.dropwizard.lifecycle.JettyManaged.doStart(JettyManaged.java:27)\n\tat org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:69)\n\tat org.eclipse.jetty.util.component.ContainerLifeCycle.start(ContainerLifeCycle.java:118)\n\tat org.eclipse.jetty.server.Server.start(Server.java:342)\n\tat org.eclipse.jetty.util.component.ContainerLifeCycle.doStart(ContainerLifeCycle.java:100)\n\tat org.eclipse.jetty.server.handler.AbstractHandler.doStart(AbstractHandler.java:60)\n\tat org.eclipse.jetty.server.Server.doStart(Server.java:290)\n\tat org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:69)\n\tat io.dropwizard.cli.ServerCommand.run(ServerCommand.java:43)\n\tat io.dropwizard.cli.EnvironmentCommand.run(EnvironmentCommand.java:43)\n\tat io.dropwizard.cli.ConfiguredCommand.run(ConfiguredCommand.java:76)\n\tat io.dropwizard.cli.Cli.run(Cli.java:70)\n\tat io.dropwizard.Application.run(Application.java:72)\n\tat com.company.sqlcdcrelay.SqlCdcRelayServiceApplication.main(SqlCdcRelayServiceApplication.java:248)\nCaused by: java.util.concurrent.TimeoutException: null\n\t… 28 common frames omitted\n”}
{“timestamp”:“2018-04-04T17:29:54.101Z”,“level”:“ERROR”,“thread”:“main”,“logger”:“io.dropwizard.cli.ServerCommand”,“message”:“Unable to start server, shutting down”,“context”:“default”,“exception”:“java.lang.RuntimeException: java.util.concurrent.TimeoutException\n\tat com.couchbase.client.core.utils.Blocking.blockForSingle(Blocking.java:74)\n\tat com.couchbase.client.java.CouchbaseCluster.openBucket(CouchbaseCluster.java:310)\n\tat com.couchbase.client.java.CouchbaseCluster.openBucket(CouchbaseCluster.java:294)\n\tat com.couchbase.client.java.CouchbaseCluster.openBucket(CouchbaseCluster.java:283)\n\tat com.company.couch2.CouchbaseClientManager.lambda$initializeBuckets$3(CouchbaseClientManager.java:160)\n\tat java.util.Iterator.forEachRemaining(Iterator.java:116)\n\tat java.util.Spliterators$IteratorSpliterator.forEachRemaining(Spliterators.java:1801)\n\tat java.util.stream.ReferencePipeline$Head.forEach(ReferencePipeline.java:580)\n\tat com.company.couch2.CouchbaseClientManager.initializeBuckets(CouchbaseClientManager.java:154)\n\tat com.company.couch2.CouchbaseClientManager.lambda$start$1(CouchbaseClientManager.java:87)\n\tat java.util.Iterator.forEachRemaining(Iterator.java:116)\n\tat java.util.Spliterators$IteratorSpliterator.forEachRemaining(Spliterators.java:1801)\n\tat java.util.stream.ReferencePipeline$Head.forEach(ReferencePipeline.java:580)\n\tat com.company.couch2.CouchbaseClientManager.start(CouchbaseClientManager.java:71)\n\tat io.dropwizard.lifecycle.JettyManaged.doStart(JettyManaged.java:27)\n\tat org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:69)\n\tat org.eclipse.jetty.util.component.ContainerLifeCycle.start(ContainerLifeCycle.java:118)\n\tat org.eclipse.jetty.server.Server.start(Server.java:342)\n\tat org.eclipse.jetty.util.component.ContainerLifeCycle.doStart(ContainerLifeCycle.java:100)\n\tat org.eclipse.jetty.server.handler.AbstractHandler.doStart(AbstractHandler.java:60)\n\tat org.eclipse.jetty.server.Server.doStart(Server.java:290)\n\tat org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:69)\n\tat io.dropwizard.cli.ServerCommand.run(ServerCommand.java:43)\n\tat io.dropwizard.cli.EnvironmentCommand.run(EnvironmentCommand.java:43)\n\tat io.dropwizard.cli.ConfiguredCommand.run(ConfiguredCommand.java:76)\n\tat io.dropwizard.cli.Cli.run(Cli.java:70)\n\tat io.dropwizard.Application.run(Application.java:72)\n\tat com.company.sqlcdcrelay.SqlCdcRelayServiceApplication.main(SqlCdcRelayServiceApplication.java:248)\nCaused by: java.util.concurrent.TimeoutException: null\n\t… 28 common frames omitted\n”}

{“timestamp”:“2018-04-04T17:29:56.412Z”,“level”:“WARN”,“thread”:“RxComputationScheduler-2”,“logger”:“com.couchbase.client.core.endpoint.Endpoint”,“message”:"[null][KeyValueEndpoint]: Socket connect took longer than specified timeout.",“context”:“default”}
{“timestamp”:“2018-04-04T17:29:56.413Z”,“level”:“WARN”,“thread”:“RxComputationScheduler-2”,“logger”:“com.couchbase.client.core.endpoint.Endpoint”,“message”:“Error during reconnect: “,“context”:“default”,“exception”:“com.couchbase.client.deps.io.netty.channel.ConnectTimeoutException: Connect callback did not return, hit safeguarding timeout.\n\tat com.couchbase.client.core.endpoint.AbstractEndpoint$3.call(AbstractEndpoint.java:337)\n\tat com.couchbase.client.core.endpoint.AbstractEndpoint$3.call(AbstractEndpoint.java:330)\n\tat rx.internal.operators.SingleOperatorOnErrorResumeNext$2.onError(SingleOperatorOnErrorResumeNext.java:69)\n\tat rx.Single$18.onError(Single.java:1883)\n\tat rx.observers.SafeSubscriber._onError(SafeSubscriber.java:152)\n\tat rx.observers.SafeSubscriber.onError(SafeSubscriber.java:115)\n\tat rx.observers.SerializedObserver.onError(SerializedObserver.java:153)\n\tat rx.observers.SerializedSubscriber.onError(SerializedSubscriber.java:78)\n\tat rx.internal.operators.OperatorTimeoutBase$TimeoutSubscriber$1.onError(OperatorTimeoutBase.java:187)\n\tat rx.Single$1$1.onError(Single.java:85)\n\tat rx.Single$3.call(Single.java:505)\n\tat rx.Single$3.call(Single.java:501)\n\tat rx.Single$1.call(Single.java:90)\n\tat rx.Single$1.call(Single.java:70)\n\tat rx.Observable.unsafeSubscribe(Observable.java:9860)\n\tat rx.internal.operators.OperatorTimeoutBase$TimeoutSubscriber.onTimeout(OperatorTimeoutBase.java:200)\n\tat rx.internal.operators.OperatorTimeout$1$1.call(OperatorTimeout.java:41)\n\tat rx.internal.schedulers.EventLoopsScheduler$EventLoopWorker$2.call(EventLoopsScheduler.java:189)\n\tat rx.internal.schedulers.ScheduledAction.run(ScheduledAction.java:55)\n\tat java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)\n\tat java.util.concurrent.FutureTask.run(FutureTask.java:266)\n\tat java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$201(ScheduledThreadPoolExecutor.java:180)\n\tat java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:293)\n\tat java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)\n\tat java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)\n\tat java.lang.Thread.run(Thread.java:745)\n”}
{“timestamp”:“2018-04-04T17:29:56.413Z”,“level”:“WARN”,“thread”:“RxComputationScheduler-2”,“logger”:“com.couchbase.client.core.endpoint.Endpoint”,“message”:”[null][KeyValueEndpoint]: Could not connect to endpoint, retrying with delay 32 MILLISECONDS: “,“context”:“default”,“exception”:“com.couchbase.client.deps.io.netty.channel.ConnectTimeoutException: Connect callback did not return, hit safeguarding timeout.\n\tat com.couchbase.client.core.endpoint.AbstractEndpoint$3.call(AbstractEndpoint.java:337)\n\tat com.couchbase.client.core.endpoint.AbstractEndpoint$3.call(AbstractEndpoint.java:330)\n\tat rx.internal.operators.SingleOperatorOnErrorResumeNext$2.onError(SingleOperatorOnErrorResumeNext.java:69)\n\tat rx.Single$18.onError(Single.java:1883)\n\tat rx.observers.SafeSubscriber._onError(SafeSubscriber.java:152)\n\tat rx.observers.SafeSubscriber.onError(SafeSubscriber.java:115)\n\tat rx.observers.SerializedObserver.onError(SerializedObserver.java:153)\n\tat rx.observers.SerializedSubscriber.onError(SerializedSubscriber.java:78)\n\tat rx.internal.operators.OperatorTimeoutBase$TimeoutSubscriber$1.onError(OperatorTimeoutBase.java:187)\n\tat rx.Single$1$1.onError(Single.java:85)\n\tat rx.Single$3.call(Single.java:505)\n\tat rx.Single$3.call(Single.java:501)\n\tat rx.Single$1.call(Single.java:90)\n\tat rx.Single$1.call(Single.java:70)\n\tat rx.Observable.unsafeSubscribe(Observable.java:9860)\n\tat rx.internal.operators.OperatorTimeoutBase$TimeoutSubscriber.onTimeout(OperatorTimeoutBase.java:200)\n\tat rx.internal.operators.OperatorTimeout$1$1.call(OperatorTimeout.java:41)\n\tat rx.internal.schedulers.EventLoopsScheduler$EventLoopWorker$2.call(EventLoopsScheduler.java:189)\n\tat rx.internal.schedulers.ScheduledAction.run(ScheduledAction.java:55)\n\tat java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)\n\tat java.util.concurrent.FutureTask.run(FutureTask.java:266)\n\tat java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$201(ScheduledThreadPoolExecutor.java:180)\n\tat java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:293)\n\tat java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)\n\tat java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)\n\tat java.lang.Thread.run(Thread.java:745)\n”}
{“timestamp”:“2018-04-04T17:29:56.415Z”,“level”:“WARN”,“thread”:“RxComputationScheduler-1”,“logger”:“com.couchbase.client.core.endpoint.Endpoint”,“message”:”[null][KeyValueEndpoint]: Socket connect took longer than specified timeout.”,“context”:“default”}
{“timestamp”:“2018-04-04T17:29:56.416Z”,“level”:“WARN”,“thread”:“RxComputationScheduler-1”,“logger”:“com.couchbase.client.core.endpoint.Endpoint”,“message”:“Error during reconnect: “,“context”:“default”,“exception”:“com.couchbase.client.deps.io.netty.channel.ConnectTimeoutException: Connect callback did not return, hit safeguarding timeout.\n\tat com.couchbase.client.core.endpoint.AbstractEndpoint$3.call(AbstractEndpoint.java:337)\n\tat com.couchbase.client.core.endpoint.AbstractEndpoint$3.call(AbstractEndpoint.java:330)\n\tat rx.internal.operators.SingleOperatorOnErrorResumeNext$2.onError(SingleOperatorOnErrorResumeNext.java:69)\n\tat rx.Single$18.onError(Single.java:1883)\n\tat rx.observers.SafeSubscriber._onError(SafeSubscriber.java:152)\n\tat rx.observers.SafeSubscriber.onError(SafeSubscriber.java:115)\n\tat rx.observers.SerializedObserver.onError(SerializedObserver.java:153)\n\tat rx.observers.SerializedSubscriber.onError(SerializedSubscriber.java:78)\n\tat rx.internal.operators.OperatorTimeoutBase$TimeoutSubscriber$1.onError(OperatorTimeoutBase.java:187)\n\tat rx.Single$1$1.onError(Single.java:85)\n\tat rx.Single$3.call(Single.java:505)\n\tat rx.Single$3.call(Single.java:501)\n\tat rx.Single$1.call(Single.java:90)\n\tat rx.Single$1.call(Single.java:70)\n\tat rx.Observable.unsafeSubscribe(Observable.java:9860)\n\tat rx.internal.operators.OperatorTimeoutBase$TimeoutSubscriber.onTimeout(OperatorTimeoutBase.java:200)\n\tat rx.internal.operators.OperatorTimeout$1$1.call(OperatorTimeout.java:41)\n\tat rx.internal.schedulers.EventLoopsScheduler$EventLoopWorker$2.call(EventLoopsScheduler.java:189)\n\tat rx.internal.schedulers.ScheduledAction.run(ScheduledAction.java:55)\n\tat java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)\n\tat java.util.concurrent.FutureTask.run(FutureTask.java:266)\n\tat java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$201(ScheduledThreadPoolExecutor.java:180)\n\tat java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:293)\n\tat java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)\n\tat java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)\n\tat java.lang.Thread.run(Thread.java:745)\n”}
{“timestamp”:“2018-04-04T17:29:56.416Z”,“level”:“WARN”,“thread”:“RxComputationScheduler-1”,“logger”:“com.couchbase.client.core.endpoint.Endpoint”,“message”:”[null][KeyValueEndpoint]: Could not connect to endpoint, retrying with delay 32 MILLISECONDS: “,“context”:“default”,“exception”:“com.couchbase.client.deps.io.netty.channel.ConnectTimeoutException: Connect callback did not return, hit safeguarding timeout.\n\tat com.couchbase.client.core.endpoint.AbstractEndpoint$3.call(AbstractEndpoint.java:337)\n\tat com.couchbase.client.core.endpoint.AbstractEndpoint$3.call(AbstractEndpoint.java:330)\n\tat rx.internal.operators.SingleOperatorOnErrorResumeNext$2.onError(SingleOperatorOnErrorResumeNext.java:69)\n\tat rx.Single$18.onError(Single.java:1883)\n\tat rx.observers.SafeSubscriber._onError(SafeSubscriber.java:152)\n\tat rx.observers.SafeSubscriber.onError(SafeSubscriber.java:115)\n\tat rx.observers.SerializedObserver.onError(SerializedObserver.java:153)\n\tat rx.observers.SerializedSubscriber.onError(SerializedSubscriber.java:78)\n\tat rx.internal.operators.OperatorTimeoutBase$TimeoutSubscriber$1.onError(OperatorTimeoutBase.java:187)\n\tat rx.Single$1$1.onError(Single.java:85)\n\tat rx.Single$3.call(Single.java:505)\n\tat rx.Single$3.call(Single.java:501)\n\tat rx.Single$1.call(Single.java:90)\n\tat rx.Single$1.call(Single.java:70)\n\tat rx.Observable.unsafeSubscribe(Observable.java:9860)\n\tat rx.internal.operators.OperatorTimeoutBase$TimeoutSubscriber.onTimeout(OperatorTimeoutBase.java:200)\n\tat rx.internal.operators.OperatorTimeout$1$1.call(OperatorTimeout.java:41)\n\tat rx.internal.schedulers.EventLoopsScheduler$EventLoopWorker$2.call(EventLoopsScheduler.java:189)\n\tat rx.internal.schedulers.ScheduledAction.run(ScheduledAction.java:55)\n\tat java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)\n\tat java.util.concurrent.FutureTask.run(FutureTask.java:266)\n\tat java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$201(ScheduledThreadPoolExecutor.java:180)\n\tat java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:293)\n\tat java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)\n\tat java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)\n\tat java.lang.Thread.run(Thread.java:745)\n”}
{“timestamp”:“2018-04-04T17:29:56.416Z”,“level”:“WARN”,“thread”:“RxComputationScheduler-4”,“logger”:“com.couchbase.client.core.endpoint.Endpoint”,“message”:”[null][KeyValueEndpoint]: Socket connect took longer than specified timeout.”,“context”:“default”}
{“timestamp”:“2018-04-04T17:29:56.417Z”,“level”:“WARN”,“thread”:“RxComputationScheduler-4”,“logger”:“com.couchbase.client.core.endpoint.Endpoint”,“message”:“Error during reconnect: “,“context”:“default”,“exception”:“com.couchbase.client.deps.io.netty.channel.ConnectTimeoutException: Connect callback did not return, hit safeguarding timeout.\n\tat com.couchbase.client.core.endpoint.AbstractEndpoint$3.call(AbstractEndpoint.java:337)\n\tat com.couchbase.client.core.endpoint.AbstractEndpoint$3.call(AbstractEndpoint.java:330)\n\tat rx.internal.operators.SingleOperatorOnErrorResumeNext$2.onError(SingleOperatorOnErrorResumeNext.java:69)\n\tat rx.Single$18.onError(Single.java:1883)\n\tat rx.observers.SafeSubscriber._onError(SafeSubscriber.java:152)\n\tat rx.observers.SafeSubscriber.onError(SafeSubscriber.java:115)\n\tat rx.observers.SerializedObserver.onError(SerializedObserver.java:153)\n\tat rx.observers.SerializedSubscriber.onError(SerializedSubscriber.java:78)\n\tat rx.internal.operators.OperatorTimeoutBase$TimeoutSubscriber$1.onError(OperatorTimeoutBase.java:187)\n\tat rx.Single$1$1.onError(Single.java:85)\n\tat rx.Single$3.call(Single.java:505)\n\tat rx.Single$3.call(Single.java:501)\n\tat rx.Single$1.call(Single.java:90)\n\tat rx.Single$1.call(Single.java:70)\n\tat rx.Observable.unsafeSubscribe(Observable.java:9860)\n\tat rx.internal.operators.OperatorTimeoutBase$TimeoutSubscriber.onTimeout(OperatorTimeoutBase.java:200)\n\tat rx.internal.operators.OperatorTimeout$1$1.call(OperatorTimeout.java:41)\n\tat rx.internal.schedulers.EventLoopsScheduler$EventLoopWorker$2.call(EventLoopsScheduler.java:189)\n\tat rx.internal.schedulers.ScheduledAction.run(ScheduledAction.java:55)\n\tat java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)\n\tat java.util.concurrent.FutureTask.run(FutureTask.java:266)\n\tat java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$201(ScheduledThreadPoolExecutor.java:180)\n\tat java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:293)\n\tat java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)\n\tat java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)\n\tat java.lang.Thread.run(Thread.java:745)\n”}
{“timestamp”:“2018-04-04T17:29:56.417Z”,“level”:“WARN”,“thread”:“RxComputationScheduler-4”,“logger”:“com.couchbase.client.core.endpoint.Endpoint”,“message”:”[null][KeyValueEndpoint]: Could not connect to endpoint, retrying with delay 32 MILLISECONDS: “,“context”:“default”,“exception”:“com.couchbase.client.deps.io.netty.channel.ConnectTimeoutException: Connect callback did not return, hit safeguarding timeout.\n\tat com.couchbase.client.core.endpoint.AbstractEndpoint$3.call(AbstractEndpoint.java:337)\n\tat com.couchbase.client.core.endpoint.AbstractEndpoint$3.call(AbstractEndpoint.java:330)\n\tat rx.internal.operators.SingleOperatorOnErrorResumeNext$2.onError(SingleOperatorOnErrorResumeNext.java:69)\n\tat rx.Single$18.onError(Single.java:1883)\n\tat rx.observers.SafeSubscriber._onError(SafeSubscriber.java:152)\n\tat rx.observers.SafeSubscriber.onError(SafeSubscriber.java:115)\n\tat rx.observers.SerializedObserver.onError(SerializedObserver.java:153)\n\tat rx.observers.SerializedSubscriber.onError(SerializedSubscriber.java:78)\n\tat rx.internal.operators.OperatorTimeoutBase$TimeoutSubscriber$1.onError(OperatorTimeoutBase.java:187)\n\tat rx.Single$1$1.onError(Single.java:85)\n\tat rx.Single$3.call(Single.java:505)\n\tat rx.Single$3.call(Single.java:501)\n\tat rx.Single$1.call(Single.java:90)\n\tat rx.Single$1.call(Single.java:70)\n\tat rx.Observable.unsafeSubscribe(Observable.java:9860)\n\tat rx.internal.operators.OperatorTimeoutBase$TimeoutSubscriber.onTimeout(OperatorTimeoutBase.java:200)\n\tat rx.internal.operators.OperatorTimeout$1$1.call(OperatorTimeout.java:41)\n\tat rx.internal.schedulers.EventLoopsScheduler$EventLoopWorker$2.call(EventLoopsScheduler.java:189)\n\tat rx.internal.schedulers.ScheduledAction.run(ScheduledAction.java:55)\n\tat java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)\n\tat java.util.concurrent.FutureTask.run(FutureTask.java:266)\n\tat java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$201(ScheduledThreadPoolExecutor.java:180)\n\tat java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:293)\n\tat java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)\n\tat java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)\n\tat java.lang.Thread.run(Thread.java:745)\n”}
{“timestamp”:“2018-04-04T17:29:56.518Z”,“level”:“WARN”,“thread”:“RxComputationScheduler-3”,“logger”:“com.couchbase.client.core.endpoint.Endpoint”,“message”:”[null][ConfigEndpoint]: Socket connect took longer than specified timeout.”,“context”:“default”}
{“timestamp”:“2018-04-04T17:29:56.551Z”,“level”:“WARN”,“thread”:“RxComputationScheduler-1”,“logger”:“com.couchbase.client.core.endpoint.Endpoint”,“message”:"[null][ConfigEndpoint]: Socket connect took longer than specified timeout.",“context”:“default”}
{“timestamp”:“2018-04-04T17:29:56.555Z”,“level”:“DEBUG”,“thread”:“cb-core-3-1”,“logger”:“com.couchbase.client.core.config.ConfigurationProvider”,“message”:“Received signal to proactively refresh (a maybe outdated) configuration.”,“context”:“default”}
{“timestamp”:“2018-04-04T17:29:56.555Z”,“level”:“DEBUG”,“thread”:“cb-core-3-1”,“logger”:“com.couchbase.client.core.config.ConfigurationProvider”,“message”:“Ignoring outdated signal, since no buckets are open.”,“context”:“default”}
{“timestamp”:“2018-04-04T17:29:56.555Z”,“level”:“DEBUG”,“thread”:“cb-core-3-1”,“logger”:“com.couchbase.client.core.config.ConfigurationProvider”,“message”:“Received signal to proactively refresh (a maybe outdated) configuration.”,“context”:“default”}
{“timestamp”:“2018-04-04T17:29:56.555Z”,“level”:“DEBUG”,“thread”:“cb-core-3-1”,“logger”:“com.couchbase.client.core.config.ConfigurationProvider”,“message”:“Ignoring outdated signal, since no buckets are open.”,“context”:“default”}
{“timestamp”:“2018-04-04T17:29:56.555Z”,“level”:“DEBUG”,“thread”:“cb-core-3-1”,“logger”:“com.couchbase.client.core.config.ConfigurationProvider”,“message”:“Received signal to proactively refresh (a maybe outdated) configuration.”,“context”:“default”}
{“timestamp”:“2018-04-04T17:29:56.555Z”,“level”:“DEBUG”,“thread”:“cb-core-3-1”,“logger”:“com.couchbase.client.core.config.ConfigurationProvider”,“message”:“Ignoring outdated signal, since no buckets are open.”,“context”:“default”}
{“timestamp”:“2018-04-04T17:29:56.610Z”,“level”:“WARN”,“thread”:“RxComputationScheduler-4”,“logger”:“com.couchbase.client.core.endpoint.Endpoint”,“message”:"[null][ConfigEndpoint]: Socket connect took longer than specified timeout.",“context”:“default”}


#4

{“timestamp”:“2018-04-04T17:30:01.134Z”,“level”:“DEBUG”,“thread”:“cb-io-1-1”,“logger”:“com.couchbase.client.core.endpoint.kv.KeyValueFeatureHandler”,“message”:“Requesting supported features: [TCPNODELAY, XATTR]”,“context”:“default”}
{“timestamp”:“2018-04-04T17:30:01.299Z”,“level”:“DEBUG”,“thread”:“cb-io-1-1”,“logger”:“com.couchbase.client.core.endpoint.kv.KeyValueFeatureHandler”,“message”:“Negotiated supported features: [TCPNODELAY, XATTR]”,“context”:“default”}
{“timestamp”:“2018-04-04T17:30:01.302Z”,“level”:“DEBUG”,“thread”:“cb-io-1-1”,“logger”:“com.couchbase.client.core.endpoint.AbstractGenericHandler”,“message”:"[1-1-14-155.company.com/1.1.14.155:11210][KeyValueEndpoint]: Channel Active.",“context”:“default”}
{“timestamp”:“2018-04-04T17:30:01.887Z”,“level”:“DEBUG”,“thread”:“cb-computations-4”,“logger”:“com.couchbase.client.core.config.ConfigurationProvider”,“message”:“Received signal to proactively refresh (a maybe outdated) configuration.”,“context”:“default”}
{“timestamp”:“2018-04-04T17:30:01.887Z”,“level”:“DEBUG”,“thread”:“cb-computations-4”,“logger”:“com.couchbase.client.core.config.ConfigurationProvider”,“message”:“Ignoring outdated signal, since no buckets are open.”,“context”:“default”}
{“timestamp”:“2018-04-04T17:30:02.620Z”,“level”:“DEBUG”,“thread”:“cb-io-1-1”,“logger”:“com.couchbase.client.core.endpoint.kv.KeyValueFeatureHandler”,“message”:“Requesting supported features: [TCPNODELAY, XATTR]”,“context”:“default”}
{“timestamp”:“2018-04-04T17:30:02.635Z”,“level”:“DEBUG”,“thread”:“cb-io-1-1”,“logger”:“com.couchbase.client.core.endpoint.kv.KeyValueFeatureHandler”,“message”:“Negotiated supported features: [TCPNODELAY, XATTR]”,“context”:“default”}
{“timestamp”:“2018-04-04T17:30:04.068Z”,“level”:“DEBUG”,“thread”:“cb-io-1-1”,“logger”:“com.couchbase.client.core.endpoint.AbstractGenericHandler”,“message”:"[1-1-12-243.company.com/1.1.12.243:11210][KeyValueEndpoint]: Channel Active.",“context”:“default”}
{“timestamp”:“2018-04-04T17:30:04.179Z”,“level”:“DEBUG”,“thread”:“cb-io-1-4”,“logger”:“com.couchbase.client.core.endpoint.kv.KeyValueFeatureHandler”,“message”:“Requesting supported features: [TCPNODELAY, XATTR]”,“context”:“default”}
{“timestamp”:“2018-04-04T17:30:04.347Z”,“level”:“DEBUG”,“thread”:“cb-io-1-4”,“logger”:“com.couchbase.client.core.endpoint.AbstractGenericHandler”,“message”:"[1-1-14-155.company.com/1.1.14.155:8091][ConfigEndpoint]: Channel Active.",“context”:“default”}
{“timestamp”:“2018-04-04T17:30:04.347Z”,“level”:“DEBUG”,“thread”:“cb-io-1-4”,“logger”:“com.couchbase.client.core.endpoint.kv.KeyValueFeatureHandler”,“message”:“Negotiated supported features: [TCPNODELAY, XATTR]”,“context”:“default”}
{“timestamp”:“2018-04-04T17:30:04.347Z”,“level”:“DEBUG”,“thread”:“cb-io-1-4”,“logger”:“com.couchbase.client.core.endpoint.AbstractGenericHandler”,“message”:"[1-1-14-155.company.com/1.1.14.155:11210][KeyValueEndpoint]: Channel Active.",“context”:“default”}
{“timestamp”:“2018-04-04T17:30:04.350Z”,“level”:“DEBUG”,“thread”:“cb-io-1-2”,“logger”:“com.couchbase.client.core.endpoint.kv.KeyValueFeatureHandler”,“message”:“Requesting supported features: [TCPNODELAY, XATTR]”,“context”:“default”}
{“timestamp”:“2018-04-04T17:30:04.351Z”,“level”:“DEBUG”,“thread”:“cb-io-1-3”,“logger”:“com.couchbase.client.core.endpoint.kv.KeyValueFeatureHandler”,“message”:“Requesting supported features: [TCPNODELAY, XATTR]”,“context”:“default”}
{“timestamp”:“2018-04-04T17:30:04.501Z”,“level”:“DEBUG”,“thread”:“RxComputationScheduler-1”,“logger”:“com.couchbase.client.core.config.ConfigurationProvider”,“message”:“Explicitly closing bucket volatile1 after failed open attempt to clean resources.”,“context”:“default”}
{“timestamp”:“2018-04-04T17:30:04.501Z”,“level”:“DEBUG”,“thread”:“RxComputationScheduler-1”,“logger”:“com.couchbase.client.core.config.ConfigurationProvider”,“message”:“Removing bucket volatile1 configuration from known configs.”,“context”:“default”}
{“timestamp”:“2018-04-04T17:30:04.501Z”,“level”:“DEBUG”,“thread”:“RxComputationScheduler-1”,“logger”:“com.couchbase.client.core.RequestHandler”,“message”:“Got notified of a new configuration arriving.”,“context”:“default”}
{“timestamp”:“2018-04-04T17:30:04.501Z”,“level”:“DEBUG”,“thread”:“RxComputationScheduler-1”,“logger”:“com.couchbase.client.core.RequestHandler”,“message”:“Starting reconfiguration.”,“context”:“default”}
{“timestamp”:“2018-04-04T17:30:04.501Z”,“level”:“DEBUG”,“thread”:“RxComputationScheduler-1”,“logger”:“com.couchbase.client.core.RequestHandler”,“message”:“No open bucket found in config, disconnecting all nodes.”,“context”:“default”}
{“timestamp”:“2018-04-04T17:30:04.503Z”,“level”:“DEBUG”,“thread”:“RxComputationScheduler-1”,“logger”:“com.couchbase.client.core.RequestHandler”,“message”:“Got instructed to remove Node 1-1-14-155.company.com/1.1.14.155",“context”:"default”}
{“timestamp”:“2018-04-04T17:30:04.503Z”,“level”:“DEBUG”,“thread”:“RxComputationScheduler-1”,“logger”:“com.couchbase.client.core.node.Node”,“message”:"[1-1-14-155.company.com]: Got instructed to disconnect.",“context”:“default”}
{“timestamp”:“2018-04-04T17:30:04.507Z”,“level”:“DEBUG”,“thread”:“RxComputationScheduler-1”,“logger”:“com.couchbase.client.core.node.Node”,“message”:"[1-1-14-155.company.com]: Got instructed to disconnect.",“context”:“default”}
{“timestamp”:“2018-04-04T17:30:04.508Z”,“level”:“DEBUG”,“thread”:“RxComputationScheduler-1”,“logger”:“com.couchbase.client.core.node.Node”,“message”:"[1-1-14-155.company.com]: Instructing Service CONFIG to disconnect.",“context”:“default”}
{“timestamp”:“2018-04-04T17:30:04.508Z”,“level”:“DEBUG”,“thread”:“RxComputationScheduler-1”,“logger”:“com.couchbase.client.core.service.Service”,“message”:"[1-1-14-155.company.com][ConfigService]: Got instructed to disconnect.",“context”:“default”}
{“timestamp”:“2018-04-04T17:30:04.510Z”,“level”:“DEBUG”,“thread”:“RxComputationScheduler-1”,“logger”:“com.couchbase.client.core.node.Node”,“message”:"[1-1-14-155.company.com]: Instructing Service BINARY to disconnect.",“context”:“default”}
{“timestamp”:“2018-04-04T17:30:04.510Z”,“level”:“DEBUG”,“thread”:“RxComputationScheduler-1”,“logger”:“com.couchbase.client.core.service.Service”,“message”:"[1-1-14-155.company.com][KeyValueService]: Got instructed to disconnect.",“context”:“default”}
{“timestamp”:“2018-04-04T17:30:04.511Z”,“level”:“DEBUG”,“thread”:“RxComputationScheduler-1”,“logger”:“com.couchbase.client.core.service.Service”,“message”:"[1-1-14-155.company.com][KeyValueService]: New number of endpoints is 1",“context”:“default”}
{“timestamp”:“2018-04-04T17:30:04.512Z”,“level”:“DEBUG”,“thread”:“RxComputationScheduler-1”,“logger”:“com.couchbase.client.core.service.Service”,“message”:"[1-1-14-155.company.com][KeyValueService]: Disconnecting Endpoint during Service disconnect.",“context”:“default”}
{“timestamp”:“2018-04-04T17:30:04.522Z”,“level”:“DEBUG”,“thread”:“RxComputationScheduler-1”,“logger”:“com.couchbase.client.core.node.Node”,“message”:“Disconnected (CONNECTING) from Node 1-1-14-155.company.com/1.1.14.155",“context”:"default”}
{“timestamp”:“2018-04-04T17:30:04.526Z”,“level”:“DEBUG”,“thread”:“RxComputationScheduler-1”,“logger”:“com.couchbase.client.core.RequestHandler”,“message”:“Got instructed to remove Node 1-1-18-208.company.com/1.1.18.208",“context”:"default”}
{“timestamp”:“2018-04-04T17:30:04.581Z”,“level”:“DEBUG”,“thread”:“RxComputationScheduler-1”,“logger”:“com.couchbase.client.core.node.Node”,“message”:"[1-1-18-208.company.com]: Got instructed to disconnect.",“context”:“default”}
{“timestamp”:“2018-04-04T17:30:04.582Z”,“level”:“DEBUG”,“thread”:“RxComputationScheduler-1”,“logger”:“com.couchbase.client.core.node.Node”,“message”:"[1-1-18-208.company.com]: Got instructed to disconnect.",“context”:“default”}
{“timestamp”:“2018-04-04T17:30:04.583Z”,“level”:“DEBUG”,“thread”:“RxComputationScheduler-1”,“logger”:“com.couchbase.client.core.node.Node”,“message”:"[1-1-18-208.company.com]: Instructing Service CONFIG to disconnect.",“context”:“default”}
{“timestamp”:“2018-04-04T17:30:04.583Z”,“level”:“DEBUG”,“thread”:“RxComputationScheduler-1”,“logger”:“com.couchbase.client.core.service.Service”,“message”:"[1-1-18-208.company.com][ConfigService]: Got instructed to disconnect.",“context”:“default”}
{“timestamp”:“2018-04-04T17:30:04.584Z”,“level”:“DEBUG”,“thread”:“RxComputationScheduler-1”,“logger”:“com.couchbase.client.core.node.Node”,“message”:"[1-1-18-208.company.com]: Instructing Service BINARY to disconnect.",“context”:“default”}
{“timestamp”:“2018-04-04T17:30:04.588Z”,“level”:“DEBUG”,“thread”:“RxComputationScheduler-1”,“logger”:“com.couchbase.client.core.service.Service”,“message”:"[1-1-18-208.company.com][KeyValueService]: Got instructed to disconnect.",“context”:“default”}
{“timestamp”:“2018-04-04T17:30:04.588Z”,“level”:“DEBUG”,“thread”:“RxComputationScheduler-1”,“logger”:“com.couchbase.client.core.service.Service”,“message”:"[1-1-18-208.company.com][KeyValueService]: New number of endpoints is 1",“context”:“default”}
{“timestamp”:“2018-04-04T17:30:04.589Z”,“level”:“DEBUG”,“thread”:“RxComputationScheduler-1”,“logger”:“com.couchbase.client.core.service.Service”,“message”:"[1-1-18-208.company.com][KeyValueService]: Disconnecting Endpoint during Service disconnect.",“context”:“default”}
{“timestamp”:“2018-04-04T17:30:04.589Z”,“level”:“DEBUG”,“thread”:“RxComputationScheduler-1”,“logger”:“com.couchbase.client.core.node.Node”,“message”:“Disconnected (CONNECTING) from Node 1-1-18-208.company.com/1.1.18.208",“context”:"default”}
{“timestamp”:“2018-04-04T17:30:04.595Z”,“level”:“DEBUG”,“thread”:“RxComputationScheduler-1”,“logger”:“com.couchbase.client.core.RequestHandler”,“message”:“Got instructed to remove Node 1-1-12-243.company.com/1.1.12.243",“context”:"default”}
{“timestamp”:“2018-04-04T17:30:04.601Z”,“level”:“DEBUG”,“thread”:“RxComputationScheduler-1”,“logger”:“com.couchbase.client.core.node.Node”,“message”:"[1-1-12-243.company.com]: Got instructed to disconnect.",“context”:“default”}
{“timestamp”:“2018-04-04T17:30:04.601Z”,“level”:“DEBUG”,“thread”:“RxComputationScheduler-1”,“logger”:“com.couchbase.client.core.node.Node”,“message”:"[1-1-12-243.company.com]: Got instructed to disconnect.",“context”:“default”}
{“timestamp”:“2018-04-04T17:30:04.601Z”,“level”:“DEBUG”,“thread”:“RxComputationScheduler-1”,“logger”:“com.couchbase.client.core.node.Node”,“message”:"[1-1-12-243.company.com]: Instructing Service CONFIG to disconnect.",“context”:“default”}
{“timestamp”:“2018-04-04T17:30:04.601Z”,“level”:“DEBUG”,“thread”:“RxComputationScheduler-1”,“logger”:“com.couchbase.client.core.service.Service”,“message”:"[1-1-12-243.company.com][ConfigService]: Got instructed to disconnect.",“context”:“default”}
{“timestamp”:“2018-04-04T17:30:04.602Z”,“level”:“DEBUG”,“thread”:“RxComputationScheduler-1”,“logger”:“com.couchbase.client.core.node.Node”,“message”:"[1-1-12-243.company.com]: Instructing Service BINARY to disconnect.",“context”:“default”}
{“timestamp”:“2018-04-04T17:30:04.602Z”,“level”:“DEBUG”,“thread”:“RxComputationScheduler-1”,“logger”:“com.couchbase.client.core.service.Service”,“message”:"[1-1-12-243.company.com][KeyValueService]: Got instructed to disconnect.",“context”:“default”}
{“timestamp”:“2018-04-04T17:30:04.602Z”,“level”:“DEBUG”,“thread”:“RxComputationScheduler-1”,“logger”:“com.couchbase.client.core.service.Service”,“message”:"[1-1-12-243.company.com][KeyValueService]: New number of endpoints is 1",“context”:“default”}
{“timestamp”:“2018-04-04T17:30:04.603Z”,“level”:“DEBUG”,“thread”:“RxComputationScheduler-1”,“logger”:“com.couchbase.client.core.service.Service”,“message”:"[1-1-12-243.company.com][KeyValueService]: Disconnecting Endpoint during Service disconnect.",“context”:“default”}
{“timestamp”:“2018-04-04T17:30:04.651Z”,“level”:“DEBUG”,“thread”:“RxComputationScheduler-1”,“logger”:“com.couchbase.client.core.node.Node”,“message”:“Disconnected (CONNECTING) from Node 1-1-12-243.company.com/1.1.12.243",“context”:"default”}
{“timestamp”:“2018-04-04T17:30:06.148Z”,“level”:“DEBUG”,“thread”:“cb-io-1-3”,“logger”:“com.couchbase.client.core.endpoint.kv.KeyValueFeatureHandler”,“message”:“Negotiated supported features: [TCPNODELAY, XATTR]”,“context”:“default”}
{“timestamp”:“2018-04-04T17:30:06.148Z”,“level”:“DEBUG”,“thread”:“cb-io-1-3”,“logger”:“com.couchbase.client.core.endpoint.AbstractGenericHandler”,“message”:"[1-1-12-243.company.com/1.1.12.243:11210][KeyValueEndpoint]: Channel Active.",“context”:“default”}
{“timestamp”:“2018-04-04T17:30:06.151Z”,“level”:“DEBUG”,“thread”:“cb-io-1-2”,“logger”:“com.couchbase.client.core.endpoint.Endpoint”,“message”:"[null][KeyValueEndpoint]: Explicitly breaking retry loop because already disconnected.",“context”:“default”}
{“timestamp”:“2018-04-04T17:30:06.151Z”,“level”:“DEBUG”,“thread”:“cb-io-1-2”,“logger”:“com.couchbase.client.core.endpoint.Endpoint”,“message”:"[null][KeyValueEndpoint]: Explicitly breaking retry loop because already disconnected.",“context”:“default”}
{“timestamp”:“2018-04-04T17:30:06.151Z”,“level”:“DEBUG”,“thread”:“cb-io-1-4”,“logger”:“com.couchbase.client.core.endpoint.Endpoint”,“message”:"[1-1-12-243.company.com/1.1.12.243:8091][ConfigEndpoint]: Connected Endpoint.",“context”:“default”}
{“timestamp”:“2018-04-04T17:30:06.220Z”,“level”:“DEBUG”,“thread”:“cb-io-1-2”,“logger”:“com.couchbase.client.core.endpoint.kv.KeyValueFeatureHandler”,“message”:“Negotiated supported features: [TCPNODELAY, XATTR]”,“context”:“default”}
{“timestamp”:“2018-04-04T17:30:06.220Z”,“level”:“DEBUG”,“thread”:“cb-io-1-2”,“logger”:“com.couchbase.client.core.endpoint.AbstractGenericHandler”,“message”:"[1-1-18-208.company.com/1.1.18.208:11210][KeyValueEndpoint]: Channel Active.",“context”:“default”}
{“timestamp”:“2018-04-04T17:30:06.220Z”,“level”:“DEBUG”,“thread”:“cb-io-1-2”,“logger”:“com.couchbase.client.core.endpoint.AbstractGenericHandler”,“message”:"[1-1-18-208.company.com/1.1.18.208:8091][ConfigEndpoint]: Channel Active.",“context”:“default”}
{“timestamp”:“2018-04-04T17:30:08.151Z”,“level”:“WARN”,“thread”:“RxComputationScheduler-3”,“logger”:“com.couchbase.client.core.endpoint.Endpoint”,“message”:"[null][ConfigEndpoint]: Socket connect took longer than specified timeout.",“context”:“default”}
{“timestamp”:“2018-04-04T17:30:08.152Z”,“level”:“WARN”,“thread”:“RxComputationScheduler-3”,“logger”:“com.couchbase.client.core.endpoint.Endpoint”,“message”:“Error during reconnect: “,“context”:“default”,“exception”:“com.couchbase.client.deps.io.netty.channel.ConnectTimeoutException: Connect callback did not return, hit safeguarding timeout.\n\tat com.couchbase.client.core.endpoint.AbstractEndpoint$3.call(AbstractEndpoint.java:337)\n\tat com.couchbase.client.core.endpoint.AbstractEndpoint$3.call(AbstractEndpoint.java:330)\n\tat rx.internal.operators.SingleOperatorOnErrorResumeNext$2.onError(SingleOperatorOnErrorResumeNext.java:69)\n\tat rx.Single$18.onError(Single.java:1883)\n\tat rx.observers.SafeSubscriber._onError(SafeSubscriber.java:152)\n\tat rx.observers.SafeSubscriber.onError(SafeSubscriber.java:115)\n\tat rx.observers.SerializedObserver.onError(SerializedObserver.java:153)\n\tat rx.observers.SerializedSubscriber.onError(SerializedSubscriber.java:78)\n\tat rx.internal.operators.OperatorTimeoutBase$TimeoutSubscriber$1.onError(OperatorTimeoutBase.java:187)\n\tat rx.Single$1$1.onError(Single.java:85)\n\tat rx.Single$3.call(Single.java:505)\n\tat rx.Single$3.call(Single.java:501)\n\tat rx.Single$1.call(Single.java:90)\n\tat rx.Single$1.call(Single.java:70)\n\tat rx.Observable.unsafeSubscribe(Observable.java:9860)\n\tat rx.internal.operators.OperatorTimeoutBase$TimeoutSubscriber.onTimeout(OperatorTimeoutBase.java:200)\n\tat rx.internal.operators.OperatorTimeout$1$1.call(OperatorTimeout.java:41)\n\tat rx.internal.schedulers.EventLoopsScheduler$EventLoopWorker$2.call(EventLoopsScheduler.java:189)\n\tat rx.internal.schedulers.ScheduledAction.run(ScheduledAction.java:55)\n\tat java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)\n\tat java.util.concurrent.FutureTask.run(FutureTask.java:266)\n\tat java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$201(ScheduledThreadPoolExecutor.java:180)\n\tat java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:293)\n\tat java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)\n\tat java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)\n\tat java.lang.Thread.run(Thread.java:745)\n”}
{“timestamp”:“2018-04-04T17:30:08.152Z”,“level”:“DEBUG”,“thread”:“RxComputationScheduler-3”,“logger”:“com.couchbase.client.core.endpoint.Endpoint”,“message”:”[null][ConfigEndpoint]: Not retrying because already disconnected or transient.”,“context”:“default”}


#5

“com.couchbase.client.deps.io.netty.channel.ConnectTimeoutException: Connect callback did not return, hit safeguarding timeout"

This happens because during the initial connect phase the actual call didn’t complete in the given time interval. Usually this is because some operation (socket connect, auth, bucket selection…) or the combination took longer than the specified connect timeout.


#6

Needed to compose one simple word yet thanks for the suggestions that you are contributed here, I hope it will be fixed in Couchbase Core 1.6.0 / Java client 2.6.0.


#7

As you can see in the JVMCBC referenced above, it was closed as there is a fix on the cluster side. You should be good as of Couchbase Server 6.0!