Scan-cap is set to 0, but still see scan-backfills in query logs

n1ql

#1

Hi,

I’ve been noticing higher CPU usage in query service, so I started investigating. Only thing I noticed is that I see a lot of backfill file logs from query.log.

I checked “scan-cap” value according to https://developer.couchbase.com/documentation/server/current/settings/query-settings.html and confirmed that it is set to 0 (disabled).

  1. Is it expected to see scan backfill activities when scan-cap is set to 0 ?
  2. Is there a way to find out which query is getting backfilled? I’ve made sure that my query results are within reasonable size.

Thanks!


#2

scan-cap <=0 makes it default value 512. DOC-3795

Set high value. cc @deepkaran.salooja is there any way disable backfill from indexer side.

In 5.5 https://developer.couchbase.com/documentation/server/5.5/settings/cluster-settings.html
Query Temp Disk Path Quota 0 makes it disable

Check system:completed_requests for high PhaseCounts for IndexScan


#3

Thank you so much. I had no idea CB 4.5 had such features. That’s really nice to have :slight_smile:


#4

scan_cap is only 5.0 feature


#5

Oh no…I meant those monitoring features. I thought those were new to 5. I did not know they were in 4.5.


#6

In 4.5 monitoring is through queries. In 5.0 Enhanced monitoring, added profiling are integrated with Query Workbench. cc @marcoeg

https://blog.couchbase.com/optimize-n1ql-performance-using-request-profiling/


#7

In 5.0, backfill can be disabled by setting “queryport.client.settings.backfillLimit” to 0 using the indexer setting url.