Server CPU usage goes to 100%


#1

Hello,

We have moved our DB from Sql Server to Couchebase, now we are facing the one problem that our Asp.Net W3WP process takes 98% cpu and application hang,below is server and couche db information.

Application was developed using Asp.Net c#.

Coucbase SDK version : 1.3.0
Cocubase Server : 2.2

We have 3 cluster node and all have Windows 2012 Server OS.

Any help would be appreciate.

Thanks!
Jatin


#2

I do not have specify any connection time out in my configuration file.
is it required to specify?
If yes then

what is best value to specify for connectionTImeOut and deadTimeOut?


#3

Hi Jatin, have you profiled your asp.net application to know where the cpu cycles are spent?
thanks
-cihan


#4

Hello cihan ,
First thanks for your support,

I just want to add additional information,our CPU usage always not goes to 100%,it reaches sometime to 100% and that time 98% CPU taken by W3WP,that was not happening with SQL.

I also want to asked is there any kind of setting required like connection timout or not?

As you have asked “have you profiled your asp.net application to know where the cpu cycles are spent?”.

Sorry to say but i do not know how to measure it,so i will google it check and let you know.


#5

Hi Jatin -

A couple suggestions:

  • Update your client to the latest if you can: 1.3.6 at time of writing: http://docs.couchbase.com/couchbase-sdk-net-1.3/#release-notes-for-couchbase-client-library-net-136-ga-5-june-2014
  • Ensure you are following best practices for instantiating clients per: http://docs.couchbase.com/couchbase-sdk-net-1.3/#instantiating-the-client
  • Configure logging if you can and provide logs so we can help pinpoint the issue (if it's the Couchbase Client): http://docs.couchbase.com/couchbase-sdk-net-1.3/#configuring-logging
  • You can configure the socketPool element using the parameters defined here: http://docs.couchbase.com/couchbase-sdk-net-1.3/#configuring-the-net-client-library

With respect to the last bullet point, the default settings are generally good for most scenarios. The TCP connections in the client are long-lived and pooled - this important for performance/resource reasons.

Hopefully this helps,

-Jeff


#6

HI,

I’ve found the same problem doing load tests in a asp.net api that uses couchbase.

did you manage to find a reason or a fix for that?

Regards,

Hector


#7

Are you able to repro this issue with 2.5.x or 3.0 (Windows beta?)

Thanks,
Don


#8

Can you please clarify if you see 100% CPU on the Couchbase Server machines or on the application servers? Also, a little more context would be helpful (what type of ops performed, was the cluster ongoing some changes?). If it’s the server side, please share cbcollect_info data in an MB ticket (I assume you are not having paid support? If so, please contact our support instead).