Sigar_port running at 25% on 4 core (ie, 100% on 1 core)


#1

Been running 3.0.2 for a while and although the development machine (Windows 8.1 64bit) does not seem to be sluggish, the sigar_port.exe is always running at 100% on 1 core (Taskmgr shows 25% on 4 core CPU)

Today, I installed 3.0.3 and after the install it restarted backup and reached 25% again, along with memcached.exe which reached 50% (presumably running 100% on 2 cores).

I restarted the Couchbase service and memcached returned to normal, but sigar_port still runs at 25%.

Not entirely sure whether it is something to be concerned about or not.


#2

sigar_port is the component that manages a process which looks at system resources, like CPU and memory. sigar is a separate open source project. I think the best thing would be to upload a collect info (which you can do from within the UI) and then update this issue. It looks like we’ve had difficulty reproducing it.


#3

I know this is an old topic but I’m able to reproduce this issue. It is in fact very simple. Do not use a dedicated machine to host Couchbase, instead use a developer computer for instance with many services installed and many process running concurrently.

For instance, I have 195 process running on my computer with 4 CPU and 16Gb of RAM.
This probably is a very uncommon scenario for a typical Couchbase production server.

I think the best thing to do is to allow this component to be deactivated or started on demand. I understand that it is used to display useful informations in the Couchbase console.