Sync Gateway config with Couchbase Server 5.0



I was using Couchbase Server 4.6.2 with Sync Gateway 1.4 and everything was working fine. I upgraded to Couchbase Server 5.0 with Sync Gateway 1.4.1 (last release) and I cannot open the database, I created a bucket named default and my config file is really simple :

{ "log": ["*"], "databases": { "db": { "server" : "http://localhost:8091", // reachable with curl "bucket": "default", "users: { "GUEST" : { "disabled": false, "admin_channels": ["*"] }} } } }

It is written in Debug’s logs : RetryLoop retrying Attempt to connect to bucket default on … as user "default"
I think that the problem come from the “as user “default”” because it doesn’t exist to me.



This looks like the same issue reported here:

Which has been fixed by this PR:

If you would like to test this fix before the next SG release you will need to build Sync Gateway from source on latest master using the extended build instructions.


Thanks for the reply. Indeed with the build from source on latest master it works fine.
Some of the tests failed but it’s working fine for now.