Sync gateway issue


#1

i am downloading sync gateway from the link:
http://www.couchbase.com/dl/releases/couchbase-sync-gateway/1.1.0/couchbase-sync-gateway-enterprise_1.1.0-28_x86_64.exe
i have installed it on my machine and its working. but i installed it on an other 32- bit machine but its showing
error:
this version is not compatible with the version of windows your running. check your computer`s system iformation to see whether you need a x89(32 bit) or x64 (64bit ) version if the program,


#2

Hey @zeeshan_niazi,

What version of Windows are you using (Vista, 7, 8, 10, etc.)? The machine it works on, is it the same version?

Best,


#3

no, i am running windows 8, and other machine is running windows 7.


#4

Hey @zeeshan_niazi,

Which version of Windows are you having issues on just so we can rule things out.

Best,


#5

Hey @zeeshan_niazi,

After further investigation with one of our mobile engineers, @zgramana, there is no 32-bit version of the Sync Gateway for Windows at this time. The x86_64 in the URL is referring to 64-bit only.

Best,


#6

Hi nraboy,

I am working in connecting from one sync gateway to another sync gateway, second sync gateway configured to connect database. Please suggest me to configure from one sync gateway(windows) to another sync gateway(Linux).

Architecture:
SyncGateway(Windows)---->SyncGateway(Linux)---->Couchbase Server.

Configuration:
SyncGateway(Windows)-Config file

{
“log”:[“CRUD+”, “REST+”, “Changes+”, “Attach+”],
“databases”: {
“sample”: {
“server”:“http://hostaddress:4984/”,
“sync”:function (doc) { channel (doc.channels); },
“users”: {
“GUEST”: {
“disabled”: false,
“admin_channels”: ["*"]
}
}
}
}
}

SyncGateway(Linux)-Config File:
{
“log”:[“CRUD+”, “REST+”, “Changes+”, “Attach+”],
“databases”: {
“sample”: {
“server”:“http://sever-addr:8091/”,
“sync”:function (doc) { channel (doc.channels); },
“users”: {
“GUEST”: {
“disabled”: false,
“admin_channels”: ["*"]
}
}
}
}
}

I am getting the following error when I tried to run config file(Sync Gateway) on Windows machine.

ERROR:
C:\Program Files (x86)\Couchbase>sync_gateway.exe config.json
2016-02-06T13:09:24.970+05:30 Enabling logging: [CRUD+ REST+ Changes+ Attach+]
2016-02-06T13:09:24.975+05:30 ==== Couchbase Sync Gateway/1.2.0(83;5740bb3) ====
2016-02-06T13:09:24.978+05:30 Opening db /sample as bucket “sample”, pool “default”, server http://192.168.244.176:4984/
2016-02-06T13:09:24.984+05:30 Opening Couchbase database sample on http://192.168.244.176:4984/
2016-02-06T13:09:24.991+05:30 FATAL: Error opening database: 502 Unable to connect to Couchbase Server (connection refused). Please ensure it is running and reachable at the configured host and port. Detailed error: HTTP error 404 Not Found getting “http://192.168.244.176:4984/pools”: {“error”:“not_found”,“reason”:“no such database “pools””} – rest.RunServer() at config.go:644

Please help me on this. Thanks in Advance.