Sync Gateway Web Admin UI not showing any data but REST calls do


#1

We are using Couchbase Community Edition Server 6.0 and Sync Gateway 2.1.1. When viewing the Sync Gateway Admin UI it returns no user data. It lists channels and I can access documents by ID (although it shows ‘0 documents highlighted’ on the UI)
Yet via the REST calls to the same server, it does return users

Any idea why this might happen?

Sync Gateway Config
“interface”:":4984",
“adminInterface”:":4985",
“log”: [ “CRUD”, “CRUD+”, “HTTP”, “HTTP+”, “Access”, “Cache”, “Shadow”, “Shadow+”, “Changes”, “Changes+”, “REST” ],
“databases”: {
“primary”: {
“server”: “http://SOMEIP:8091”,
“sync”:
function(doc, oldDoc) { var sync_channels = [doc.cb_type]; if(doc.cb_channels) { sync_channels = doc.cb_channels.split(","); sync_channels = sync_channels.filter(function(e){return e}); } channel(sync_channels); },
“username”:“user”,
“password”:“pass”,
“bucket”:“primary”,
“enable_shared_bucket_access”: true,
“num_index_replicas” : 0,
“import_docs”: “continuous”,
“users”: {
“primary”:{
“disabled”:true,
“admin_channels”: ,
“password”: “somepass”
}
}
}
}


#2

@ruaanv, Could you let me know what is the url you are using to access sync gateway admin UI?


#3

The Sync Gateway admin UI is an unofficial project that is not actively maintained by the Engineering team. To that end, efforts to keep it working with the latest version of Sync Gateway have not been a priority. So I am not surprised if you are seeing issues with the latest version.
I would not recommend relying on it (It is more of a demonstration vehicle ) . Please use the REST API for testing purposes.


Empty list of users in sync gateway admin interface
#4

The url I tried was ip:4985/_admin/


#5

Okay thanks @priya.rajagopal, I was just worried that we had something set up wrong. Will stick to the rest calls for now.