Sync Gateway with Ubuntu 16.04 LTS

#1

Hello,

Considering the new Ubuntu 16.04 is a LTS, I assumed the sync gateway install script would support it, but it doesn’t.

Recent Ubuntu versions are using systemd, so I used CentOS 7 script (which uses systemd) and it almost worked: I just needed to create the /var/lib/systemd/system directory and change the systemd service file (/usr/lib/systemd/system/sync_gateway.service) replacing /usr/bin/bash for /bin/bash.

I think it’d be useful to support it by default, changing the sync gateway install script accordingly.

#2

@renato

Thanks for the feedback, I have created a new ticket to track this.