SyncGateway AdminUI not accessible from remote machine


#1

Hi,

I installed Couchbase Sync Gateway on an Azure VirtualMachine, I am able to use the url.cloudapp.net:4984 interface, and the url.cloudapp.net:4985 admin interface, yet I can’t access the Admin UI web interface at url.cloudapp.net:4985/_admin from my local machine.

This is the config I use

{
        "log": ["HTTP+"],
        "adminInterface": ":4985",
        "interface": ":4984",
        "databases": {
                "timnet": {
                        "server": "http://localhost:8091",
                        "bucket": "timnet",
                        "users": {
                                "GUEST": {"disabled": false, "admin_channels": ["*"] }
                        },
                        "sync":`function(doc) {channel(doc.channels);}`
                }
        }
}

#2

Admin port only accessible from 127.0.0.1, see also.


#3

Hmm are you sure? I can access the REST API but not the web interface, there must be someway to enable it. Maybe it was not bundled in the sync gateway ?


#4

yes, see also.


#5

It’s not correct that the Admin Port is only accessible from localhost, if you’ve got the adminInterface property set in your config file (which you do). You should be able to access the endpoint as described, as long as the port is enabled on your VM.

What kind of error are you getting? If it’s a JSON not_found/unknown URL payload, you might just be missing the trailing slash on :4985/_admin/.